Ubuntu

software-center crashed with SIGABRT in __assert_fail_base()

Reported by keestux on 2012-02-22
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

This is on a MacMini (!) with two screens attached

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.9
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.92-0ubuntu1
Architecture: amd64
Date: Wed Feb 22 15:07:22 2012
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: software-center
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
Title: software-center crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to precise on 2012-02-22 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

keestux (kees-bakker-xs4all) wrote :

StacktraceTop:
 __assert_fail_base (fmt=<optimized out>, assertion=0x7fd5f0c3cad8 "!xcb_xlib_threads_sequence_lost", file=0x7fd5f0c3cd92 "../../src/xcb_io.c", line=<optimized out>, function=<optimized out>) at assert.c:94
 __GI___assert_fail (assertion=0x7fd5f0c3cad8 "!xcb_xlib_threads_sequence_lost", file=0x7fd5f0c3cd92 "../../src/xcb_io.c", line=273, function=0x7fd5f0c3ceb8 "poll_for_event") at assert.c:103
 poll_for_event (dpy=<optimized out>) at ../../src/xcb_io.c:270
 poll_for_response (dpy=0xd76d50) at ../../src/xcb_io.c:288
 _XEventsQueued (dpy=0xd76d50, mode=<optimized out>) at ../../src/xcb_io.c:362

Changed in software-center (Ubuntu):
importance: Undecided → Medium
summary: - software-center crashed with SIGABRT in raise()
+ software-center crashed with SIGABRT in __assert_fail_base()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) wrote :

This does not look like a software-center issue to me but more a fundamental problem with X or gtk.

Did you managed to reproduce this error?

Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
visibility: private → public

Op 2012-04-18 15:54 , Michael Vogt schreef:
> This does not look like a software-center issue to me but more a
> fundamental problem with X or gtk.
>
> Did you managed to reproduce this error?
>
> ** Changed in: software-center (Ubuntu)
> Status: Confirmed => Incomplete
>
> ** Visibility changed to: Public
>
No, it hasn't happened anymore. It's fine with me to
get rid of the report.
--
Kees

Gary Lasker (gary-lasker) wrote :

Hi keestux, thanks for getting back to us! Based on your comment #7, I'll close this bug. If anybody encounters this again with software-center 5.2 or later in current Precise, please be sure to reopen and comment here.

Thanks very much for your help!

Changed in software-center (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers