software-center crashed with AttributeError in pkg_downloaded(): 'NoneType' object has no attribute 'filename'

Bug #936262 reported by Kostas Kapatos on 2012-02-19
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Michael Vogt

Bug Description

I was just trying to install "Utilities Lens - Calculator" and crashed.

Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/appdetailsview.py", line 2008, in update_totalsize
    self.app.archive_suite)
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/aptcache.py", line 585, in get_total_size_on_install
    if not pkg_downloaded(pkg) and not pkg.package.installed:
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/aptcache.py", line 58, in pkg_downloaded
    filename = os.path.basename(pkg_version.filename)
AttributeError: 'NoneType' object has no attribute 'filename'

As at 2012-04-27 this is the #4 top crash in Ubuntu.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.9
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Sun Feb 19 16:49:42 2012
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with AttributeError in pkg_downloaded(): 'NoneType' object has no attribute 'filename'
UpgradeStatus: Upgraded to precise on 2012-02-19 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Kostas Kapatos (k-kapatos) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
description: updated
Changed in software-center (Ubuntu):
importance: Undecided → High
visibility: private → public
Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
milestone: none → precise-updates
status: Confirmed → In Progress
Gary Lasker (gary-lasker) wrote :

This one was fixed by mvo and the fix is in the upcoming 5.2.1 version of software-center that is currently in precise-proposed. It should be released within a few days.

Thanks!

Changed in software-center (Ubuntu):
assignee: Gary Lasker (gary-lasker) → Michael Vogt (mvo)
status: In Progress → Fix Committed
Michael Vogt (mvo) on 2012-09-13
Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers