software-center not work in fluxbox (without policykit-agent running?)

Bug #932416 reported by Pavlo Bohmat on 2012-02-14
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

software-center support only unity? in fluxbox runs, but nothing works.

2012-02-15 00:52:02,001 - softwarecenter.ui.gtk3.em - INFO - EM's: 18 14 21
2012-02-15 00:52:02,314 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2012-02-15 00:52:02,368 - softwarecenter.ui.gtk3.utils - INFO - Softwarecenter style provider for ambiance Gtk theme: /usr/share/software-center/ui/gtk3/css/softwarecenter.css

Gtk-WARNING **: Theme parsing error: softwarecenter.css:17:19: Not using units is deprecated. Assuming 'px'.
...
Gtk-WARNING **: Theme parsing error: softwarecenter.css:65:19: Not using units is deprecated. Assuming 'px'.
2012-02-15 00:52:04,115 - softwarecenter.backend.spawn_helper - WARNING - exit code 1 from helper
2012-02-15 00:52:04,115 - softwarecenter.backend.spawn_helper - WARNING - got error from helper: 'WARNING:__main__:Unable to find the server at recommender.ubuntu.com
'
2012-02-15 00:52:04,115 - softwarecenter.db.categories - WARNING - Error while accessing the recommender service: WARNING:__main__:Unable to find the server at recommender.ubuntu.com

2012-02-15 00:52:04,115 - softwarecenter.ui.gtk3.views.catview_gtk - WARNING - Error while accessing the recommender agent: WARNING:__main__:Unable to find the server at recommender.ubuntu.com

Gdk-WARNING **: /build/buildd/gtk+3.0-3.3.14/./gdk/x11/gdkwindow-x11.c:4873 drawable is not a native X11 window

Gdk-WARNING **: /build/buildd/gtk+3.0-3.3.14/./gdk/x11/gdkwindow-x11.c:4873 drawable is not a native X11 window

Gdk-WARNING **: /build/buildd/gtk+3.0-3.3.14/./gdk/x11/gdkwindow-x11.c:4873 drawable is not a native X11 window
2012-02-15 00:52:34,487 - softwarecenter.ui.gtk3.app - INFO - software-center-agent finished with status 0

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.8
ProcVersionSignature: Ubuntu 3.2.0-15.24-generic 3.2.5
Uname: Linux 3.2.0-15-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Wed Feb 15 00:56:07 2012
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=ru_UA.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: Upgraded to precise on 2012-02-10 (4 days ago)

Pavlo Bohmat (bohm) wrote :
Matthew Paul Thomas (mpt) wrote :

Ubuntu Software Center is not Unity-specific. I use it in XFCE and it works just fine.

So, please be more specific about "nothing works". Does the window open? Can you navigate to an application screen? Can you click the "Install" button? Please provide steps to reproduce the problem, what happens, and what you expected to happen. Thanks.

Changed in software-center (Ubuntu):
status: New → Incomplete
Pavlo Bohmat (bohm) wrote :

Localfile (nautilus+fluxbox or firefox+apt-url) can not be install because they do not ask for a password as root (gdebi: OK)
Install/Remove button is clickable, but it does nothing, even no error reports.

Gtk-WARNING **: Unknown property: GtkGrid.n-columns
2012-03-12 13:42:54,877 - softwarecenter.backend - WARNING - _on_trans_error: org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name': ':1.144'}): org.debian.apt.install-or-remove-packages

If you use in terminal 'gksu software-center' work, but from the Nautilus and the browser is not caused by the terminal and the USC.
In any case, does not work "Write your own review" - when pressed, nothing happens.
There is no way to update the package list (need 'sudo apt-get update' or synaptic)

Changed in software-center (Ubuntu):
status: Incomplete → New
Changed in software-center (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please check if you have a process called "/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1" ?
E.g. via
$ ps afx|grep policykit

It looks like there is no authentication agent in your session running.

Changed in software-center (Ubuntu):
status: Triaged → Incomplete
summary: - software-center not work in fluxbox
+ software-center not work in fluxbox (without policykit-agent running?)
Pavlo Bohmat (bohm) wrote :

~$ ps afx|grep policykit
25339 pts/1 S+ 0:00 \_ grep policykit
 1354 ? Sl 0:00 /usr/lib/policykit-1/polkitd --no-debug

~$ /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1

(polkit-gnome-authentication-agent-1:25519): GLib-CRITICAL **: g_variant_new_string: assertion `string != NULL' failed

(polkit-gnome-authentication-agent-1:25519): polkit-gnome-1-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

Markus Naeher (kubuntu-user) wrote :

I have a similar problem in Xubuntu 12.04: synaptic, gparted etc ... are no mor startable from the menu. Starting /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 gives the same error message as above.

I have 2 AMD64 PC's and an i386 Laptop. The problem occurs on one of the PC's and the Laptop.
Before I found this bug report, I already had opened my own one:
It's Bug #976638.

Pavlo Bohmat (bohm) wrote :

after /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
....#5

~$ pkexec software-center
** (software-center:19467): WARNING **: Command line `dbus-launch --autolaunch=88bf69b62e8e1077f3c30fbd4c24e436 --binary-syntax --close-stderr' exited with non-zero exit status 1: Autolaunch error: X11 initialization failed.\n
Traceback (most recent call last):
  File "/usr/bin/software-center", line 25, in <module>
    from gi.repository import Gtk, GObject
  File "/usr/lib/python2.7/dist-packages/gi/importer.py", line 76, in load_module
    dynamic_module._load()
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 224, in _load
    overrides_modules = __import__('gi.overrides', fromlist=[self._namespace])
  File "/usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py", line 1517, in <module>
    raise RuntimeError("Gtk couldn't be initialized")
RuntimeError: Gtk couldn't be initialized

Full FAIL!

Markus Naeher (kubuntu-user) wrote :

As I am affected by the "root cause" in a similar way, can I help fixing the "incomplete" status ?

Changed in software-center (Ubuntu):
status: Incomplete → New
Changed in software-center (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers