Ubuntu

The action button does not have initial focus in the appdetails view

Reported by Gary Lasker on 2012-02-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Gary Lasker

Bug Description

software-center version 5.1.7, The Precise Pangolin

As reported by the indefatigable Mr. Dave Morley, the action button ("Install"/"Remove") does not have initial focus when the application details view is displayed.

To reproduce:

1. Open software-center and navigate to the details view for any app.
2. Observe that the "Install"/"Remove" button does not have focus.

Changed in software-center (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.8

---------------
software-center (5.1.8) precise; urgency=low

  [ Michael Vogt ]
  * softwarecenter/db/update.py:
    - trivial fix to skip unreadable app-install-data files
  * lp:~mvo/software-center/device-profiles:
    - implement the hardware-requirements display in
      the detailsview
  * lp:~mvo/software-center/arb-partner-channels:
    - add support for extras.ubuntu.com and archive.canonical.com
      channel detection and adding via software-center-agent
  * data/software-center.menu.in:
    - do not show "X-Publishing" in education because the
      software-center-agent will send "X-Publishing;Education" for
      compatibility with the old clients
  * lp:~mvo/software-center/fix-cachedir-for-public-api:
    - add missing cachedir argument
  * lp:~mvo/software-center/region-support:
    - add support for a region tag and display a warning to
      the user if an application is not suitable for their
      region

  [ Brendan Donegan ]
  * lp:~brendan-donegan/software-center/test_utils_get_nice_date_string:
    - add a test function in test_utils.py which covers all of
      get_nice_date_string

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/launcher-integration-lp761851:
    - update to the Unity launcher integration implementation to
      support the revamped functionality on the Unity side (LP: #761851)
  * lp:~gary-lasker/software-center/recommends-ui-lobby:
    - initial recommends UI implementation, limited to non-personalized
      recommends currently
  * lp:~gary-lasker/software-center/appdetailsview-button-focus-fix:
    - make sure the action button in the applications details view
      always gets the initial focus (LP: #925613)
 -- Michael Vogt <email address hidden> Fri, 03 Feb 2012 18:34:43 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers