Purchased items are not being added to the Unity launcher

Bug #925014 reported by Dave Morley on 2012-02-01
70
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Bilal Akhtar
5.0
Fix Released
High
Bilal Akhtar
software-center (Ubuntu)
High
Gary Lasker
Precise
High
Gary Lasker
unity (Ubuntu)
High
Bilal Akhtar
Precise
High
Unassigned

Bug Description

Ubuntu Software Center 5.1.14.1, the Precise Pangolin, beta 2
Unity 5.8.0-0ubuntu2

[Test Case]
1. Launch the current Ubuntu Software Center in Precise.
2. Click the down arrow in the toolbar next to the "All Software" button, and choose the "For Purchase" item.
3. In the list of displayed items for purchase, choose an application (but *not* a magazine or book) that is free (that is, marked as $0 -- unless you wish to purchase something).
4. Click the "More Info" button.
5. In the details view for the application, click the "Buy" button.
6. Follow the purchase process. For a $0 item, you will not be prompted for payment information.
7. Enter the password for the install when prompted.
8: The progress bar activates in Software Center. Note that for purchased items, it can take a bit of time before the progress bar transitions from intdeterminate to determinate.
9: At the very *end* of the installation process (when the progress bar has completed), verify that no icon for the installed purchase item has been added to the Unity launcher.
10. Close Ubuntu Software Center.
11. Update to both the software-center *and* unity packages in precise-proposed.
12. Repeat steps 1 through 8.
13. This time, at the very *end* of the install process, verify that the corresponding icon "flies" to the Unity launcher and is added there.
14. Click the launcher icon and verify that the newly installed application launches.

[Regression Potential]
Risk of regression is very low. Probably the only thing you might watch for would be an unexpected exception reported. If anything like this occurs, of course, please note it in the bug.

---

Bug Description:

Update: With the most recent version of Unity, 5.8.0-0ubuntu2, and Software Center version 5.1.14.1, *no* purchased apps are being installed to the Unity launcher upon installation.

Previous description from the esteemed Mr. Davmor2:

I have install 6 perviously purchase apps of the 6 only 3 have displayed in the app launcher.

In App Launcher:
Braid, Darwinia, family farm

Not In Launcher:
Full Circle Magazine, spacechem, steel storm 2:

Steel storm has an issue on newer versions with the : in it's name so that may be why it failed to appear

Version:
n/a

OS:
64bit Precise

USC Version:
5.1.7

Steps To Reproduce:
1. Open USC
2. install the apps from previous purchases

Expected Results:
I expect all of the applications to appear in the launcher or none of them.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.7
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Wed Feb 1 17:59:01 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120117)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: Upgraded to precise on 2012-01-28 (4 days ago)

Related branches

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
importance: Undecided → Medium
Dave Morley (davmor2) wrote :
summary: - Some apps are not showing up in applauncher
+ Some previously purchase items are not being added to the Unity launcher
Changed in software-center (Ubuntu):
status: New → Triaged
summary: - Some previously purchase items are not being added to the Unity launcher
+ Purchased items are not being added to the Unity launcher
Changed in software-center (Ubuntu):
milestone: none → ubuntu-12.04
description: updated
Gary Lasker (gary-lasker) wrote :

The problem appears to stem from the fact that the agent sends the value "software-center-agent" for the desktop file name, and this is not a real desktop file. Initial code in the attached branch, I'll dig in and find a fix for this.

Changed in software-center (Ubuntu):
status: Triaged → In Progress
Michael Vogt (mvo) on 2012-04-18
Changed in software-center (Ubuntu):
milestone: ubuntu-12.04 → precise-updates
Michael Vogt (mvo) on 2012-05-09
tags: added: ca-escalated
Changed in software-center (Ubuntu):
importance: Medium → High
no longer affects: unity (Ubuntu)
Changed in unity (Ubuntu):
assignee: nobody → Bilal Akhtar (bilalakhtar)
Gary Lasker (gary-lasker) wrote :

It appears that this bug is due to at least in large part to a regression on the Unity side that appeared very late in the cycle. I've opened a separate bug 999427 for that. The issue is that the file path conversion for the desktop file from the app-install path to the actual installed location is no longer being done. Please refer to the description for bug 999427 that includes a snippet of Python code that we used to use in Software Center to do this previously (before the full integration was complete on the Unity side).

Since apps for purchase do not have desktop files in app-install-data desktop , the key is to simply use the package name itself to look up a desktop file in the installed directory (/usr/share/applications) once the installation has completed. Please refer to the code snippet in the description for bug 999427 for this.

Gary Lasker (gary-lasker) wrote :

Hello Bilal! Please note that I added you as the assignee for the Unity part of this fix (and please refer to bug 999427 for details on that). Feel free to reassign as needed and of course, please don't hesitate to let me know if there's anything I can do to help.

Many thanks!

David Pitkin (dpitkin) on 2012-05-21
Changed in unity (Ubuntu):
importance: Undecided → High
Michael Vogt (mvo) on 2012-05-21
Changed in unity (Ubuntu):
status: New → Triaged
David Pitkin (dpitkin) on 2012-05-21
Changed in unity (Ubuntu):
milestone: none → ubuntu-12.04.1
Michael Vogt (mvo) on 2012-05-21
Changed in unity (Ubuntu):
milestone: ubuntu-12.04.1 → precise-updates
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: New → In Progress
importance: Undecided → High
milestone: none → 5.14.0
assignee: nobody → Bilal Akhtar (bilalakhtar)
Bilal Akhtar (bilalakhtar) wrote :

As decided between Gary and me, it's architecturally not possible to send the icon flying to the launcher before installation, for two reasons: 1) We don't have a desktop file to feed BAMF on, and 2) The icon is not stored locally, but rather generated from the server.

It would be possible to fix it and still allow icons to be sent to the launcher before installation, but that would mean basing the icon on a different desktop file and modifying the icon/name to that of the app. Also, SC would have to store the icon in /tmp or somewhere so that Unity can read it. And, the icon's UpdateDesktopFile could be called to change the desktop file on-the-fly to prevent any duplication issues in the launcher.

Rather, we've decided on an alternative solution for a Precise SRU: Send icons AFTER installation is complete. That would need a few one-line changes on the Unity side, which are part of the linked branch which I'm proposing for the next SRU. Meanwhile, Gary is working on the SC side (thanks a lot for that!)

Changed in unity:
milestone: 5.14.0 → 6.0

Hey Bilal,

 I was reviewing your code and heres what I would do for this transaction:
        + if (!aptdaemon_trans_id_.empty()) // Application is being installed, or hasn't been installed yet
47 + tooltip_text = _("Waiting to install");
48 + else {
49 + SetQuirk(QUIRK_URGENT, true);
50 + needs_urgent_ = true;
                           tooltip_text=_(Appname.string);

51 + }

As it currently quirks, if you hover over it it still says "Waiting to install" it does on my installation anyway ;)
I

Didier Roche (didrocks) on 2012-07-10
Changed in unity:
milestone: 6.0 → 6.2
Michael Vogt (mvo) on 2012-07-20
Changed in software-center (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
Changed in software-center (Ubuntu):
status: In Progress → Fix Released
Changed in unity (Ubuntu Precise):
importance: Undecided → High
status: New → In Progress

Hello Dave, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in software-center (Ubuntu Precise):
milestone: none → precise-updates
description: updated
Changed in software-center (Ubuntu Precise):
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-done
removed: verification-needed
description: updated
Changed in unity:
status: In Progress → Fix Committed
Stéphane Graber (stgraber) wrote :

Reverting to "In progress" on the precise task, "Fix commited" are for packages currently in -proposed, this package is still in the unapproved queue.

Changed in software-center (Ubuntu Precise):
status: Fix Committed → In Progress
Clint Byrum (clint-fewbar) wrote :

Hello Dave, or anyone else affected,

Accepted software-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/software-center/5.2.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-center (Ubuntu Precise):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Gary Lasker (gary-lasker) wrote :

Thanks Alan for your verification. I have also verified that software-center version 5.2.5 in precise-proposed fixes this bug per the test case given in the description (for the app Limbo).

Thanks!

Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity - 5.14.0-0ubuntu1

---------------
unity (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Unity launcher shows internal partitions after they have been unmounted
      (LP: #994163)
    - can't click to dismiss hud in the area where dynamic hud results are
      meant to appear (LP: #962651)
    - Spread/Scale should exit if Dash is invoked (LP: #944033)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dash - The search bar gets the focus when pressing invalid keys
      (LP: #931393)
    - unity crashed with NameError in reset_unity_compiz_profile(): global name
      'GError' is not defined (LP: #778470)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      from unity::UnityWindow::glPaint() (LP: #851982)
    - "Keyboard Shortcuts" overlay can cause annoyance (LP: #934062)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - HUD Draws improperly while searching for results (LP: #932531)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold (LP: #839717)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - dash should open when pressing "super" in scale mode (LP: #1023811)
    - Multimonitor, Launcher - When the Launcher is set to autohide and
      'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure'
      seems to be broken when revealing the Launcher (LP: #987955)
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - Regression: shift+click on a launcher icon to open a new application
      instance gone (LP: #754565)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Duplicated applications icons on quick application restart (LP: #1003574)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - alt-backtick flickers between windows (LP: #987156)
    - [Hud] The result grid is not drawn in proximity of the search entry
      (LP: #1008603)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - [hud] The last button is not rounded (LP: #1008656)
    - Hud flickers when show up (LP: #1011507)
    - Dash maximise button changed location (LP: #987674)
    - launcher reordering "line" doesn't go to the bottom slot (LP: #971421)
    - Dash/HUD should close on "Spread" (LP: #870284)
    - Nothing should be written into the dash/hud searchbar whe...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2.5

---------------
software-center (5.2.5) precise-proposed; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/fix-lp1009039:
    - fix treeview selection background (LP: #1009039)
  * lp:~mvo/software-center/fix-lp1011522:
    - fix bug where clicking on "Reinstall previous purchases" twice
      shows endless spinner (LP: #1011522)
  * lp:~mvo/software-center/click_url:
    - adds support for a "click_url" from the exhibits banner to
      support banners for things like the humble-bundle where we
      don't have packages but URLs (LP: #1020205)
  * lp:~mvo/software-center/hopefully-fix-lp1008229:
    - fix crash that can happen if there is an error while
      opening a deb file (LP: #1008229)
  * lp:~mvo/software-center/lp1026494:
    - typo fix in the hw description code (LP: #1026494)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/unity-launcher-integration-fixes:
    - fix bug where for-purchase items are not being added to the Unity
      launcher (LP: #925014)
    - fix bug where the Unity launcher item for an application incorrectly
      points to its app-install-data desktop file rather than its installed
      desktop file (LP: #999427)
    - fix bug where an application's icon remains in the Unity launcher after
      the corresponding application has been uninstalled (LP: #981488)
    - fix bug where the Unity launcher fails to auto-hide after installation
      of a for-purchase item (LP: #1002440)
    - fix bug where items in the "Independent" section are not being added
      to the Unity launcher (LP: #1012877)
  * lp:~gary-lasker/software-center/tech-items-to-launcher-fix-lp1006483:
    - don't add an item to the launcher if its desktop file specifies
      NoDisplay=true (LP: #1006483)
  * lp:~gary-lasker/software-center/launcher-integration-unit-tests:
   - additional unit tests to round out the suite for the Unity
     launcher integration feature
  * lp:~gary-lasker/software-center/fix-lp969907-for-5.2:
    - fix race condition in _app_activated_cb() (LP: #969907)
 -- Michael Vogt <email address hidden> Mon, 23 Jul 2012 16:38:04 +0200

Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package unity - 6.2.0-0ubuntu1

---------------
unity (6.2.0-0ubuntu1) quantal-proposed; urgency=low

  [ Adam Conrad ]
  * Removed debian/patches/libgeis-rename.patch

  [ Łukasz 'sil2100' Zemczak ]
  * debian/rules:
    - added override for dh_shlibdeps to point it to the private directory of
      libunity-protocol-private.so
  * debian/unity.lintian-overrides,
    debian/libunity-core-6.0-5.lintian-overrides:
    - added override to silence the binary-or-shlib-defines-rpath error, since
      we are forced to use RPATH in our case

  [ Didier Roche ]
  * New upstream release.
    - [nvidia] compiz crashed with SIGSEGV in
      nux::GraphicsEngine::QRP_GLSL_Color() from
      nux::GraphicsEngine::QRP_Color() from nux::BasePainter::PaintBackground
      (LP: #982626)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold. (LP: #839717)
    - running applications without an icon use a blank icon (LP: #886778)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - still some accent issues with unity/nux (LP: #950740)
    - Launcher doesn't autoscroll when holding an icon (can't reach trash)
      (LP: #987223)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - [GLES] framebuffer output scaled incorrect in both blur and items above
      shell with multimonitor (LP: #1016789)
    - [regression] [unity 6.0] Fullscreen windows flicker and/or never redraw
      properly if panel_opacity<1.0 or dash is opened. (LP: #1024911)
    - panel and launcher blinks when using libreoffice presenter/spreadsheet
      (LP: #1024459)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Update to 1.6.4 (LP: #1014850)
    - [nvidia] unity crashed in nux::GraphicsEngine::QRP_GLSL_1Tex
      (glDrawArrays) (LP: #1031554)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - Launcher, Dash - Showing dash, via super key, with a quicklist shown
      doesn't work (LP: #913994)
    - REGRESSION: can't type characters with accent (dead keys) (LP: #961741)
    - Launcher wrongly shows top tooltip when peforming the accordion effect
      (LP: #980942)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - logging out/in with mounted drives causes unity launcher icons to be
      duplicated (LP: #1010714)
    - Mounted volume icons doubled up in launcher (LP: #1010858)
    - Launcher - when a user starts dragging a item, the launcher icons that
      are *not* valid drop receptacles should be tinted (LP: #1020891)
    - Alt+F4 does not close the hud when Numlock or Capslock are on.
      (LP: #1022801)
    - Unity shortcut overlay needs to include shortcut for video lens
      (LP: #937334)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - give a way to remove 'Show Desktop' from the Alt-Tab items
      (LP: #1014346)
    - Multi...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints