software-center crashed with UnicodeDecodeError in __hash__(): 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)

Bug #922225 reported by mastaiza on 2012-01-26
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned
Precise
Undecided
Unassigned
Quantal
Medium
Unassigned

Bug Description

ups

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.7
ProcVersionSignature: Ubuntu 3.2.0-10.18-generic 3.2.1
Uname: Linux 3.2.0-10-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Fri Jan 27 00:23:02 2012
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center merkaartor/Merkaartor
PythonArgs: ['/usr/bin/software-center', 'merkaartor/Merkaartor']
SourcePackage: software-center
Title: software-center crashed with UnicodeDecodeError in __hash__(): 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)
UpgradeStatus: Upgraded to precise on 2012-01-26 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

mastaiza (mastaiza) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Sven Romeike (lun4tic) wrote :

had the same issue when installed blender from the application lens and while blender was installing searching and installing openshot through the application lens

Sven Romeike (lun4tic) wrote :

fresh 12.04 install here so its not an upgrade issue imo

Michael Vogt (mvo) wrote :

Any hints how to reproduce this are welcome, I tried this with software-center 5.2 and the LANGUAGE set to "ru" but could not reproduce the crash.

Michael Vogt (mvo) wrote :

But given that it affects 10 more people it seems like we need to add some extra protection.

Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Yann Dìnendal (yannbreliere) wrote :

Happened when trying to see the reviews of an app (gparted).

Michael Vogt (mvo) on 2012-04-23
Changed in software-center (Ubuntu):
importance: Undecided → Medium
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed

Hello mastaiza, or anyone else affected,

Accepted software-center into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in software-center (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Gary Lasker (gary-lasker) wrote :

Unfortunately, I also am unable to reproduce the original error. However, I was able to test software-center version 5.2.1 in precise-proposed and can verify that this fix causes no regressions or other problems.

Many thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2.1

---------------
software-center (5.2.1) precise-proposed; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/lp977179:
    - make the review UI react correctly to conditions of network
      availability (LP: #977179)
  * lp:~mvo/software-center/fix-crash-deb-file-size-calc:
    - fix crash when installing a deb file that is not found in
      the current apt cache
  * lp:~mvo/software-center/lp981992:
    - fix a crash in the new a11y code if there is a row that has
      no data or is not yet preloaded (LP: #981992)
  * lp:~mvo/software-center/fix-gmenu-searcher:
    - fix the menu searcher for non-Unity configurations after
      the app-install-data-ubuntu file layout changed
  * lp:~mvo/software-center/lp808455:
    - trivial fix for crash on downstream distros (LP: #808455)
  * lp:~mvo/software-center/lp927262:
    - fix crash when get_vadjustment() returns None (LP: #927262)
  * lp:~mvo/software-center/utf8-fixes:
    - fix various utf8-related crashes (LP: #943500, LP: #922225,
      LP: #917755)
  * lp:~mvo/software-center/gwibber-utf8-lp985255:
    - fix a utf8 crash in the gwibber integration (LP: #985255)
  * lp:~mvo/software-center/workaround-gtk-regression-lp986186:
    - workaround performance issue with the Gtk.TreeView.set_model()
      call when there is a cell_data_func attached. Not every user is
      affected (settings dependant somehow), but when affected it causes
      a massive performance degration for huge list models like "System"
      (LP: #986186). This branch works around the problem by disconnecting
      the cell_data_func before setting the new model.
  * lp:~mvo/software-center/fix-clear-credentials-race:
    - fix an incorrect use of the sso dbus backend, we now correctly
      wait until it emits a CredentialsCleared signal (LP: #986117)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/add-to-launcher-after-auth-lp972710:
    - fix bug where an application will be added to the Unity launcher
      in the case where the user cancels the installation auth dialog
      (LP: #972710)
  * lp:~gary-lasker/software-center/recommendations-sso-login-lp973612:
    - fix bug where the recommendations opt-in panel is hidden if
      the user declines the SSO dialog after opting in (LP: #973612)
    - fix the user experience if the user has previously opted-in to
      recommendations and their SSO token is found have been removed
      or revoked or otherwise found to be invalid (LP: #967064)
    - improve the responsiveness of the spinner in the recommendations
      flow
 -- Michael Vogt <email address hidden> Thu, 26 Apr 2012 09:47:19 +0200

Changed in software-center (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers