drop down menus from app toolbar have black background

Bug #921477 reported by Martin Pitt on 2012-01-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
software-center-developers

Bug Description

In current precise, opening software-center and clicking on the dropdown arrows next to the "All apps"/"Installed" buttons in the top toolbar gives a menu with a pitch black background. This might be because I'm using the light Radiance theme instead of standard Ambiance, but I think even with Ambiance it should not be that black. It should just use the default theme colors IMHO.

Attaching screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.7
ProcVersionSignature: Ubuntu 3.2.0-10.18-generic 3.2.1
Uname: Linux 3.2.0-10-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Wed Jan 25 10:52:47 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110831)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Martin Pitt (pitti) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Confirmed with Ambiance theme..

Changed in software-center (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → software-center-developers (software-center-developers)
Michael Vogt (mvo) wrote :

I debugged this for a bit but I'm stuck currently. I can not reproduce this on oneriric or with different themes like adwaita or the highcontrast ones. I wonder if its something in the theme itself?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.10

---------------
software-center (5.1.10) precise; urgency=low

  [ Michael Vogt ]
  * revert again:
    lp:~gary-lasker/software-center/temp-disable-lobby-recommendations-view
  * lp:~mvo/software-center/lp917096:
    - fix crash when opening a debfile and add regression test
      (LP: #917096)
  * softwarecenter/region.py:
    - trivial change to make region tag prefix "iso3166::" to align
      with the latest debtags upstream plans

  [ Kiwinote ]
  * softwarecenter/ui/gtk3/app.py:
    - disable navigating back by pressing the backspace key because it has
      started showing dodgy side effects - use ctrl+[ or alt+LEFT instead
  * remember the scroll position when navigating back to a list view,
    this only works in the available pane (LP: #852763)
  * correctly theme the channel selector menus (LP: #921477)
  * trigger pot file rebuild

  [ Barneedhar (jokerdino) ]
  * softwarecenter/hw.py:
    - fix broken string (LP: #936403)

  [ Stéphane Graber ]
  * utils/piston-helpers/x2go_helper.py: Fix weblive helper to work with
    Precise's python-x2go.
 -- Michael Vogt <email address hidden> Thu, 23 Feb 2012 16:58:30 +0100

Changed in software-center (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers