Ubuntu

software-center crashed with AttributeError in __contains__(): 'NoneType' object has no attribute '__contains__'

Reported by George Christofis on 2012-01-22
74
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Ubuntu Software Center
Undecided
Unassigned
software-center (Ubuntu)
Low
Gary Lasker

Bug Description

The ubuntu software-center doesn't open, it's loading without any result o screen until it crashes.

Although the test description above does not describe this, I found that I could reproduce this crash as follows:

TEST CASE:
1. open stock software-center
2. click on the "All Software" button very quickly while the main page is still loading
3. verify that there is a traceback (note that this does not happen always, just most of the time)
4. use the fixed version from -proposed
5. verify that (2) no longer produces a traceback

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.6
ProcVersionSignature: Ubuntu 3.2.0-10.17-generic 3.2.1
Uname: Linux 3.2.0-10-generic i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Mon Jan 23 00:22:16 2012
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111129.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 PATH=(custom, no user)
 LANG=el_GR.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with AttributeError in __contains__(): 'NoneType' object has no attribute '__contains__'
UpgradeStatus: Upgraded to precise on 2012-01-22 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

George Christofis (geochr) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Gary Lasker (gary-lasker)
milestone: none → precise-updates
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
description: updated
description: updated
description: updated
Changed in software-center (Ubuntu):
importance: Medium → Low
Changed in software-center (Ubuntu):
milestone: precise-updates → none
Gary Lasker (gary-lasker) wrote :
Download full text (3.6 KiB)

Examining errors.ubuntu.com shows that this crash no longer occurs since the release of software-center version 5.2.2, which included the branch lp:~gary-lasker/software-center/toolbar-buttons-insensitive-during-startup.

This bug was fixed in the package software-center - 5.2.2

---------------
software-center (5.2.2) precise-proposed; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/whatsnew-leak-lp985389:
    - search filter fix for the case when the "installed-only"
      filter leaks into subsequent searches (LP: #985389)
  * lp:~mvo/software-center/fix-lp994632:
    - add a dep to ensure we get the correct ubuntu-sso-client-gtk
      (LP: #994632)
  * lp:~mvo/software-center/proper-error-on-unknown-files:
    - show a proper error message when attempting to open unknown
      file types (LP: #944868)
  * lp:~mvo/software-center/lp921799:
    - fix crash when decoding screenshots JSON (LP: #921799)
  * lp:~mvo/software-center/lp959612:
    - fix crash when selecting the Installed view very quickly
      after startup (LP: #959612)

  [ Ken VanDine ]
  * lp:~ken-vandine/software-center/lp_982567:
    - Check if the proxy is enabled, if the proxy host is set but not
      enabled we shouldn't attempt to use the proxy (LP: #982567)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/fix-crash-lp969732:
    - need to explicitly declare the needs-refresh signal in the
      AppTreeStore class to prevent a crash (LP: #969732)
  * lp:~gary-lasker/software-center/fix-crash-lp870822:
    - don't crash if we don't get a pkgversion object back
      (LP: #870822)
  * lp:~gary-lasker/software-center/fix-shutdown-crash-lp996333:
    - never crash when writing out the software center config file on
      shutdown (LP: #996333)
  * lp:~gary-lasker/software-center/fix-makedirs-race-crashes:
    - fix crash on race when creating the cache or config directories
      (LP: #743003, LP: #621182)
  * lp:~gary-lasker/software-center/fix-crash_lp973379:
    - ensure that the cache is ready before using the recommender
      service (LP: #973379 )
  * lp:~gary-lasker/software-center/toolbar-buttons-insensitive-during-startup:
    - set the toolbar buttons insensitive for the duration of time that the
      lobby panels are initializing (LP: #999486, LP: #994341)

  [ Robert Roth ]
  * lp:~evfool/software-center/bug532072:
    - escape markup for support info and license (LP: #993279)
    - ellipsize summary at trailing end (LP: #532072)
  * lp:~evfool/software-center/lp626037:
    - subtle background color tweak for consistency
      between views (LP: #626037)
  * lp:~evfool/software-center/lp835005:
    - no need for the software-properties dialog to be modal
      to software-center (LP: #835005)
  * lp:~evfool/software-center/lp839389:
    - don't display an "icon not found" image in the Unity
      launcher when a report a review window is opened (LP: #839389)
  * lp:~evfool/software-center/867588:
    - capitalize the first letter of the package summary
      (LP: #867588)
  * lp:~evfool/software-center/lp876657:
    - make sure the search field does not disappear when an
      install or remove is in progress (LP: #876657)
  * lp:~evfool/so...

Read more...

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
Dave Morley (davmor2) on 2013-08-13
Changed in software-center (Ubuntu):
assignee: Gary Lasker (gary-lasker) → nobody
assignee: nobody → Gary Lasker (gary-lasker)
tags: added: u1-notrack
Rodney Dawes (dobey) on 2013-09-11
Changed in software-center:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers