software-center crashed with KeyError in __getitem__(): "The cache has no package named 'package_name'"

Bug #917096 reported by Jean-Baptiste Lallement on 2012-01-16
224
This bug affects 27 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Michael Vogt
Precise
High
Michael Vogt

Bug Description

TEST CASE:
1. Download a debian package that is not already in the package cache. (tested with crossover and lightscribe)
2. From a terminal run the following command:
$ software-center lightscribeApplications-1.18.15.1-linux-2.6-intel.deb

EXPECTED RESULT:
Software-Center starts and open the detail page for the package

ACTUAL RESULT:
This crash

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.5.1
ProcVersionSignature: Ubuntu 3.2.0-8.15-generic 3.2.0
Uname: Linux 3.2.0-8-generic x86_64
ApportVersion: 1.90-0ubuntu2
Architecture: amd64
Date: Mon Jan 16 11:37:10 2012
DuplicateOf: https://bugs.launchpad.net/bugs/916193
EcryptfsInUse: Yes
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center crossover-pro-demo_9.0.1-1_i386.deb
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.utf8
PythonArgs: ['/usr/bin/software-center', 'crossover-pro-demo_9.0.1-1_i386.deb']
SourcePackage: software-center
Title: software-center crashed with KeyError in __getitem__(): "The cache has no package named 'cxoffice2'"
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin libvirtd lpadmin sambashare

Related branches

Jean-Baptiste Lallement (jibel) wrote :
summary: software-center crashed with KeyError in __getitem__(): "The cache has
- no package named 'cxoffice2'"
+ no package named 'package_name'"
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu Precise):
importance: Undecided → High
status: Confirmed → Triaged
assignee: nobody → software-center-developers (software-center-developers)
tags: added: qa-manual-testing rls-mgr-p-tracking
Changed in software-center (Ubuntu Precise):
milestone: none → precise-alpha-2
tags: removed: need-duplicate-check
Martin Pitt (pitti) on 2012-02-06
Changed in software-center (Ubuntu):
milestone: precise-alpha-2 → ubuntu-12.04-beta-1
Michael Vogt (mvo) on 2012-02-16
Changed in software-center (Ubuntu Precise):
status: Triaged → In Progress
Changed in software-center (Ubuntu Precise):
status: In Progress → Fix Committed
assignee: software-center-developers (software-center-developers) → Michael Vogt (mvo)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.10

---------------
software-center (5.1.10) precise; urgency=low

  [ Michael Vogt ]
  * revert again:
    lp:~gary-lasker/software-center/temp-disable-lobby-recommendations-view
  * lp:~mvo/software-center/lp917096:
    - fix crash when opening a debfile and add regression test
      (LP: #917096)
  * softwarecenter/region.py:
    - trivial change to make region tag prefix "iso3166::" to align
      with the latest debtags upstream plans

  [ Kiwinote ]
  * softwarecenter/ui/gtk3/app.py:
    - disable navigating back by pressing the backspace key because it has
      started showing dodgy side effects - use ctrl+[ or alt+LEFT instead
  * remember the scroll position when navigating back to a list view,
    this only works in the available pane (LP: #852763)
  * correctly theme the channel selector menus (LP: #921477)
  * trigger pot file rebuild

  [ Barneedhar (jokerdino) ]
  * softwarecenter/hw.py:
    - fix broken string (LP: #936403)

  [ Stéphane Graber ]
  * utils/piston-helpers/x2go_helper.py: Fix weblive helper to work with
    Precise's python-x2go.
 -- Michael Vogt <email address hidden> Thu, 23 Feb 2012 16:58:30 +0100

Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.