Ubuntu-restricted-extras package is incorrectly added to the Unity launcher

Bug #913756 reported by Fabio Marconi on 2012-01-09
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Gary Lasker
Oneiric
Low
Gary Lasker

Bug Description

Hello
I've installed Ubuntu-restricted-extras and now it's unuseful icon is on the launcher.
See attached screenshot
Thanks
Fabio

TEST CASE:

1. Install the version of software-center in oneiric-proposed.
2. Launch Software Center and enter "ubuntu-restricted-extras" in the search bar.
3. Select the result and click the "More Info" button to see the details view.
4. If "ubuntu-restricted-extras" is already installed, please uninstall it now (you will reinstall in a moment).
5. Click "Install" in the details view.
6. Verify that the "Add to Launcher" panel does *not* come into view at the bottom of the details view.

bug 761851

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.5.1
ProcVersionSignature: Ubuntu 3.2.0-8.14-generic 3.2.0
Uname: Linux 3.2.0-8-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Mon Jan 9 13:42:28 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120108)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SoftwareCenterLog:
 2012-01-09 13:31:53,346 - softwarecenter.ui.gtk3.em - INFO - EM's: 17 13 20
 2012-01-09 13:31:59,544 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
 2012-01-09 13:31:59,914 - softwarecenter.ui.gtk3.utils - INFO - Softwarecenter style provider for ambiance Gtk theme: /usr/share/software-center/ui/gtk3/css/softwarecenter.css
 2012-01-09 13:32:33,618 - softwarecenter.ui.gtk3.app - INFO - software-center-agent finished with status 0
 2012-01-09 13:32:44,616 - softwarecenter.backend - WARNING - _on_trans_error: org.freedesktop.PolicyKit.Error.NotAuthorized: ('system-bus-name', {'name': ':1.71'}): org.debian.apt.install-or-remove-packages
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Fabio Marconi (fabiomarconi) wrote :
summary: - Wrong icons pon launcher
+ Wrong icons on launcher
Changed in software-center (Ubuntu):
status: New → Confirmed

Hello Gary
as you are working to 761851 I subscrbe you to this just to be sure avoid this thing.
Sorry of disturb
Fabio

Hello Fabio! Thanks for your report and the details. Indeed, I have cofirmed this myself and we will take care of this one. Please be sure to report any other bugs or issues that you may have as you use Software Center.

Thanks again!
Gary

summary: - Wrong icons on launcher
+ Ubuntu-restricted-extras package in incorrectly added to the Unity
+ launcher
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
summary: - Ubuntu-restricted-extras package in incorrectly added to the Unity
+ Ubuntu-restricted-extras package is incorrectly added to the Unity
launcher
Gary Lasker (gary-lasker) wrote :

The problem appears to be due to the fact that the desktop file for the ubuntu-restricted-extras package does not include the following line:

  NoDisplay=true

When this is detected in the desktop file, Software Center skips the add to Unity launcher.

Changed in software-center (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Gary Lasker (gary-lasker)
Gary Lasker (gary-lasker) wrote :

Actually, for this specific purpose (adding an icon the Unity launcher), a better check is to look for an Exec entry in the corresponding desktop file. If there is no such entry, then this package will not be added.

Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Changed in software-center (Ubuntu Oneiric):
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Gary Lasker (gary-lasker)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.6

---------------
software-center (5.1.6) precise; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/startup-speed2:
    - additional startup speed improvements, brings up main window
      much more quickly
  * lp:~mvo/software-center/fix-server-pagination:
    - reset reviews "page" when showing a new app

  [Christopher Kyle Horton]
  * utils/submit_review_gtk3.py:
    - fix crash when submitting a review (LP: #912855)

  [ Anthony Lenton ]
  * lp:~elachuni/software-center/test_downloader_fix:
    - fix test hang on incorrect proxy settings
  * lp:~elachuni/software-center/check-edit-labels:
    - add test for correct labels in "Modify review" mode
    - move main RnR Helper GUI into softwarecenter.backend.rnr
      to make testing easier

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/fix-lp913756:
    - do not add an icon to the Unity launcher for packages that do
      not have an Exec entry in their corresponding desktop file,
      e.g. ubuntu-restricted-extras, wine (LP: #913756)
  * lp:~gary-lasker/software-center/search-down-arrow-lp842711:
    - select the first item in the result list when the down
      arrow is pressed during a search (LP: #842711)
  * lp:~gary-lasker/software-center/fix-lp896474:
    - fix crash when attempting to install or remove an item
      via the menu (LP: #896474)
 -- Michael Vogt <email address hidden> Tue, 17 Jan 2012 14:19:57 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released

Hello Fabio, or anyone else affected,

Accepted software-center into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Fabio Marconi (fabiomarconi) wrote :

Hello
Tested in a fresh and fully updated installation of oneiric and is not reproducible, sometimes appear only the debconf icon.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Gary Lasker (gary-lasker) wrote :

I have verified that this bug is fixed in the version of software-center 5.0.6 in oneiric-proposed per the given test case.

Thanks!

description: updated
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.0.6

---------------
software-center (5.0.6) oneiric-proposed; urgency=low

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/catalog-published-date-lp803028i-for-5.0:
    - use date_published value from the software-center-agent server
      so that for-purchase items appear correctly and in the proper order
      in What's New; include corresponding unit test (LP: #803028)

  [ Michael Vogt ]
  * backport fix from lp:~mvo/software-center/fix-refresh-of-whats-new
    to ensure that new apps from e.g. the software-center-agent are
    immediately displayed in the "Whats new" section of the lobby
    (LP: #949725)

software-center (5.0.5) oneiric-proposed; urgency=low

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/fix-lp913756-for-5.0:
    - do not offer to add an icon to the Unity launcher for packages
      that do not have an Exec entry in their corresponding desktop
      file, e.g. ubuntu-restricted-extras, wine (LP: #913756)
  * lp:~gary-lasker/software-center/staging-certs-2-for-5.0:
    - add SOFTWARE_CENTER_FORCE_DISABLE_CERTS_CHECK to allow QA easier
      testing (LP: #918746)

  [ Michael Vogt ]
  * lp:~mvo/software-center/fix-server-pagination:
    - reset server side review "page" when switching to a different
      app
  * lp:~mvo/software-center/expunge-cache-5.0:
    - fix invalid httplib cache entries (LP: #938736)

  [ Kiwinote ]
  * grab exhibits for the current series only (LP: #899257)
 -- Michael Vogt <email address hidden> Thu, 08 Mar 2012 09:07:20 +0100

Changed in software-center (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers