submit_review_gtk3.py crashed with TypeError in _maybe_login_successful(): get_ubuntu_sso_backend() takes no arguments (1 given)

Bug #912855 reported by Zed on 2012-01-06
86
This bug affects 12 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Christopher Kyle Horton

Bug Description

crash on attempt write a review

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.5.1
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Fri Jan 6 20:33:20 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/share/software-center/submit_review_gtk3.py
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111129.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/software-center/submit_review_gtk3.py --pkgname remmina --iconname remmina --parent-xid --version 0.9.3-3 --origin ubuntu --datadir /usr/share/software-center/ --appname Remmina\ Remote\ Desktop\ Client
PythonArgs: ['/usr/share/software-center/submit_review_gtk3.py', '--pkgname', 'remmina', '--iconname', 'remmina', '--parent-xid', '', '--version', '0.9.3-3', '--origin', 'ubuntu', '--datadir', '/usr/share/software-center/', '--appname', 'Remmina Remote Desktop Client']
SourcePackage: software-center
Title: submit_review_gtk3.py crashed with TypeError in _maybe_login_successful(): get_ubuntu_sso_backend() takes no arguments (1 given)
Traceback:
 Traceback (most recent call last):
   File "/usr/share/software-center/submit_review_gtk3.py", line 489, in _maybe_login_successful
     self.ssoapi = get_ubuntu_sso_backend(self.token)
 TypeError: get_ubuntu_sso_backend() takes no arguments (1 given)
UpgradeStatus: Upgraded to precise on 2011-12-17 (19 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Zed (darkbroodzed) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Kiwinote (kiwinote) on 2012-01-07
visibility: private → public
Changed in software-center (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged

I just got this same problem. After clicking the "Be the first to review it" link for Phlipple in the Ubuntu Software Center, the "Review Phlipple" window came up, saying "Signing in...". A few seconds later, this crash came up, and it stayed stuck there.

Clicking Cancel and trying again leads to same exact crash again, so this is very reproducible for me.

I think I know how to fix this crash. I have attached a modified version of /usr/share/software-center/submit_review_gtk3.py containing the fix, as suggested by someone in Ask Ubuntu general chat. The problem is an unneeded function argument at line 489.

Since I couldn't get bzr working on grabbing the source and fixing it the "proper" way, I just modified that file and ran the Software Center from a terminal afterwards to confirm the crash was fixed.

(This is my first time trying to actually fix a bug...please go easy on me.)

Barneedhar (barneedhar) on 2012-01-07
tags: added: patch
amith kk (amith) on 2012-01-07
Changed in software-center (Ubuntu):
status: Triaged → In Progress
Changed in software-center (Ubuntu):
assignee: nobody → Christopher Kyle Horton (christhehorton)
Gary Lasker (gary-lasker) wrote :

Hello Christopher! Thanks very much for your patch, it looks just right. I've merged it to software-center trunk now and it will be available in the next development release of software-center in Precise.

Congratulations on your first bug fix in Ubuntu! I hope you will feel encouraged to submit many more. :)

Thanks again, your help is very much appreciated!

Best regards,
Gary

Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Oleg (msodmin) wrote :

sorry, don't Fix Released

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Oleg (msodmin) wrote :

Ater replace attached a modified version of /usr/share/software-center/submit_review_gtk3.py

run: chmod 0555 /usr/share/software-center/submit_review_gtk3.py

see Bug #916465

@Oleg Why was this marked as "Fix Released"? AFAIK the fix is still only in software-center trunk, not in the Precise package yet.

Gary Lasker (gary-lasker) wrote :

Indeed, this one is still Fix Committed at this point. The fix will be released song in the upcoming development version 5.1.6 of software-center in Precise.

Thanks!

Changed in software-center (Ubuntu):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.6

---------------
software-center (5.1.6) precise; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/startup-speed2:
    - additional startup speed improvements, brings up main window
      much more quickly
  * lp:~mvo/software-center/fix-server-pagination:
    - reset reviews "page" when showing a new app

  [Christopher Kyle Horton]
  * utils/submit_review_gtk3.py:
    - fix crash when submitting a review (LP: #912855)

  [ Anthony Lenton ]
  * lp:~elachuni/software-center/test_downloader_fix:
    - fix test hang on incorrect proxy settings
  * lp:~elachuni/software-center/check-edit-labels:
    - add test for correct labels in "Modify review" mode
    - move main RnR Helper GUI into softwarecenter.backend.rnr
      to make testing easier

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/fix-lp913756:
    - do not add an icon to the Unity launcher for packages that do
      not have an Exec entry in their corresponding desktop file,
      e.g. ubuntu-restricted-extras, wine (LP: #913756)
  * lp:~gary-lasker/software-center/search-down-arrow-lp842711:
    - select the first item in the result list when the down
      arrow is pressed during a search (LP: #842711)
  * lp:~gary-lasker/software-center/fix-lp896474:
    - fix crash when attempting to install or remove an item
      via the menu (LP: #896474)
 -- Michael Vogt <email address hidden> Tue, 17 Jan 2012 14:19:57 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers