software-center crashed with AttributeError in on_menuitem_install_activate(): SoftwareCenterAppGtk3 instance has no attribute 'on_application_request_action'

Bug #896474 reported by Logan on 2011-11-26
56
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Gary Lasker

Bug Description

Attempting to install or remove items using the corresponding menu items no longer works (crash info below). This is a regression.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.2.1
ProcVersionSignature: Ubuntu 3.2.0-1.3-generic 3.2.0-rc2
Uname: Linux 3.2.0-1-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Fri Nov 25 21:31:16 2011
ExecutablePath: /usr/share/software-center/software-center
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with AttributeError in on_menuitem_install_activate(): SoftwareCenterAppGtk3 instance has no attribute 'on_application_request_action'
Traceback:
 Traceback (most recent call last):
   File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 734, in on_menuitem_install_activate
     self.on_application_request_action(self, app, [], [], AppActions.INSTALL)
 AttributeError: SoftwareCenterAppGtk3 instance has no attribute 'on_application_request_action'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Logan (logan88noe) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Gary Lasker (gary-lasker)
description: updated
Changed in software-center (Ubuntu):
importance: High → Medium
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.6

---------------
software-center (5.1.6) precise; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/startup-speed2:
    - additional startup speed improvements, brings up main window
      much more quickly
  * lp:~mvo/software-center/fix-server-pagination:
    - reset reviews "page" when showing a new app

  [Christopher Kyle Horton]
  * utils/submit_review_gtk3.py:
    - fix crash when submitting a review (LP: #912855)

  [ Anthony Lenton ]
  * lp:~elachuni/software-center/test_downloader_fix:
    - fix test hang on incorrect proxy settings
  * lp:~elachuni/software-center/check-edit-labels:
    - add test for correct labels in "Modify review" mode
    - move main RnR Helper GUI into softwarecenter.backend.rnr
      to make testing easier

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/fix-lp913756:
    - do not add an icon to the Unity launcher for packages that do
      not have an Exec entry in their corresponding desktop file,
      e.g. ubuntu-restricted-extras, wine (LP: #913756)
  * lp:~gary-lasker/software-center/search-down-arrow-lp842711:
    - select the first item in the result list when the down
      arrow is pressed during a search (LP: #842711)
  * lp:~gary-lasker/software-center/fix-lp896474:
    - fix crash when attempting to install or remove an item
      via the menu (LP: #896474)
 -- Michael Vogt <email address hidden> Tue, 17 Jan 2012 14:19:57 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers