Skype Icon shows twice while searching for it at software-center

Bug #891613 reported by Fabio Rafael Rosa on 2011-11-17
66
This bug affects 11 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Michael Vogt

Bug Description

While searching for skype at software-center for installing, the result window shows skype icon twice.
During the installation of the software, the progress bar showed at both icons.
After the installation, both icons are still shown at the result window, both marked as installed.
I attached a screenshot

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: software-center 5.0.2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Thu Nov 17 11:18:04 2011
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=pt_BR:pt:en
 PATH=(custom, no user)
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Fabio Rafael Rosa (rafaelfdr) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Thibault D (thibdrev) wrote :

Strange : I do not get it the french version (see screenshot).
But it have Software Centre 5.0.3.1 so maybe it is fixed now.

Bilal Shahid (s9iper1) wrote :

Thank you for taking time in filing the bug to make ubuntu better.
here i am not be able to reproduce this bug.
1). is the bug reproduce able?
2).describe the steps to reproduce it?

Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
Thibault D (thibdrev) wrote :

I am not able to reproduce it with software-centre 5.0.4
I think this bug is being fixed now, at least on Oneiric.

I have the same problem in Oneiric

helloSaurabh (saucy178) wrote :

I am getting two icon problem in super key search for almost every program! Is anyone else facing the issue?

Bilal Shahid (s9iper1) wrote :

i am not be able to reproduce it. i am using 5.0.4 version of software center.see the screenshots.
@ saucy178
are you using precise or oneiric.? alexander can you tell me your software center version.?

Bilal Shahid (s9iper1) wrote :

I am using 5.0.4, too.

i can reproduce it, here's a screenshot

Steps to reproduce:
1. open software center
2. search "skype" minus the quotes

That will result in (at least for me) seeing two of the Skype among other apps as well.
If you want just the"double skype" (again, at least for me) type "skype internet telephony" into the search bar
and you should see something exactly like my attachment

Marking this as confirmed, what has failed to have been noticed here is, well take a nice look at all of the screen shots people posted here, see if you notice a difference. The ones with the duplicate Skype also contain (skype:i386) in the name of them... which would imply that the packages are different no? This bug defiantly seems like it's on a person by person basis tho, and not a big usability problem either at the moment

Description: Ubuntu 11.10
Release: 11.10

software-center:
  Installed: 5.0.4
  Candidate: 5.0.4

Changed in software-center (Ubuntu):
status: Incomplete → Confirmed

Indeed, it is not a usability problem, everything works fine it just seems odd and at first glance confusing. What is also curious, if you remove skype, you can click on any of the two skypes to do so, however, one will remain look as if it is installed. When you then click on remove on that one it says skype is not installed and afterwards both skypes are shown as not installed.

What I just noticed: When you then install one of the skypes, the other one does not have the green check symbol and still has the option to install. When you then install and type in your password, the green check symbol appears instantly and it does not seem as if anything is installed (thankfully).

lunix (bob-l-lewis) wrote :

I am not 100% sure of this comment but I think the double entries only show up when Ubuntu 11.04 has been installed via an upgrade path. Fresh install seems to fix the double entry issue for Skype.

lunix (bob-l-lewis) wrote :

I did some testing and now have some new insight for the lucky person that might help out with this issue.
If I do a fresh install of Ubuntu 11.10 and then bring up the Software Center it shows Skype as something I can click on.
If I install Skype that way two bad things happen. 1) I get the now discontinued version of Skype instead of the new one released recently. 2) I get the double entries being discussed here once the older Skype is installed in this manor. Once I take this
path even if I remove the older version and use the method described below I always get double entries.

I think the older version which was public was skype-2.2.0.2.28

However, If I download from Skype the now shipping version of skype_precise_4.0.0.7-1_amd64.deb or the 32-bit version
if that is what is needed and double click on it. The Software Center then offers to install it. When this completes I only
see the one entry and all is well.

lunix (bob-l-lewis) wrote :

Synaptic shows a single entry so I don't see any issue with it.

My current 12.04 install was fresh and I also see it twice in the software-center but now once with the skype icon and once with the generic package icon. As in oneiric, everything is functioning so it's only a cosmetic issue.

Changed in software-center (Ubuntu):
importance: Undecided → Medium
John Pugh (jpugh) on 2012-09-27
summary: - Skype Icon shows twice while seaching for it at software-center
+ Skype Icon shows twice while searching for it at software-center
Michael Vogt (mvo) on 2012-09-27
tags: added: ca-escalated
Michael Vogt (mvo) wrote :

This seems to be a side effect of the exact query we do for pkgname matches. When we do this for items in the apt-xapian-database, we add a:

"""
            # filter out docs of pkgs of which there exists a doc of the app
            enquire.set_query(xapian.Query(xapian.Query.OP_AND_NOT,
                                           q, xapian.Query("XD")))
"""

The apt-xapian-index adds a "XD" to all the documents that have a desktop file in app-install-data. This makes the de-duplication
for items in app-install-data-ubuntu working fine, but it does not work for data comming from the software-center-agent
as this does not have a desktop file on disk.

Changed in software-center (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Michael Vogt (mvo)
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.3.14.3

---------------
software-center (5.3.14.3) quantal; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/downloader-fix-race839462-again:
    - fix a race condition in the SimpleFileDownloader when the file
      is downloaded but the signal did not get delivered yet by the
      gtk event loop (LP: #1055441)
  * lp:~mvo/software-center/thumbnail-test-fixes:
    - fix the get_test_screenshot_thumbnail_window() function and
      ensure that its properly used in the automatic test
  * lp:~mvo/software-center/support-multiple-exhibit-images:
    - add support for multiple images in the exhibit banners
      (LP: #920542)
  * lp:~mvo/software-center/robustness-lp1054070:
    - extends the recovery mechanism for corrupted berkeley
      DB files to MemoryErrors as well to catch LP: #1054070
  * lp:~mvo/software-center/whats-new-lp1044033:
    - ensure that there is a fallback xapian value that can be
      used if the apt-xapian-index has not been created
      (LP: #1044033)
  * lp:~mvo/software-center/exact-match-duplication-lp891613:
    - fix the duplication of packages during a search if there
      is an exact pkgname match in the apt-xapian-index and
      also in the software-center-agent (LP: #891613)
  * lp:~mvo/software-center/lp1047494:
    - fix AttributeError crash in _on_reviews_ready_callback()
      (LP: #1047494)
  * lp:~mvo/software-center/de-duplication-multiple-pkgnames-lp1043159:
    - fix duplication for multiple package lists (LP: #1043159)

  [ Stéphane Graber ]
  * lp:~stgraber/software-center/fix-weblive-isinstance:
    - sync weblive_pristine.py to the latest upstream version,
      this includes porting to be pep8 and python 3 ready and
      restores correct weblive operation

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/de-duplication-multiple-pkgnames-lp1043159-tweak
    - pass DB to the recommendations categories
 -- Michael Vogt <email address hidden> Tue, 02 Oct 2012 10:02:51 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers