software-center crashed with IndexError in set_thumbnails_from_data(): list index out of range

Bug #888669 reported by newuser on 2011-11-10
210
This bug affects 47 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Kiwinote
Precise
Medium
Kiwinote

Bug Description

Software-center crashed when I try to get more info for qt creator package.

I'm using live-usb and running unity-2d.

TEST CASE:
1. Launch Software Center from the command line
2. Select an application without a screenshot
   2.1 Enter 'hello' in the search box
   2.2 Select the line with title 'The Classic greeting, and good example'
3. Click on 'More info'

EXPECTED RESULT:
Detail page is displayed without error

ACTUAL RESULT:
The following error is displayed on the terminal
-----
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/ui/gtk3/widgets/thumbnail.py", line 264, in _on_screenshots_available
    self.thumbnails.set_thumbnails_from_data(screenshots)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/widgets/thumbnail.py", line 482, in set_thumbnails_from_data
    self._prev = self.get_children()[0]
IndexError: list index out of range
-----

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.1.1
ProcVersionSignature: Ubuntu 3.1.0-2.3-generic 3.1.0
Uname: Linux 3.1.0-2-generic x86_64
ApportVersion: 1.25-0ubuntu1
Architecture: amd64
CasperVersion: 1.289
Date: Thu Nov 10 19:21:45 2011
ExecutablePath: /usr/share/software-center/software-center
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111107)
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SoftwareCenterLog:
 2011-11-10 19:13:54,809 - softwarecenter.ui.gtk3.em - INFO - EM's: 17 13 20
 2011-11-10 19:14:02,443 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
 2011-11-10 19:14:03,189 - softwarecenter.ui.gtk3.utils - INFO - Softwarecenter style provider for ambiance Gtk theme: /usr/share/software-center/ui/gtk3/css/softwarecenter.css
 2011-11-10 19:14:46,212 - softwarecenter.ui.gtk3.app - INFO - software-center-agent finished with status 0
SourcePackage: software-center
Title: software-center crashed with IndexError in set_thumbnails_from_data(): list index out of range
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout dip lpadmin plugdev sambashare sudo

Related branches

newuser (newuser) wrote :
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
tags: removed: need-duplicate-check
Adrian Ciriaci (ciriaci) on 2011-11-27
Changed in software-center (Ubuntu):
assignee: nobody → Adrian Ciriaci (ciriaci)
col reilly (lupinehorror) wrote :

just clicked one of the apps on the main page and the crash occurred.
didn't happen the first time i clicked...i'd already viewed something else, returned to the main page and then tried another.

tags: added: iso-testing
Wajih Letaief (mawale) wrote :

Happens on 12.04 Alpha1 32 bits

Oscar (oscaci) wrote :

try installing with synaptic the glib-networking

Filippos Kolyvas (fkol-k4) wrote :

Running 12.04 Alpha 1 i386 in VirtualBox. Host O/S is Ubuntu 11.10 X86-64.
The crash occured as i was trying to install nautilus-open-terminal.
The procedure was:
1-Search for the application. 2-Show extra info. 3-Select "Install".
The glib-networking package was already installed and updated as suggested in answer #5.
My localization settings: el_gr-UTF8 language.

can't install anything with software center now. Press install and it does nothing. For some seconds later it shows a crash report. I have to use synaptic and apt-get to install things i need for now.

Changed in software-center (Ubuntu Precise):
importance: Undecided → High
status: Confirmed → Triaged
assignee: Adrian Ciriaci (ciriaci) → nobody
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
description: updated
Changed in software-center (Ubuntu Precise):
milestone: none → precise-alpha-2
tags: added: rls-mgr-p-tracking
Martin Pitt (pitti) on 2011-12-13
Changed in software-center (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Gary Lasker (gary-lasker)
monnok (russx) wrote :

same problems with software center
and when i click at system preferences nothing happends

Brian Smith (brian-smith-i) wrote :

Nothing I try to install succeeds. Not much use when one is using a developing version

Kiwinote (kiwinote) wrote :

Hi! Thanks for your bug report. The bug you describe has been fixed in the branch I have linked and should be available in the next release. Please continue to report any bugs you may find in software-center. Thanks again for your help!

Changed in software-center (Ubuntu Precise):
assignee: Gary Lasker (gary-lasker) → Kiwinote (kiwinote)
importance: High → Medium
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.5

---------------
software-center (5.1.5) precise; urgency=low

  [ Kiwinote ]
  * softwarecenter/ui/gtk3/models/appstore2.py:
    - fix TypeError in load_range (LP: #911886)
  * softwarecenter/ui/gtk3/panes/historypane.py:
    - change COL_PKG to an object rather than a str (LP: #905762)
  * softwarecenter/ui/gtk3/panes/installedpane.py:
    - fix utf8 oddness to make remote installed panes work
  * softwarecenter/ui/gtk3/widgets/oneconfviews.py:
    - ensure that hostid is always a string (as we declared) (LP: #905605)
  * softwarecenter/ui/gtk3/widgets/thumbnail.py:
    - fix IndexError in set_thumbnails_from_data (LP: #888669)
  * grab exhibits for the current series only (LP: #899257)

  [ Michael Vogt ]
  * Remove explicit GObject.threads_init as initializing the threads
    explicitely causes a segfault on close but nothing more
    (LP: #907568)
  * lp:~mvo/software-center/startup-speed2:
    - improve the startup speed by moving out the (expensive) channel
      change test out of the main app into a spawned helper, also
      delays some computations and adds a cheaper way for getting the
      appcount
  * lp:~mvo/software-center/icon-data:
    - remove the need for inline icon data from the agent, instead
      download icons directly using the provided URL
  * softwarecenter/db/debfile.py:
    - fix encoding error for some debs (based on
      lp:~roignac/software-center/bug-738771-summary-unicode), thanks
      to Vadim Rutkovsky, LP: #738771
  * softwarecenter/ui/gtk3/views/appdetailsview.py:
    - fix crash in test/gtk3/test_views.py
  * lp:~mvo/software-center/replace-restfulclient-with-piston:
    - replace lazr.restfulclient with piston-mini-client for ubuntu-sso
      and cleanup the piston-mini-client helper code

  [ Gary Lasker ]
  * softwarecenter/backend/channel_impl/aptchannels.py:
    - display the correct label text for the For Purchase menu item
      in the toolbar (LP: #911964)
  * lp:~gary-lasker/software-center/date-published-cleanup:
    - remove no longer needed code
  * lp:~gary-lasker/software-center/replace-restfulclient-with-piston-tweaks:
    - tweaks and fixes the branch

  [ Vadim Rutkovsky ]
  * lp:~roignac/software-center/bug-632773-selectable-title:
    - make the app title selectable (LP: #632773)
 -- Michael Vogt <email address hidden> Fri, 06 Jan 2012 10:56:48 +0100

Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/888669

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers