On Kubuntu, doesn't display any screenshots - just shows "no screenshot"

Bug #888401 reported by tedaste on 2011-11-10
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

Doesn't display any screen shots - just shows "no screenshot"

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: software-center 5.0.2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Thu Nov 10 12:36:38 2011
InstallationMedia: Kubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: software-center
UpgradeStatus: Upgraded to oneiric on 2011-10-17 (24 days ago)

tedaste (toivo-arach) wrote :
Robert Roth (evfool) wrote :

Could you please check audacity for example? Or No screenshot is shown for every application?

Changed in software-center (Ubuntu):
status: New → Incomplete

I'm running Kubuntu 12.04, I tried Audacity and there are no
screenshots. This is on two separate machines

On Sat 12 May 2012 13:37:24 WST, Robert Roth wrote:
> Could you please check audacity for example? Or No screenshot is shown
> for every application?
>
> ** Changed in: software-center (Ubuntu)
> Status: New => Incomplete
>

tedaste (toivo-arach) wrote :

I'm running Kubuntu 12.04, I tried Audacity and there are no
screenshots. This is on two separate machines

On 12/05/12 13:37, Robert Roth wrote:
> Could you please check audacity for example? Or No screenshot is shown
> for every application?
>
> ** Changed in: software-center (Ubuntu)
> Status: New => Incomplete
>

Robert Roth (evfool) on 2012-05-13
Changed in software-center (Ubuntu):
status: Incomplete → New
Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
tags: added: kubuntu
summary: - Doesn't display any screen shots - just shows "no screensho"
+ On Kubuntu, doesn't display any screenshots - just shows "no screenshot"
Coruja074 (coruja074) wrote :

I am running 12.04 LTS 64-bit (the Linux computer is behind a www proxy). I also have this software center bug. I have attached the output of the command "software-center --debug picsaw >software-center.out 2>&1".

pre. 2012-12-05 14:02:03,424 - softwarecenter.ui.gtk3.widgets.exhibits - WARNING - download failed: '<class 'gi._glib.GError'>', 'DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.'

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please check if you have: "glib-networking" installed? And if not, if installing it fixes the problem? It looks like its might be a missing dependency in software-center that is installed by default in ubuntu but not kubuntu.

glib-networking is already installed on my system. Any other dependency
that it could be? I already tried installing the packages that synaptic
reports under "Recommends:", but that didn't solve anything.

-~Chris

On 12/10/2012 03:09 AM, Michael Vogt wrote:
> Thanks for your bugreport.
>
> Could you please check if you have: "glib-networking" installed? And if
> not, if installing it fixes the problem? It looks like its might be a
> missing dependency in software-center that is installed by default in
> ubuntu but not kubuntu.
>

glib-networking is already installed on my system. Any other dependency
that it could be? I already tried installing the packages that synaptic
reports under "Recommends:", but that didn't solve anything.

Michael Vogt (mvo) wrote :

Hey Christian, thanks for your reply. The other one I can think of is: "gvfs-backends"?

Michael Vogt (mvo) wrote :

I can reproduce this in a chroot now and it seems like installing gvfs-backend fixes it for me. If that works for you as well I will add it to the dependencies.

That's weird... I already have gvfs-backends installed. I tried reinstalling it, but I still get no screenshots. Perhaps it is gvfs-backends plus something else that needs to be installed?

Michael Vogt (mvo) wrote :

Thanks again Christian. That is confusing, I just tested again with a live-cd of kubuntu and after installing gvfs-backeds (which in turn installed a bunch of additional dependencies) it works for me and I can see the screenshot of e.g. gparted.

Okay, I was able to confirm that installing gvfs-backends works with a LiveCD, so I tried to figure out what was different on my system. It turns out, I had edited the Ubuntu Software Center menu entry to launch with 'kdesudo'. I don't remember why I made this change, but it was probably a long time ago for an older version of the software center.

Anyway, after removing 'kdesudo' from the launch command, I can now see the screenshots.

Coruja074 (coruja074) wrote :

On Ubuntu 12.04, I have software-center 5.2.6 and I have verified that gvfs-backends (1.12.1-0ubuntu1.1) and glib-networking (2.32.1-1ubuntu2) are installed, but still no screenshots. I open software center with the Unity Dash or with the CLI, no special admin privilege set with sudo or similar.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.5.2.1

---------------
software-center (5.5.2.1) raring; urgency=low

  * lp:~mvo/software-center/lp1081691:
    - add set X-Unity-IconBackgroundColor=#ffbf87 (LP: #1081691)
  * lp:~mvo/software-center/add-missing-dependency-lp888401:
    - add missing dependency on gvfs-backends to get working
      screenshots support (LP: #888401) on systems like kubuntu
  * fix tests in the ADT environment
 -- Michael Vogt <email address hidden> Thu, 13 Dec 2012 21:05:58 +0100

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
Marty Arnold (brotherarnold) wrote :

I have Ubuntu 12.04 and went a while without screenshots in software-center. Then software-center was updated a week or two ago to 5.2.7 (I think) and I had screenshots again. YAY!

BUT now I'm back to the same, no screenshots again. I have checked and I have glib-networking installed and gvfs-backed installed. I used Synaptic to reinstall software-center and glib-networking but nothing changed. I though if I logged off and back on that might help, but nothing again. It's very frustrating for me to not be able to seen a screenshot preview of an app.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers