Activity log for bug #878354

Date Who What changed Old value New value Message
2011-10-19 17:17:51 Matthew Paul Thomas bug added bug
2011-10-19 17:18:33 Matthew Paul Thomas description Third-party .deb packages -- such as Opera and Chrome -- sometimes have their data.tar portion compressed using LZMA. Until Ubuntu 11.10 this wasn't a problem, because the lzma package was installed by default. In 11.10, however, it was not (bug 868188). <http://my.opera.com/community/forums/topic.dml?id=1124872&t=1318873023&page=1#comment10564932> To work around this problem, software-center 5.0.2 Recommends lzma. However, as described by ruario in that bug report, "the lzma package installs the older lzma utils, which are no longer actively maintained[. T]he upstream maintainer of lzma utils is the same as xz utils. He considers xz to be the replacement for lzma, which is why it is backwards compatible". So, apt should probably use xz-lzma, and software-center should no longer depend on lzma. Third-party .deb packages -- such as Opera and Chrome -- sometimes have their data.tar portion compressed using LZMA. Until Ubuntu 11.10 this wasn't a problem, because the lzma package was installed by default. In 11.10, however, it was not (bug 868188). <http://my.opera.com/community/forums/topic.dml?id=1124872&t=1318873023&page=1#comment10564932> To work around this problem, software-center 5.0.2 Recommends lzma. However, as described by ruario in that bug report, "the lzma package installs the older lzma utils, which are no longer actively maintained[. T]he upstream maintainer of lzma utils is the same as xz utils. He considers xz to be the replacement for lzma, which is why it is backwards compatible". So, apt should probably use xz-lzma, and software-center should no longer depend on lzma. xz-utils has been in Main at least since Lucid.
2011-10-19 17:51:50 Launchpad Janitor software-center (Ubuntu): status New Confirmed
2011-10-19 17:54:19 Matthew Paul Thomas description Third-party .deb packages -- such as Opera and Chrome -- sometimes have their data.tar portion compressed using LZMA. Until Ubuntu 11.10 this wasn't a problem, because the lzma package was installed by default. In 11.10, however, it was not (bug 868188). <http://my.opera.com/community/forums/topic.dml?id=1124872&t=1318873023&page=1#comment10564932> To work around this problem, software-center 5.0.2 Recommends lzma. However, as described by ruario in that bug report, "the lzma package installs the older lzma utils, which are no longer actively maintained[. T]he upstream maintainer of lzma utils is the same as xz utils. He considers xz to be the replacement for lzma, which is why it is backwards compatible". So, apt should probably use xz-lzma, and software-center should no longer depend on lzma. xz-utils has been in Main at least since Lucid. Third-party .deb packages -- such as Opera and Chrome -- sometimes have their data.tar portion compressed using LZMA. Until Ubuntu 11.10 this wasn't a problem, because the lzma package was installed by default. In 11.10, however, it was not (bug 868188). <http://my.opera.com/community/forums/topic.dml?id=1124872&t=1318873023&page=1#comment10564932> To work around this problem, software-center 5.0.2 Recommends lzma. However, as described by ruario in that bug report, "the lzma package installs the older lzma utils, which are no longer actively maintained[. T]he upstream maintainer of lzma utils is the same as xz utils. He considers xz to be the replacement for lzma, which is why it is backwards compatible". While the xz-utils source package has been in Main at least since Lucid, the xz-lzma binary package inside it is in Universe. So, xz-lzma should be promoted to Main, apt should use xz-lzma, and software-center should no longer Recommend lzma.
2011-10-19 18:02:42 Matthew Paul Thomas bug task added apt (Ubuntu)
2011-10-19 18:18:57 Launchpad Janitor apt (Ubuntu): status New Confirmed
2011-10-19 18:19:03 ruario bug added subscriber ruario
2011-10-19 19:23:28 Michael Vogt nominated for series Ubuntu Precise
2011-10-19 19:23:28 Michael Vogt bug task added apt (Ubuntu Precise)
2011-10-19 19:23:28 Michael Vogt bug task added software-center (Ubuntu Precise)
2011-10-19 19:23:36 Michael Vogt apt (Ubuntu Precise): importance Undecided Medium
2011-10-19 19:23:38 Michael Vogt software-center (Ubuntu Precise): importance Undecided Medium
2011-11-21 14:44:01 Pedro Villavicencio software-center (Ubuntu Precise): status Confirmed Triaged
2011-11-21 14:44:04 Pedro Villavicencio apt (Ubuntu Precise): status Confirmed Triaged
2012-04-11 08:17:02 Michael Vogt software-center (Ubuntu Precise): milestone ubuntu-12.04
2012-04-11 08:19:03 Michael Vogt software-center (Ubuntu Precise): status Triaged Fix Committed
2012-04-11 08:19:17 Launchpad Janitor branch linked lp:software-center
2012-04-11 08:21:05 Michael Vogt apt (Ubuntu Precise): status Triaged Fix Committed
2012-04-13 18:00:43 Launchpad Janitor software-center (Ubuntu Precise): status Fix Committed Fix Released
2012-04-13 18:11:26 Launchpad Janitor branch linked lp:ubuntu/software-center
2016-05-15 16:36:37 Julian Andres Klode apt (Ubuntu): status Fix Committed Fix Released