Expanding and collapsing items in the 'Installed' tab needs work

Bug #877130 reported by Dean Matzkov on 2011-10-18
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Kiwinote

Bug Description

Expanding and collapsing the tree items in the 'Installed' tab is unnecessary difficult, as the only functional areas are the small arrows to the left. I think it'd make sense if they could also be expanded/collapsed by double-clicking anywhere on them.

Another issue is trying to collapse and then expand an item without moving your mouse. I'll offer my explanation in the form of the following reproduction-steps:

1. Go to the 'Installed tab', and click anywhere once on any tree item.
2. Move your mouse to another tree item, but this time single-click its arrow.
3. Without moving your mouse, single-click the arrow again to try to close it.
4. Witness that rather than collapsing, it just becomes selected.
5. Still not moving your mouse, click it again. And again. And again.

Ubuntu version: 11.10, 32-bit (fresh installation)
Software Center version: 5.0.1.4

Related branches

description: updated
Robert Roth (evfool) on 2011-10-19
Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Matthew Paul Thomas (mpt) wrote :

Charline reports that this has been a common problem in usability testing of USC in Ubuntu 12.04 beta. "Every one I've seen so far, have tried to open the category by clicking on the word 'games' and not on the arrow beside it." So I'm bumping this up to Medium, and I've made explicit in the specification how the category headings should work. <https://wiki.ubuntu.com/SoftwareCenter?action=diff&rev2=618&rev1=617> See also bug 617435.

Changed in software-center (Ubuntu):
importance: Low → Medium
status: Confirmed → Triaged
Gary Lasker (gary-lasker) wrote :

Honestly, I don't know why we ever moved to tree views for the installed pane in the first place. Tree views are notoriously awful UI components. I think our old, uncategorized list was better compared to this (especially since we had made that list very, very fast in its most recent incarnation before the new UI). To me this treeview just seems anomalous because we don't use a treeview like this anywhere else in the UI. The available pane views use category icons that lead to lists., Why is it different for installed items?

Another thing that I find inconvenient about the treeviews is that when you open the pane you see absolutely nothing useful at all until you click open one of the categories. And, as this bug so aptly describes, that's currently not easy to do because of the tiny disclosure triangle (this is, after all, how treeviews work).

I suppose it's far to late in the cycle to switch back now, but, isn't the better long term solution for this usability issue to get rid of the treeview altogether and have the installed pane look and act like the available pane?

Or maybe there's just something I'm missing. :)

Matthew Paul Thomas (mpt) wrote :

To begin with the second question, I specced "Installed" to be very different from "All Software" for two reasons. First, it helps avoid confusion between the two sections -- so that, for example, you don't end up flummoxed that you can't find an application you want to install because you're mistakenly looking only at the things you already have installed. Another way of solving that would be just to merge the sections, replacing "Installed" with an easy-to-find filter on "All Software". But second, "Installed" has different use cases: for example, a support technician looking up exactly which libraries you have installed, or someone with multiple machines comparing the software installed on each. (In the former case you could use the terminal, but you shouldn't have to.) The list is optimized for that kind of quick scanning, whereas All Software is optimized for browsing and will increasingly use tile views instead of lists.

As for the first question, why the list has branches, if it did not it would be either several hundred or several thousand items long, depending on whether you were currently showing technical items. (I don't remember exactly, but I think the previous list did not have that option.) I've met one designer who despises tree views, but I'm not aware of them being "notoriously awful" -- they're used in every file manager, and are perhaps unique in having had an entire software genre, outliners, based around them.

Now, tree controls work in a couple of different ways, depending on what you can do with the branches. What you describe as "how treeviews work" is how they work if branch labels are editable, as with renameable folders in a file manager. Where they are not, as in this case, a branch can and should expand and collapse by clicking anywhere on it.

There is some overlap between "All Software" and "Installed", different overlap between "Installed" and "History", different overlap again between "History" and "Reinstall Previous Purchases", and different overlap still between "Reinstall Previous Purchases" and your forthcoming account page. So it's vaguely possible that one or more of those might disappear altogether in future. But as long as "Installed" does exist, I think it should be categorized with single-click categories.

Gary Lasker (gary-lasker) wrote :

Thanks for your comments, mpt! I knew that you would have good reasons for these design details and I was just curious about them. I guess "notoriously awful" is not a fair characterization in that it is simply based on my own personal opinion, as well as from hearing the same sentiment from other non-designers that I have talked to. What does user testing show?

Anyway, it was just a question as of course we are not likely to change this anytime soon. I think the fix of making the node expand on a click anywhere in the title is exactly what is needed. Unfortunately, the GTK treeview doesn't work that way by default, but we can add the custom code to do this.

Thanks again!

Gary Lasker (gary-lasker) wrote :

Please take a look at bugs 976062 and 975282. Seems there are at least a couple of other folks who also don't like treeviews. ;)

Gary Lasker (gary-lasker) wrote :

Make that bug 976062 and bug 975282, so we get links that work.

Michael Vogt (mvo) on 2012-04-11
tags: added: treeview ui
Kiwinote (kiwinote) on 2012-04-12
Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2

---------------
software-center (5.2) precise; urgency=low

  [ Michael Vogt ]
  * debian/control:
    - recommend xz-lmza instead of lzma (LP: #878354)
  * lp:~mvo/software-center/track-axi-changes:
    - add a monitor for changes in the apt-xapian-index to ensure
      the DB is reopened if the cron job changes the apt-xapian-index
      database (LP: #507836)
  * lp:~mvo/software-center/lp970342:
    - do not crash if the parent goes away (and therefore the pipe)
      and the token can not be obtained (LP: #970342)
  * lp:~mvo/software-center/lp967036:
    - fix UnicodeDecodeError crash for apps with hardware
      requirements in the details view (LP: #967036)
  * lp:~mvo/software-center/list-a11y:
    - restore the a11y support for orca/accerciser/ldtp for
      the listview and treeview
  * lp:~mvo/software-center/lp979013:
    - fix a bug in the review display for certain language
      environments (LP: #979013)
  * lp:~mvo/software-center/appview-tweaks:
    - code cleanup in the sortmode code
  * lp:~mvo/software-center/lp772549:
    - fix a bug that can result in a blank software center
      screen on startup (LP: #772549)
  * lp:~mvo/software-center/lp914393:
    - adds an explicit sys.exit() to ensure all gtk event
      processing is stopped on application quit (LP: #914393)
  * lp:~mvo/software-center/lp976169:
    - do not crash if apt-xapian-index is not installed
      (LP: #976337)
    - ignore xapian.DatabaseOpeningError here (happens when
      there is no a-x-i so we don't care) (LP: #976169)
  * lp:~mvo/software-center/lp976525:
    - do not show "upgradable" button when there should be "remove"
      (LP: #976525)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/sorting-fix-lp969215:
    - fix sort combo box inconsistencies (LP: #969215)

  [ Dave Morley ]
  * lp:~davmor2/software-center/remove_two_lines:
    - small fixes for test script USC-start-stop-times.py

  [ Kiwinote ]
  * sc/ui/gtk3/widgets/apptreeview.py:
    - everyone tries to expand a category in the installed pane by clicking
      on the text rather than the expander arrow (LP: #877130)
 -- Michael Vogt <email address hidden> Fri, 13 Apr 2012 18:35:13 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers