Ubuntu

English descriptions should distinguish free as in "freedom" or "free beer" to avoid translation issues

Reported by Loris Zinsou on 2011-10-15
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

This may be a translation bug :
Non-free softwares as Adobe Flash Plugin 10 (the package version is flash 11, another bug ?) and skype are marked as "libre", but they are not pieces of free software.
For languages which have two different words for "free" (as in "free beer" or as "freedom"), the translation should be fixed to avoid any confusion.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Normand C (gemnoc) wrote :

We could say that technically, the adobe-flashplugin package IS "libre", since it's an utility that downloads and installs Adobe Flash, not Flash itself. Still this is potentially confusing to users.

But I agree about Skype, this is an obvious mistake.

Searching for the string "Free" in software-store package (https://translations.launchpad.net/software-center/trunk/+pots/software-center/fr/+translate?batch=10&show=all&search=free), it looks like there is only one string for both meaning. So it might not be a problem only related to the translation of the software, but also something missing in the software's conception.

Thibault D (thibdrev) on 2011-10-30
summary: - Adobe Flash Plugin and Skype marked as "libre" (free as in freedom)
- instead of "gratuit" (free as in "free beer")) in french locale
+ English descriptions should distinguish free as in "freedom" or "free
+ beer" to avoid translation issues
Gabor Kelemen (kelemeng) on 2011-11-01
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
Gabor Kelemen (kelemeng) wrote :

We have these occurrences:

#: ../softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:275
#: ../softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:536
#: ../softwarecenter/ui/gtk3/widgets/buttons.py:246
#: ../softwarecenter/ui/gtk3/widgets/buttons.py:248
#: ../softwarecenter/ui/gtk3/widgets/buttons.py:249
msgid "Free"

First two are from this file, and they mean price:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/precise/software-center/precise/view/head:/softwarecenter/ui/gtk3/views/appdetailsview_gtk.py#L275
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/precise/software-center/precise/view/head:/softwarecenter/ui/gtk3/views/appdetailsview_gtk.py#L536

Last three comes from this file, and these mean price too:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/precise/software-center/precise/view/head:/softwarecenter/ui/gtk3/widgets/buttons.py#L246

This means that the French translation should be corrected, and a few translator comments should be added to the source code, so that future confusion can be avoided.

Gabor Kelemen (kelemeng) on 2011-11-01
Changed in ubuntu-translations:
assignee: nobody → Ubuntu French Translators (ubuntu-l10n-fr)
Nicolas Delvaux (malizor) wrote :

@Gabor: This won't work (ie. your change is good but not enough to fix this bug).

In your branch, run "python setup.py build_i18n" and then open the "po/software-center.pot" file.
You will find that there is now:

#. TRANSLATORS: Free here means Gratis
#: ../softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:276
#: ../softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:538
#: ../softwarecenter/ui/gtk3/widgets/buttons.py:247
#: ../softwarecenter/ui/gtk3/widgets/buttons.py:250
#: ../softwarecenter/ui/gtk3/widgets/buttons.py:252
msgid "Free"

So we still can't distinguish the two distinct "Free" in translations.

We need to use Gettext context feature ( http://www.gnu.org/s/hello/manual/gettext/Contexts.html ).
Unfortunately, it seems that Python does not expose this by default, so it needs some work.
(there is some clues in this thread: http://bugs.python.org/issue2504 )

Something easier may be to just change one of these string, eg. to "Gratis", "Free Software" or whatever suit you.

Changed in ubuntu-translations:
assignee: Ubuntu French Translators (ubuntu-l10n-fr) → nobody
Gabor Kelemen (kelemeng) wrote :

Nicolas: which instance would you like to change? To me it seems that all of them means Gratis and none of them means Libre, so we are good with using only one msgid (and telling translators the meaning in a comment), at least for now.

Nicolas Delvaux (malizor) wrote :

Ok, I'm sorry, I was wrong since the beginning in this bug.
(I was sure that the licence value in the app-detail-view was "Free" in English, but in fact it was "Open source" ><)

Sorry for the waste of time and digital ink.
I just fixed the French translation.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.1

---------------
software-center (5.1.1) precise; urgency=low

  [ Matthew McGowan ]
  * fix the rtl rendering of the "more label arrow"
  * lp:~mmcg069/software-center/multi-screenshot-gallery:
    - add support for multiple screenshots for the main archive

  [ Nicolas Delvaux ]
  * lp:~malizor/software-center/fix-lp813803:
    - Time format in historypane: The translators comment was not
      extracted, which led to poor translations (eg. as reported
      in bug LP: #813803)

  [ Gabor Kelemen ]
  * lp:~kelemeng/software-center/bug875306:
    - Add translator comment: Free means Gratis, as it is used as price.
      LP: #875306

  [ Sebastian Heinlein ]
  * lp:~glatzor/software-center/portability:
    - improve portability

  [ Michael Vogt ]
  * more portability fixes
 -- Michael Vogt <email address hidden> Mon, 07 Nov 2011 14:58:40 +0100

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
Gabor Kelemen (kelemeng) on 2011-11-07
Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers