Ubuntu

Adobe flash provided by canonical partner repositories is not 64 bit in the Software centre

Reported by Saurabh Gupta on 2011-10-14
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

 If you enable canonical partner repositories the Ubuntu software center shows Adobe Flash for i386 architecture [adobe-flashplugin:i386 11.0.1.152-0oneiric1] which is 32 bit and not 64 bit. It reports the version as version 11.0.1.152-0oneiric1 in the description but the title says Adobe flash 10 which is another bug in software centre.

To actually obtain Adobe flash 64 bit version 11 for Ubuntu 11.10 go to this link and download the deb manually : http://archive.canonical.com/p... [third link from bottom]

Saurabh Gupta (bhaismachine) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Charles Profitt (cprofitt) wrote :

I used software center and verified that it does report version 10 and used Synaptic to check what was installed and it was marked as the 32bit package.

affects: ubuntu → software-center (Ubuntu)
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
Charles Profitt (cprofitt) wrote :

For those looking for 64bit flash you can download it directly - http://get.adobe.com/flashplayer/

Id2ndR (id2ndr) wrote :

Just run $ sudo apt-get install adobe-flashplugin
which correctly install 64 bits version of flash 11.
You cannot currently do the same with software center.

Amr Ibrahim (amribrahim1987) wrote :

If you search for Adobe Flash in Synaptic, you'll find a different story. There are three different packages, two provided through Ubuntu multiverse (32bit) and one through Canonical Partners (64bit). That's very confusing.

People are giving very bad reviews on Adobe Flash installed from the Software Centre because they're actually installing the 32bit version on their 64bit Ubuntu. The 64bit version is working very good on my 64bit Oneiric.

Daniel Bomar (dbdaniel42) wrote :

Sorry didn't mean to change the status >.<

I didn't even know I could do that. Change back to Triaged please mods and sorry again :(

Changed in software-center (Ubuntu):
status: Triaged → In Progress
status: In Progress → New
status: New → Fix Released
Gary Lasker (gary-lasker) wrote :

Hi Daniel, no worries! I reset the status. :)

Changed in software-center (Ubuntu):
status: Fix Released → Confirmed
importance: Undecided → Low
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers