Featured apps section is broken

Bug #873078 reported by Nicolás Abel Carbone on 2011-10-12
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Kiwinote
Oneiric
Undecided
Unassigned

Bug Description

Since a couple of days ago, the Featured section of Ubuntu Software Center is broken. Only one app, "Braid", is shown occupying the entire banner (sometimes with white borders) and clicking on it has no effect.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: software-center 5.0.1.4
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Wed Oct 12 18:02:41 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
PackageArchitecture: all
SourcePackage: software-center
UpgradeStatus: Upgraded to oneiric on 2011-10-05 (7 days ago)

Matthew Paul Thomas (mpt) wrote :

I can't reproduce this problem. For me, clicking the Braid banner goes to the Braid application screen.

The white borders are partly fixed in trunk, and partly bug 872965.

I am still having this bug. I am the only one? Is there a way I can help debugging this bug? I attached a video showing the bug.

Robert Roth (evfool) wrote :

This is really strange, as I can't reproduce it either, but multiple users have reported this. It might be locale-related, as this has been reported using es_AR, and the duplicate using pl_PL, and I'm using en_US and can't reproduce it, and Matthew is probably also using an English locale, so that could make the difference.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Kiwinote (kiwinote) wrote :

Hi! Thanks for your bug report. The bug you describe has been fixed in the branch I have linked and should be available in the next release. Please continue to report any bugs you may find in software-center. Thanks again for your help!

Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
importance: Undecided → High
status: Confirmed → Fix Committed

Hello Nicolás, or anyone else affected,

Accepted software-center into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in software-center (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Michal Predotka (mpredotka) wrote :

Hi Martin.
It didn't fix this for me. After running USC from command line I get:

michal@michal-Inspiron-530-11:~$ software-center
2011-10-19 14:53:44,217 - softwarecenter.ui.gtk3.em - INFO - EM's: 17 15 21
2011-10-19 14:53:44,877 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2011-10-19 14:53:44,963 - softwarecenter.ui.gtk3.utils - INFO - Softwarecenter style provider for ambiance Gtk theme: /usr/share/software-center/ui/gtk3/css/softwarecenter.css
2011-10-19 14:53:46,486 - softwarecenter.ui.gtk3.app - INFO - software-center-agent finished with status 0
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/utils.py", line 109, in wrapper
    f(*args, **kwargs)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/availablepane.py", line 603, in on_application_activated
    self.display_details_page)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/viewmanager.py", line 151, in display_page
    self.navhistory.append(nav_item)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/navhistory.py", line 41, in append
    LOG.debug("appending: '%s'" % nav_item)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/navhistory.py", line 128, in __str__
    self.view_state)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 4: ordinal not in range(128)
michal@michal-Inspiron-530-11:~$

Line with: “Traceback (most recent call last):” is when I click Braid banner.

Kiwinote (kiwinote) wrote :

Hi mmiicc! Thanks for the feedback - this would indicate that there are multiple issues causing the details view not to load after clicking on the banner. In the proposed version of software-center I only fixed one of the causes, which can be verified by running software-center in portugese (LANGUAGE=pt_PT.utf8 LC_ALL=pt_PT.utf8 software-center). I hope that in a upcoming version of software-center we will be able to fix this other cause too! Thanks again for your help!

Matthew Paul Thomas (mpt) wrote :

mmiicc, that problem seems to be bug 870051.

Michal Predotka (mpredotka) wrote :

mpt, maybe it's related to that bug but, for me, USC has never crashed so far.

zubozrout (zubozrout) wrote :

Hello. Same problem here and on other 3 computers - using Czech language. White strips on the left and top side and if resizing the background on the right side is also white. Link do the exact app (braid, openshot) doesn't work, unless it is the featured apps banner.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.0.2

---------------
software-center (5.0.2) oneiric-proposed; urgency=low

  [ Matthew McGowan ]
  * lp:~mmcg069/software-center/bug861778:
    - improved method, use less widgets and fix case where user
      changes sort method in a search results list (LP: #861778)
  * lp:~mmcg069/software-center/dialog-improvements:
    - improve the widget packing of the submit_review dialog
    - make the dialog-dep-warning dialog neither closable or maximisable
      as per bug LP: #844025
    - make dialog-dependency-alert dialog use a gtkgrid instead of
      gtktable to fix overly big spacing
  * lp:~mmcg069/software-center/container-frame-render-fix:
    - remove the use a clip -> provide a fix for blurry font
      rendering LP: #864855

  [ Michael Vogt ]
  * test/gtk3/test_appview.py:
    - add regression test for bug #861778
  * test/gtk3/test_dialogs.py:
    - add basic test for dependency dialogs
  * softwarecenter/ui/gtk3/dialogs/dependency_dialogs.py:
    - simplfy test setup code
  * softwarecenter/backend/channel_impl/aptchannels.py:
    - delay channel update check 10s to improve startup time
  * softwarecenter/ui/gtk3/widgets/exhibits.py:
    - add workaround for rendering bug of the webkit offscreen window
      that leaves a 8px border around the image
  * debian/control:
    - update Vcs-Bzr to point to the 5.0 branch
    - add "lzma" to the recommends to ensure that opening opera and
      chrome debs works (LP: #868188). python-apt is expecting to
      have a helper that can be called with "lzma -d" to open these
      debs.

  [ Kiwinote ]
  * softwarecenter/db/update.py,
    softwarecenter/enums.py,
    softwarecenter/ui/gtk3/models/appstore2.py:
    - make apps from the canonical store appear in the categories (LP: #874330)
  * softwarecenter/ui/gtk3/panes/availablepane.py:
    - when search is cleared, don't navigate back to lobby if we're in a
      channel view (LP: #875786)
  * softwarecenter/ui/gtk3/panes/viewswitcher.py:
    - don't inherit state.category or state.subcategory upon channel selection
  * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - fix UnicodeDecodeError in _update_pkg_info_table() (LP: #868834)
      this indirectly makes banners work again in certain locales (LP: #873078)

  [ Robert Roth ]
  * Only catch button release in exhibit if button was also pressed on
    exhibit (LP: #875043)

  [ Gary Lasker ]
  * softwarecenter/db/update.py:
    - fix reinstall previous purchases functionality for locales
      that require unicode (LP: #873917)
  * setup.py:
    - force 11.10 as the release as this is the target
      version of 5.0
 -- Michael Vogt <email address hidden> Tue, 18 Oct 2011 17:43:01 +0200

Changed in software-center (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Michal Predotka (mpredotka) wrote :

Sorry, but I use version 5.0.2 and this bug is not fixed.

Gary Lasker (gary-lasker) wrote :

Hi mmiicc, indeed, the traceback that you provided in comment #8 suggests that the Featured Apps section is not working for you due to a separate bug 847050, as mentioned by mpt in comment #10 (note that in his comment he cites bug 870051, but this is simply a dupe of bug 847050).

Please monitor bug 847050 for the status of the fix for that bug. Currently, the fix for this is in progress, and will be available in the next update to Software Center.

Thank you for your help!

Michal Predotka (mpredotka) wrote :

Gary, thanks for explanation.

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers