Hardware mouse 'back key' doesn't work always in USC

Bug #871810 reported by Thibaut Brandscheid on 2011-10-10
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

software-center 5.0.1.4, 5.0.1.5, Ubuntu 11.10
software-center 13.10, Ubuntu 14.04

With a mouse that has a Back button:

1. From the main screen, click any department or app, then click "All Software", so that you have screens to go Back to.

2. Click the Back mouse button over an empty part of the window content.

    What happens: USC navigates back, as it should.

3. Click "All Software" to return to the home screen.

4. Click the Back mouse button over any of these areas:
    - A toolbar button
    - "Our star apps"
    - An app in the "What's New" area
    - An app in the "Top Rated" area

    What happens: The Back click is treated as a primary click (e.g. left click).
    What should happen: USC navigates back.

5. Click the actual Back button in the toolbar twice.

6. Click the Forward mouse button over an empty part of the window content.

    What happens: USC navigates forward, as it should.

7. Click the Forward mouse button over a toolbar button.

    What happens: The Forward click is treated as a primary click (e.g. left click).
    What should happen: USC navigates forwards.

description: updated
Matthew Paul Thomas (mpt) wrote :

As far as I know, this was fixed in 4.1.22 (bug 660050). Are you saying that there are other places in USC where the mouse's Back button does work for you?

I use USC 5.0.1.4 Oneiric 64-Bit up-to-date Unity 3D in VirtualBox.

Yes, mouse back button doesn't work everywhere in USC.
My bug report is a duplicate of #660050.
I'll try to describe the bug more precise in the other bug report now.

description: updated

Just updated my main system to oneiric 64-bit and have the same problems than before in virtual box.

apport information

tags: added: apport-collected oneiric running-unity
description: updated

apport information

apport information

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Unfortuantely my mouse does not have a "mouse-back-button". Does anyone know of a way to simulate this without
the hardware button?

Changed in software-center (Ubuntu):
importance: Undecided → Low
summary: - Mouse 'back key' doesn't work always in USC
+ Hardware mouse 'back key' doesn't work always in USC

I figured out how to emulate mouse back/forward clicks

sudo apt-get install xbindkeys xvkbd
xbindkeys --defaults >> ~/.xbindkeysrc

add to '~/.xbindkeysrc':
# mouse left = back
"/usr/bin/xvkbd -text '\[Alt_L]\[Left]'"
  Control + b:1

# mouse right = forward
"/usr/bin/xvkbd -text '\[Alt_L]\[Right]'"
Control + b:3

refresh:
pkill -f xbindkeys; xbindkeys

more: https://wiki.archlinux.org/index.php/Logitech_MX_Revolution

Robert Roth (evfool) wrote :

From duplicate bug #944315, some more issues with the mouse back button, to be seen on the Details page:

What happens:
When pressing the mouse back button in the upper button bar:
1. in a non-button area, software-center doest react at all.
2. on top of a button, a left click is performed.

see attachmened image: https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/944315/+attachment/2798594/+files/back-button_bug.png

What you expected to happen:
When pressing the mouse back button the 'back' action should always be
preformed whatever region the mouse pointer is above in the software-center.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

dino99 (9d9) wrote :

That version is no more maintained

Changed in software-center (Ubuntu):
status: Confirmed → Invalid
Matthew Paul Thomas (mpt) wrote :

Duplicate bug 944315 is from Ubuntu 12.04, which is still maintained.

Changed in software-center (Ubuntu):
status: Invalid → Confirmed
description: updated
dino99 (9d9) wrote :

@mpt

if you find time to unset the reports that i have declared as 'invalid', you should also have time to read the reporter comment #9 above for example here which give the real issue and the solution used to fine tune his mouse. I suppose you are also able to understand that 'software-center' is absolutly not concerned in such a case.

Hope you will better use your own time and stop waisting mine.

Changed in software-center (Ubuntu):
status: Confirmed → Invalid
Matthew Paul Thomas (mpt) wrote :

dino99, the comment you refer to was an answer to Michael's question about how to emulate the button clicks to reproduce the problem. It was not "the real issue" or a solution for the problem.

Anyway, I've just borrowed a mouse with Back+Forward buttons, and reproduced the problem in Ubuntu 14.04. In addition to the areas highlighted by Robert Roth, the Back button is also incorrectly treated as a primary-click on apps in the "What's New" and "Top Rated" apps on the home screen -- but oddly, not on the "Top Rated" apps in a section screen like "Games". The Forward button seems to be incorrectly treated as a primary-click only on the toolbar.

Changed in software-center (Ubuntu):
status: Invalid → Triaged
description: updated
tags: added: wily
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers