Failed to edit review

Bug #870847 reported by Dereck Wonnacott on 2011-10-08
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Michael Vogt
Precise
High
Michael Vogt

Bug Description

[Test Case]
- open software-center
- write a review
- once it appears click on "edit" on the review
- edit it and submit again
- verify failure

- install fix
- repeat steps
- verify it works now

Ubuntu Software Centre 5.2.4, Ubuntu 12.04

Today I tried to change a review that I had done earlier and when I clicked the Modify button, an error came up "Failed to Edit Review"

I wish I could copy and paste the error, but I can't select it. The control is disabled.... I suppose I would also like to add a wishlist item that if I have an error I'd like to be able to select it and copy it so i can put it in the bug report without typing it out in the future. :P I'm sorry for being picky.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: software-center 5.0.1.4
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Sat Oct 8 12:56:52 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: Upgraded to oneiric on 2011-09-30 (7 days ago)

Dereck Wonnacott (dereck) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed

I get the same thing: it fails every time. Both for reviews I wrote a half-year ago and ones I just wrote. I've attempted to edit reviews a few times over the last week so this is not intermittent.

Error details:

"Unknown error communicating with server. Check your log and consider raising a bug report if this error persists".

What logs should I be looking for?

Dylan McCall (dylanmccall) wrote :

Here's stdout and stderr from running software-center in a terminal, annotated with # to show what I'm doing at each point:

2012-04-28 15:19:00,325 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2012-04-28 15:19:00,330 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-04-28 15:19:19,787 - softwarecenter.db.database - INFO - reopen() database
2012-04-28 15:19:19,787 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-04-28 15:19:27,410 - softwarecenter.ui.gtk3.gmenusearch - WARNING - could not load GMenu path: Failed to look up menu_file for "settings.menu"

# I click the Edit Review dialog
(software-center:11803): Gtk-WARNING **: Unable to show 'none': Operation not supported
# Edit Review dialog is visible
# Attempting to submit modification. Error is displayed: "Unknown error communicating with server. Check your log and consider raising a bug report if this error persists")
# Closed Edit Review dialog
2012-04-28 15:19:36,251 - softwarecenter.ui.gtk3.app - INFO - software-center-agent finished with status 0
2012-04-28 15:19:36,252 - softwarecenter.db.database - INFO - reopen() database
2012-04-28 15:19:36,252 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-04-28 15:19:36,375 - softwarecenter.ui.gtk3.gmenusearch - WARNING - could not load GMenu path: Failed to look up menu_file for "settings.menu"

2012-04-28 15:20:57,928 - softwarecenter.backend.spawn_helper - WARNING - exit code 1 from helper for '['/usr/share/software-center/modify_review_gtk3.py', '--parent-xid', '', '--iconname', 'psensor', '--datadir', '/usr/share/software-center/', '--review-id', '43043']'
2012-04-28 15:20:57,928 - softwarecenter.backend.spawn_helper - WARNING - got error from helper: '
(modify_review_gtk3.py:11843): Gtk-WARNING **: Unknown property: GtkGrid.n-rows

(modify_review_gtk3.py:11843): Gdk-CRITICAL **: gdk_window_invalidate_rect_full: assertion `GDK_IS_WINDOW (window)' failed

(modify_review_gtk3.py:11843): Gdk-CRITICAL **: gdk_window_invalidate_rect_full: assertion `GDK_IS_WINDOW (window)' failed
modify_review
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/ui/gtk3/review_gui_helper.py", line 242, in _submit_modify_if_pending
    rating=rating)
  File "/usr/lib/python2.7/dist-packages/piston_mini_client/validators.py", line 65, in wrapper
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/piston_mini_client/validators.py", line 65, in wrapper
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/piston_mini_client/validators.py", line 44, in wrapper
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/piston_mini_client/validators.py", line 40, in wrapper
    pattern))
ValidationException: Argument 'review_text' must match pattern '[^\n]+$'
Argument 'review_text' must match pattern '[^\n]+$'
'

Jesús Morales (jesusmorales) wrote :

I think Bug #996280 is a duplicate of this one.
Anyone knows how to fix this yet? Didn't know it was this old.

Francis Chin (chinf) wrote :

I got the same error (Ubuntu Software Centre 5.2.4 on Ubuntu 12.04).

I got the same Traceback as Dylan in my .xsession-errors log.

My edited review had newlines in it, so I tried removing them and retrying, and it worked. Looks like an incorrect regexp in the code.

description: updated
Changed in software-center (Ubuntu):
importance: Undecided → Medium
tags: added: ca-escalated
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Gary Lasker (gary-lasker)
Gary Lasker (gary-lasker) wrote :

Thanks everyone. We have a fix for this planned and I will work on this soon. I appreciate everyone's help and comments, these clarified the issue nicely!

Best,
Gary

Michael Vogt (mvo) wrote :

While doing a review of the ca-escalated bugs I came accross this one and realized that currently modify_review is not working at all AFAICT for anyone and any review. I bumped the priority therefore.

Changed in software-center (Ubuntu):
assignee: Gary Lasker (gary-lasker) → nobody
status: Triaged → In Progress
Changed in software-center (Ubuntu Precise):
status: New → In Progress
Changed in software-center (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
Changed in software-center (Ubuntu Precise):
assignee: nobody → Michael Vogt (mvo)
importance: Undecided → High
Changed in software-center (Ubuntu):
importance: Medium → High
Michael Vogt (mvo) on 2012-08-17
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.3.7

---------------
software-center (5.3.7) quantal; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/cleanup-in-config-code:
    - consolidate and simplify config handling for
      all configuration values
  * lp:~mvo/software-center/distro-detection-robustness:
    - tweak the distro detection to make it more robust
      against changes in the case for the plattform string
      and also makes the filenames/classnames more pythonic
  * lp:~mvo/software-center/fix-seperator-crash:
    - remove instance of self.separator_login as we do not
      use this anymore, prevents a crash
  * lp:~mvo/software-center/improve-test-for-config:
    - additional unit tests for the config handling code
  * lp:~mvo/software-center/set-ssl-stuff-in-webkitwidget:
    - move the webkit.py file into 'widgets' and consolidate
      all of the webkit settings there
  * lp:~mvo/software-center/use-lxml:
    - use python-lxml instead of xml.etree as the former is
      quite a bit faster
  * lp:~mvo/software-center/new-pep8 :
    - use pep8 comandline instead of "import pep8" to make it work again
      on quantal where the internal API of pep8 has changed
  * merged 5.2 branch that includes fix for LP: #1026494
  * lp:~mvo/software-center/cache-for-parse-applications-menu:
    - cache the result of parse_applications menu so it is run
      only once for better startup performance
  * lp:~mvo/software-center/lp913966:
    - support the new gnome 3 in the "where is it" feature
      (LP: #913966)
  * lp:~mvo/software-center/add-currency-property:
    - add a "currency" property to the appdetails and use
      it in the UI
  * lp:~mvo/software-center/no-piston-data-means-error:
    - if we don't get data at all from the webservice/cache in
      piston-generic-helper, emit a error signal
  * lp:~mvo/software-center/rec-small-cleanup:
    - small duplication cleanup
  * lp:~mvo/software-center/dep8:
    - enable automatic dep8 based testsuite running
      on the remote server
  * lp:~mvo/software-center/fix-new-pep8:
    - fix all pep8 issues in quantal branch test
  * softwarecenter/db/categories.py, tests/test_categories.py:
    - do not use cached categories in tests
  * lp:~mvo/software-center/lobby-testfixes:
    - fix tests when categories cache is used with multiple DBs
  * lp:~mvo/software-center/fix-lp870847-5.2:
    - fix incorrect validation pattern in modify_review call, this
      should fix the ablity of users to modify their reviews
      (LP: #870847)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/fix-purchaseview-test:
   - fix the purchase view unit test to conform to the new config
     code
  * lp:~gary-lasker/software-center/display-cached-recommendations:
   - display cached recommendations in the lobby view in the case of
     no network access
  * lp:~gary-lasker/software-center/rec-tiny-cleanup:
    - additional bit of cleanup in the recommendations UI code
  * lp:~gary-lasker/software-center/fix-new-pep8-precise-fix:
    - small fix to allow trunk to continue to run on Precise
 -- Michael Vogt <email address hidden> Fri, 17 Aug 2012 11:57:20 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
Michael Vogt (mvo) wrote :

This is in the precise-proposed queue now and will get released to precise-proposed when the SRU team had a chance to look at it.

Hello Dereck, or anyone else affected,

Accepted software-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/software-center/5.2.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-center (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
description: updated

I was able to submit a comment (to cheese) and edit it too.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2.6

---------------
software-center (5.2.6) precise-proposed; urgency=low

  * lp:~mvo/software-center/fix-lp870847-5.2:
    - fix incorrect validation pattern in modify_review call, this
      should fix the ablity of users to modify their reviews
      (LP: #870847)
  * test/gtk3/test_catview.py:
    - skip some automatic tests are depend on host system state
 -- Michael Vogt <email address hidden> Mon, 27 Aug 2012 12:03:48 +0200

Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers