software-center crashed with ValueError in get_iter(): invalid tree path '1:64'

Bug #870207 reported by Paolo on 2011-10-07
104
This bug affects 20 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned

Bug Description

...

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 5.0.1.3
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: wl fglrx
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Fri Oct 7 20:29:01 2011
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with ValueError in get_iter(): invalid tree path '1:64'
UpgradeStatus: Upgraded to oneiric on 2011-10-06 (0 days ago)
UserGroups: adm admin cdrom dialout dip fax floppy fuse lpadmin plugdev sambashare tape video

Paolo (paolomon) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
visibility: private → public
Michael Vogt (mvo) wrote :

This is a pretty common error according to errors.ubuntu.com so we need to SRU a fix.

Changed in software-center (Ubuntu):
importance: Undecided → Medium
tags: added: ca-escalated
Changed in software-center (Ubuntu):
milestone: none → precise-updates
tags: added: precise
Michael Vogt (mvo) wrote :

Apparently happens on install/remove in the appdetailsview according to the info from the dupes.

Changed in software-center (Ubuntu):
importance: Medium → High
tags: removed: ca-escalated
Michael Vogt (mvo) wrote :

Re-adding ca-escalated as this is the nr. 5 on errors.ubuntu.com in the software-center page.

tags: added: ca-escalated
Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
Matthew Paul Thomas (mpt) wrote :

Reproduced in USC 5.3.10.

Changed in software-center (Ubuntu):
status: Fix Released → Confirmed

It's on Quantal with the newest updates.

Josef Andersson (northar) wrote :

Tried to remove a package in softwarecenter Quantal latest updates, x64. Get this

Roberto Alsina (ralsina) on 2013-01-22
Changed in software-center (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
dino99 (9d9) on 2013-07-08
tags: removed: oneiric
dobey (dobey) on 2014-01-29
Changed in software-center (Ubuntu):
assignee: Rodney Dawes (dobey) → nobody
bluescreen (s-drei) wrote :

Gotta love the error reporting system. In Trusty Tahr I am having a mild issue with the software center crashing apparently whenever it is maximized on screen and click the Close icon in its menu bar, not happening if I unmaximize it first.
Error report said this is the bug, nothing new. whateva

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers