software-center crashed with AttributeError in clear_model(): 'NoneType' object has no attribute 'clear'

Bug #869699 reported by gunamja on 2011-10-07
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

I don't know well

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 5.0.1.3
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: wl nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Fri Oct 7 14:06:14 2011
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 LANG=ko_KR.UTF-8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with AttributeError in clear_model(): 'NoneType' object has no attribute 'clear'
UpgradeStatus: Upgraded to oneiric on 2011-10-05 (2 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

gunamja (petal14) wrote :

This crash has the same stack trace characteristics as bug #863233. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: removed: need-duplicate-check
tags: added: regression-retracer
Michael Vogt (mvo) on 2011-10-07
Changed in software-center (Ubuntu):
status: New → Fix Committed
importance: Undecided → Medium
visibility: private → public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.0.1.4

---------------
software-center (5.0.1.4) oneiric; urgency=low

  * softwarecenter/ui/gtk3/widgets/apptreeview.py:
    - do not crash if self.appmodel is not available yet (LP: #869699)
  * softwarecenter/db/update.py:
    - fix missing i18n lookup for app-install-data (LP: #869851)
  * merge po/help from rosetta to ensure that the translated
    manual is there, this is not delivered via langpacks
    (LP: #869935)
  * test/test_database.py:
    - use sc.staging.ubuntu.com for the testing of the license
      string data
  * softwarecenter/db/application.py:
    - fix missing i18n for license send from the software-center-agent
      server
 -- Michael Vogt <email address hidden> Fri, 07 Oct 2011 16:24:53 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers