software-center crashed with AttributeError in license(): 'NoneType' object has no attribute 'get_value'

Bug #868333 reported by Thomas Horsten on 2011-10-05
180
This bug affects 21 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Gary Lasker
Oneiric
High
Gary Lasker
Precise
High
Unassigned

Bug Description

I tried to install Chrome as downloaded from Google. But it crashes every tmie when I try to open the deb file !!!!

It was the 64 bit version of Chrome.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 5.0.1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Wed Oct 5 13:57:32 2011
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/pyusernameon /usr/bin/software-center /home/username/Downloads/google-chrome-stable_current_amd64.deb
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center', '/home/username/Downloads/google-chrome-stable_current_amd64.deb']
SourcePackage: software-center
Title: software-center crashed with AttributeError in license(): 'NoneType' object has no attribute 'get_value'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Thomas Horsten (thomas-horsten) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Gary Lasker (gary-lasker)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.0.1.1

---------------
software-center (5.0.1.1) oneiric; urgency=low

  * softwarecenter/db/application.py:
    - fix crash when installing a standalone deb (LP: #868333)
 -- Gary Lasker <email address hidden> Wed, 05 Oct 2011 11:07:40 -0400

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
tags: added: bugpattern-needed
Jean-Baptiste Lallement (jibel) wrote :

I'm reopening this report, it is still an issue with 5.0.1.2 as reported in bug 869079.

Changed in software-center (Ubuntu):
status: Fix Released → In Progress
Changed in software-center (Ubuntu Oneiric):
milestone: none → oneiric-updates
Changed in software-center (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
Michael Vogt (mvo) wrote :

The stacktrace from bug 869079 does not match what is in the fixed package:

  File "/usr/share/software-center/softwarecenter/db/application.py", line 339, in license
    xapian_license = self._doc.get_value(XapianValues.LICENSE)
AttributeError: 'NoneType' object has no attribute 'get_value'

In line 339 of that file in the current oneiric it reads:
   xapian_license = None

I'm not sure how 869079 got the version, but its clearly not matching the fixed file that is in
the archive but instead matching the old unfixed version. The only explaination I have is that
the crash happend with the older version but then update-manager came along and upgraded the
system so that apport got the new version when querying the dpkg database.

Changed in software-center (Ubuntu Oneiric):
status: In Progress → Incomplete
Changed in software-center (Ubuntu Precise):
status: In Progress → Incomplete
Brian Murray (brian-murray) wrote :

Michael your explanation matches apport bug 794190.

Gary Lasker (gary-lasker) wrote :

Michael's explanation and Brian's additional information seem to indeed explain this. Furthermore, we have not had additional dupes for this bug (where we were getting them fairly regularly before), so by all appearances this bug was fixed in the specified package.

Based on this, I'll re-close the bug at this point.

Thanks everyone!

Changed in software-center (Ubuntu Oneiric):
status: Incomplete → Fix Released
Changed in software-center (Ubuntu Precise):
status: Incomplete → Invalid
Changed in software-center (Ubuntu Oneiric):
milestone: oneiric-updates → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers