Mushy/blurry/jagged fonts in software center

Bug #864855 reported by tsg1zzn on 2011-10-02
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Matthew McGowan
Oneiric
Undecided
Unassigned

Bug Description

Some of the font rendering in software center is horrible. I will attach a screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: software-center 5.0
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Sun Oct 2 22:25:37 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

tsg1zzn (tsg1zzn) wrote :
tsg1zzn (tsg1zzn) wrote :
Matthew McGowan (mmcg069) wrote :

Hi tsg1zzn,

Thanks for the bug report. could you let me know what resolution and font-size your desktop is using?

tsg1zzn (tsg1zzn) wrote :

Resolution: 1024x768
Font: Ubuntu size 9

When I turn off font antialiasing it looks normal (except it lacks antialiasing of course).

Matthew McGowan (mmcg069) wrote :

Hi again tsg1zzn,

Thanks for the prompt response.

I think i may have found the culprit. I'll push a branch in the next few days. If you could test it and confirm it provides a fix that would be much appreciated.

Matthew McGowan (mmcg069) wrote :

I have now linked the branch to this bug which hopefully contains a fix.

Changed in software-center (Ubuntu):
status: New → Confirmed
status: Confirmed → In Progress
assignee: nobody → Matthew McGowan (mmcg069)

Hello tsg1zzn, or anyone else affected,

Accepted software-center into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in software-center (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
tsg1zzn (tsg1zzn) wrote :

I installed the new version and it looks much better but far from perfect. I see cairo is used for the drawing, maybe this is a bug in cairo?

Adolfo Jayme (fitojb) wrote :

@tsgzzn: What’s the exact rendering problem that are you facing?

For me, the problem is fixed in the proposed version.

tags: added: verification-done
removed: verification-needed
tsg1zzn (tsg1zzn) wrote :

It just doesn't look smooth like other text.

Matthew McGowan (mmcg069) wrote :

We use the Gtk.render_layout so text should be rendered as other Gtk.Labels would be rendered.

2 things,

please ensure you are testing the correct branch, either of the three linked branches.

the other thing to point out is that you have your font set to 9, on my system i have 11, i assume this is the default value as i have not tweaked the font size value. The text you are complaining about as blurry is intended to be "small" relative to the normal text (in your case, size 9 font). It looks as if at font size 9, this smallness, coupled with the bold weight is causing what you consider the blurriness.

If you could try a larger application font size, perhaps even just increasing to 10, and see how things look for you?

tsg1zzn (tsg1zzn) wrote :

How would I know whether I'm testing the correct branch? I was linked to here: https://wiki.ubuntu.com/Testing/EnableProposed and did as it told. I now have 5.0.2 installed.

Matthew McGowan, what exactly is it that you are saying about the fonts? Can you not see on the screenshot that the text "View" (in the menu) and the text "Games" (in the window) have the same pixel size (8 pixels high) but have different gamma correction? I know it _should_ be rendered as other gtk labels, but it _isn't_. That's what this bug is about.

I made a gtk label in Glade and pasted a screenshot of it right next to the offending text in the software. To me, it's very obvious that the text is wrong, even though the size is the same. It is definetely not because of the small font. Even if I select a smaller UI font, fonts in other applications only get smaller - they don't get uglier.

I don't understand what you mean by saying the text is intended to be small compared to the default font - it's not. The text I circled seems to have normal font size. However, the categories pane on the left, has a smaller font. Which I also dislike. I selected "Ubuntu 9" for the UI font because _that's the font I'd like to be used for UI_. I don't see any good reason to disregard the user's preferences.

Adolfo Jayme (fitojb) wrote :

@tsg1zzn: I already have Ubuntu at 9 pt. The “problem” is not blurriness. It’s just that fonts in caruosels (What’s New and Top Rated) are 8 pt size and not 9.

Change your system font to Ubuntu 8, you’ll see all labels rendered the same. If you didn’t notice the rendering, you can open xmag in a terminal to open a magnifier.

Matthew McGowan (mmcg069) wrote :

Apologies, tsg1zzn if i came of a bit blunt. that wasn't my intention.

tsg1zzn (tsg1zzn) wrote :

Matthew McGowan, that's ok, I think I was more blunt than you.

Fitoschido, I tried changing the UI font to 8pt, and it only gets smaller - not blurry as the font in software center. It could be that I still have the wrong version installed, but there is no doubt that on my computer, there is a difference either in the way the font is rendered, or in the way it's blended onto the background.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.0.2

---------------
software-center (5.0.2) oneiric-proposed; urgency=low

  [ Matthew McGowan ]
  * lp:~mmcg069/software-center/bug861778:
    - improved method, use less widgets and fix case where user
      changes sort method in a search results list (LP: #861778)
  * lp:~mmcg069/software-center/dialog-improvements:
    - improve the widget packing of the submit_review dialog
    - make the dialog-dep-warning dialog neither closable or maximisable
      as per bug LP: #844025
    - make dialog-dependency-alert dialog use a gtkgrid instead of
      gtktable to fix overly big spacing
  * lp:~mmcg069/software-center/container-frame-render-fix:
    - remove the use a clip -> provide a fix for blurry font
      rendering LP: #864855

  [ Michael Vogt ]
  * test/gtk3/test_appview.py:
    - add regression test for bug #861778
  * test/gtk3/test_dialogs.py:
    - add basic test for dependency dialogs
  * softwarecenter/ui/gtk3/dialogs/dependency_dialogs.py:
    - simplfy test setup code
  * softwarecenter/backend/channel_impl/aptchannels.py:
    - delay channel update check 10s to improve startup time
  * softwarecenter/ui/gtk3/widgets/exhibits.py:
    - add workaround for rendering bug of the webkit offscreen window
      that leaves a 8px border around the image
  * debian/control:
    - update Vcs-Bzr to point to the 5.0 branch
    - add "lzma" to the recommends to ensure that opening opera and
      chrome debs works (LP: #868188). python-apt is expecting to
      have a helper that can be called with "lzma -d" to open these
      debs.

  [ Kiwinote ]
  * softwarecenter/db/update.py,
    softwarecenter/enums.py,
    softwarecenter/ui/gtk3/models/appstore2.py:
    - make apps from the canonical store appear in the categories (LP: #874330)
  * softwarecenter/ui/gtk3/panes/availablepane.py:
    - when search is cleared, don't navigate back to lobby if we're in a
      channel view (LP: #875786)
  * softwarecenter/ui/gtk3/panes/viewswitcher.py:
    - don't inherit state.category or state.subcategory upon channel selection
  * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - fix UnicodeDecodeError in _update_pkg_info_table() (LP: #868834)
      this indirectly makes banners work again in certain locales (LP: #873078)

  [ Robert Roth ]
  * Only catch button release in exhibit if button was also pressed on
    exhibit (LP: #875043)

  [ Gary Lasker ]
  * softwarecenter/db/update.py:
    - fix reinstall previous purchases functionality for locales
      that require unicode (LP: #873917)
  * setup.py:
    - force 11.10 as the release as this is the target
      version of 5.0
 -- Michael Vogt <email address hidden> Tue, 18 Oct 2011 17:43:01 +0200

Changed in software-center (Ubuntu Oneiric):
status: Fix Committed → Fix Released
mete han (mete-han) wrote :

hi. rookie speaking :)

I have the mushy/blurry/jagged fonts not only in software center, but in all tabs/menus (i.e the names of the launcher icons when you put the cursor on the icon, the upper right menu list which has "shut down" etc.) It starts normal, after a while I boot in they become horrible, additionally, the performance is very low. now i am in recovery mode and fonts keep normal, and the performance is very well I must say. but the resolution is 1024*768 there are no greater options. I have 1400*900 screen. that option and many other settings' options (i.e appearance options) are missing.

I have a P4, 512 mb RAM pc, sorry if it is too ridiculus to try to use Oneiric with this pc. thanks in advance.

Adolfo Jayme (fitojb) wrote :

@mete-han: If you don't have a comment that it is directly related to this (closed) bug report, please don't spam our inboxes with comments that do not have nothing to do with this. If you want to report a bug, file a concise, separate one.

mete han (mete-han) wrote :

@fitoschido: sorry for inconvience. thought it was related, may be not directly. sorry again.

Adolfo Jayme (fitojb) wrote :

@mete-han: Don't worry, but I think your issues are more related to FreeType or Cairo than software-center ;-)

Adolfo Jayme (fitojb) on 2012-04-16
Changed in software-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers