On new Ubuntu installation, "What's New" and "Top Rated" on home screen are confused

Bug #862382 reported by Matthew Paul Thomas on 2011-09-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu Software Center 4.1.23.4, Ubuntu 11.10 beta 2

1. Install Ubuntu without choosing the "Download updates while installing" option.
2. Restart into Ubuntu.
3. Launch Ubuntu Software Center.

What you see:
* "What's New" shows as an empty box.
* "Top Rated" shows not the top rated items, but the newest items.

What you should see:
* "What's New" shows the newest items.
* "Top Rated" shows the top rated items.

Matthew Paul Thomas (mpt) wrote :
description: updated
summary: - "What's New" shows as empty box on new Ubuntu installation
+ On new Ubuntu installation, "What's New" and "Top Rated" on home screen
+ are confused
Changed in software-center (Ubuntu):
importance: Undecided → Medium
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I can reproduce this and I fixed the empty new section on a fresh install now by just hidding it if we have no data. That
seems to be the least risky change at this point.

In the first screenshot the top rated its not actually sorted by "newness" but instead by randomness, there is no data on either new nor rating available at this point.In the second screenshot what appears to be "new" is again more or less random as at this point all applications have the same "cataloged time" value (the data/time of the fresh install).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.0.1

---------------
software-center (5.0.1) oneiric; urgency=low

  [ Michael Vogt ]
  * softwarecenter/ui/gtk3/widgets/reviews.py:
    - Fix i18n bug in the error string for the reviews. This
      adds two new strings for a rare error message in the UI that
      was previously not translatable. Thanks to David Planella
  * softwarecenter/db/database.py:
    - when adding a new database (e.g. on reinstall-previous purchases)
      trigger a "reopen" to ensure that the db docids are reinitialized
  * apt-xapian-index-plugin/software-center.py:
    - do not crash if a apt.Package.candidate has no url (LP: #819907)
  * softwarecenter/ui/gtk3/views/catview_gtk.py:
    - only show the frame with new apps if we actually have information
      about new applications (LP: #862382)

  [ Robert Roth ]
  * softwarecenter/ui/gtk3/widgets/apptreeview.py:
    - fix crash in clear_model() (LP: #863233)

  [ Gary Lasker ]
  * debian/control:
    - add dependency on python-gobject-cairo to prevent crash
      at startup (LP: #829067)
  * softwarecenter/db/application.py,
    softwarecenter/db/update.py,
    softwarecenter/distro/Ubuntu.py,
    softwarecenter/enums.py:
    - display the correct license type for commercial apps as
      specified via the software-center-agent (LP: #864706)

  [ Matthew McGowan ]
  * lp:~mmcg069/software-center/bug855666:
    - add missing linewrap (LP: #855666)
  * lp:~mmcg069/software-center/bug858639 :
    - fix crash when data can not be parsed from the remote reviews server
      LP: #858639
 -- Michael Vogt <email address hidden> Wed, 05 Oct 2011 11:24:05 +0200

Changed in software-center (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers