software-center crashed with AttributeError in _on_button_pressed(): 'NoneType' object has no attribute 'cancel'

Bug #861129 reported by miked on 2011-09-28
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Gary Lasker

Bug Description

win7 wubi amd64 11.04 install upgraded to Oneiric Ocelot. 11.10 beta 1/2 now.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.23.5
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Sat Sep 24 23:04:13 2011
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center /root/Downloads/virtualbox-4.1_4.1.2-73507~Ubuntu~natty_amd64.deb
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center', '/root/Downloads/virtualbox-4.1_4.1.2-73507~Ubuntu~natty_amd64.deb']
SourcePackage: software-center
Title: software-center crashed with AttributeError in _on_button_pressed(): 'NoneType' object has no attribute 'cancel'
Traceback:
 Traceback (most recent call last):
   File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/pendingpane.py", line 106, in _on_button_pressed
     trans.cancel()
 AttributeError: 'NoneType' object has no attribute 'cancel'
UpgradeStatus: Upgraded to oneiric on 2011-09-12 (16 days ago)
UserGroups: admin

miked (miked11) wrote :
visibility: private → public

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #805158, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check
Gary Lasker (gary-lasker) wrote :

Hmm, nope, this is actually not a dupe of bug 805158. Changing that.

miked (miked11) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Matthew McGowan (mmcg069) wrote :

Looking at the code, it would seem this had been fixed somewhat.

Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
Changed in software-center (Ubuntu):
status: Fix Committed → In Progress
importance: Undecided → Low
assignee: nobody → Gary Lasker (gary-lasker)
Gary Lasker (gary-lasker) wrote :

Hey Matt, referring to your comment, I've attached a branch where I generalized the exception handler for this case, just to be a bit more robust about errors (including the one reported in this bug) when attempting to cancel a transaction from the pending view.

Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.0.1.3

---------------
software-center (5.0.1.3) oneiric; urgency=low

  [ Gary Lasker ]
  * softwarecenter/ui/gtk3/panes/pendingpane.py:
    - be more robust about errors when cancelling a transaction
      from the pending pane (LP: #861129)
  * softwarecenter/ui/gtk3/app.py:
    - fix crash in on_menu_edit_activate() (LP: #861862)
  * softwarecenter/ui/gtk3/panes/installedpane.py:
    - fix crash in _row_visibility_func() (LP: #834893)
  * softwarecenter/ui/gtk3/views/appview.py:
    - fix crash in display_matches() (LP: #843795)

  [ Michael Vogt ]
  * softwarecenter/ui/gtk3/widgets/buttons.py:
    - fix incorrect i18n for the "More" button in the main screen
      (LP: #868952), thanks to David Planella
  * softwarecenter/db/categories.py:
    - fix regression when reading translated category names for
      directory types with no X-Ubuntu-Gettext-Domain (LP: #868963)

  [ Gabor Kelemen ]
  * Translate Our star apps heading on the list of the star apps.
    LP: #869038
 -- Michael Vogt <email address hidden> Thu, 06 Oct 2011 14:35:02 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers