piston_get_reviews_helper.py crashed with AttributeError in __main__: 'exceptions.ValueError' object has no attribute 'doc'

Bug #858639 reported by QA on 2011-09-25
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

??

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.23.5
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Sun Sep 25 12:20:25 2011
ExecutablePath: /usr/share/software-center/piston_get_reviews_helper.py
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110921.2)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/software-center/piston_get_reviews_helper.py --language zh_CN --origin ubuntu --distroseries oneiric --pkgname orbital-eunuchs-sniper --page 1
PythonArgs: ['/usr/share/software-center/piston_get_reviews_helper.py', '--language', 'zh_CN', '--origin', 'ubuntu', '--distroseries', 'oneiric', '--pkgname', 'orbital-eunuchs-sniper', '--page', '1']
SourcePackage: software-center
Title: piston_get_reviews_helper.py crashed with AttributeError in __main__: 'exceptions.ValueError' object has no attribute 'doc'
Traceback:
 Traceback (most recent call last):
   File "/usr/share/software-center/piston_get_reviews_helper.py", line 75, in <module>
     LOG.error("failed to parse '%s'" % e.doc)
 AttributeError: 'exceptions.ValueError' object has no attribute 'doc'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

QA (qa137) wrote :

This crash has the same stack trace characteristics as bug #827023. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: removed: need-duplicate-check
tags: added: regression-retracer
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
visibility: private → public
Michael Vogt (mvo) on 2011-10-04
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.0.1

---------------
software-center (5.0.1) oneiric; urgency=low

  [ Michael Vogt ]
  * softwarecenter/ui/gtk3/widgets/reviews.py:
    - Fix i18n bug in the error string for the reviews. This
      adds two new strings for a rare error message in the UI that
      was previously not translatable. Thanks to David Planella
  * softwarecenter/db/database.py:
    - when adding a new database (e.g. on reinstall-previous purchases)
      trigger a "reopen" to ensure that the db docids are reinitialized
  * apt-xapian-index-plugin/software-center.py:
    - do not crash if a apt.Package.candidate has no url (LP: #819907)
  * softwarecenter/ui/gtk3/views/catview_gtk.py:
    - only show the frame with new apps if we actually have information
      about new applications (LP: #862382)

  [ Robert Roth ]
  * softwarecenter/ui/gtk3/widgets/apptreeview.py:
    - fix crash in clear_model() (LP: #863233)

  [ Gary Lasker ]
  * debian/control:
    - add dependency on python-gobject-cairo to prevent crash
      at startup (LP: #829067)
  * softwarecenter/db/application.py,
    softwarecenter/db/update.py,
    softwarecenter/distro/Ubuntu.py,
    softwarecenter/enums.py:
    - display the correct license type for commercial apps as
      specified via the software-center-agent (LP: #864706)

  [ Matthew McGowan ]
  * lp:~mmcg069/software-center/bug855666:
    - add missing linewrap (LP: #855666)
  * lp:~mmcg069/software-center/bug858639 :
    - fix crash when data can not be parsed from the remote reviews server
      LP: #858639
 -- Michael Vogt <email address hidden> Wed, 05 Oct 2011 11:24:05 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers