software-center crashed with DBAgainError in _dump_bsddbm_for_unity(): (11, 'Resource temporarily unavailable -- unable to join the environment')

Bug #858437 reported by Hazuki San on 2011-09-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

Just installed the latest beta 2 11.10 edition today. I'm on 64 bit. This error seems to crop up every time I launch the software centre. Apologies if this has been reported already. I'm just following the bug reporting prompts!

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.23.5
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Sat Sep 24 20:05:05 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with DBAgainError in _dump_bsddbm_for_unity(): (11, 'Resource temporarily unavailable -- unable to join the environment')
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Hazuki San (hazuki-san) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #857931, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check
visibility: private → public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.23.6

---------------
software-center (4.1.23.6) oneiric; urgency=low

  [ Kiwinote ]
  * softwarecenter/db/update.py:
    - update the sc-agent db even if there are no apps available (LP: #857268)
  * softwarecenter/utils.py:
    - fix UnicodeDecodeError in get_icon_from_theme() (LP: #839391)
  * utils/submit_review_gtk3.py:
    - fix UnicodeDecodeError in _on_one_gwibber_account() (LP: #836911)

  [ Gary Lasker ]
  * softwarecenter/ui/gtk3/app.py:
    - fix intermittent startup crashes (LP: #846674, LP: #857989)

  [ Matthew McGowan ]
  * work around some oddness that seems to have broken
    Gdk.EventButton.copy().

  [ Michael Vogt ]
  * softwarecenter/ui/gtk3/app.py:
    - do not crash if there is no active pane
  * softwarecenter/backend/reviews.py:
    - be more robust against db corruption when writing out
      the bsddb for unity (LP: #858437)
  * softwarecenter/backend/login_sso.py:
    - port to the new SSO dbus API (LP: #857514)

  [ Didier Roche ]
  * lp:~didrocks/software-center/replace_logintext_by_helptext:
    - use help_text internally to be aligned with the new ubuntu SSO
      parameter name (LP: #857514)
 -- Michael Vogt <email address hidden> Mon, 26 Sep 2011 16:59:33 +0200

Changed in software-center (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers