Ubuntu

Software center cannot install opera deb file: Internal Error

Reported by Frederik Elwert on 2011-09-24
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

I just tried to install opera from the provided deb package. Unfortunately, software-center always displayed an “Internal Error”: “The file x could not be opened”. I checked the file is okay by installing it with dpkg, which worked fine.

See also bug 868188, the same error for the Google Chrome .deb.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.23.3
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Sat Sep 24 16:07:13 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110803.1)
PackageArchitecture: all
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Conner Lee (connerleecml) wrote :

this bug really needs to be fixed. i do not have enough experience to fix it but i can say that i have tried debs in multiple directories and i always get the internal error message. i have installed gdebi for now.

Conner Lee (connerleecml) wrote :

and this error message is for google chrome 64 bit but i tried with opera as well

Thomas C. (thomas-creutz) wrote :

here it is the same

Thomas C. (thomas-creutz) wrote :
tags: added: apport-collected

ApportVersion: 1.23-0ubuntu3
Architecture: amd64
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
NonfreeKernelModules: nvidia
Package: software-center 5.0.1.4
PackageArchitecture: all
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Tags: oneiric
Uname: Linux 3.0.0-12-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

apport information

apport information

apport information

description: updated
Grzegorz Śliwiński (fizyk) wrote :

ruario at my Opera community (an Opera employee) has made research and he determined that at least for Opera deb file, the issue is with lzma not being present in default Ubuntu install.
Here's the full discussion and ruario's research's conclusion:

http://my.opera.com/community/forums/topic.dml?id=1124872&t=1318873023&page=1#comment10564932

ruario (e-launchpad-ruari-com) wrote :

The problem is that the data.tar file within the Opera Debian package is lzma compressed. Since /usr/bin/lzma is not present on Ubuntu "Oneiric Ocelot" 11.10, Software Center cannot open the file.

However, other utilities such as dpkg and apt can open the package and install it without any issue because they use /usr/bin/xz to open lzma compressed files. Indeed if you create /usr/bin/lzma as a symlink to /usr/bin/xz then software center can open the Opera package as well.

This can be fixed in two ways, either the /usr/bin/lzma symlink should be provided by the xz package for backwards compatibility (in fact that is good idea anyway as xz is just a continuation of lzma and other distros do this) and/or Software Center should be updated to use xz when lzma is not present.

http://my.opera.com/community/forums/findpost.pl?id=10564932

mscuarto (mscuarto) wrote :

the same is true with me when i downloaded a google earth amd64.deb

Krešo Kunjas (deresh) wrote :

for a quick fix until this is resolved, on precise install package xz-lzma which provides symlink from xz to lzma

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers