[MASTER] software-center crashed with DBusException in _convert_dbus_exception(): org.freedesktop.DBus.Error.UnknownMethod: Method "GetAll" with signature "s" on interface "org.freedesktop.DBus.Properties" doesn't exist

Bug #848676 reported by milton barton on 2011-09-13
382
This bug affects 64 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

its for firefox 7

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.22
ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.22.1-0ubuntu2
Architecture: i386
Date: Tue Sep 13 00:11:44 2011
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center apt:adobe-flashplugin?channel=$distro-partner
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center', 'apt:adobe-flashplugin?channel=$distro-partner']
SourcePackage: software-center
Title: software-center crashed with DBusException in _convert_dbus_exception(): org.freedesktop.DBus.Error.UnknownMethod: Method "GetAll" with signature "s" on interface "org.freedesktop.DBus.Properties" doesn't exist
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

milton barton (barton-mk) wrote :
tags: removed: need-duplicate-check
Changed in software-center (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Michael Vogt (mvo) on 2011-09-15
Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
visibility: private → public
summary: - software-center crashed with DBusException in _convert_dbus_exception():
- org.freedesktop.DBus.Error.UnknownMethod: Method "GetAll" with signature
- "s" on interface "org.freedesktop.DBus.Properties" doesn't exist
+ [MASTER] software-center crashed with DBusException in
+ _convert_dbus_exception(): org.freedesktop.DBus.Error.UnknownMethod:
+ Method "GetAll" with signature "s" on interface
+ "org.freedesktop.DBus.Properties" doesn't exist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.23.2

---------------
software-center (4.1.23.2) oneiric; urgency=low

  [ Michael Vogt ]
  * softwarecenter/backend/reviews.py:
    - update review sorting to follow spec (wilson score)
  * lp:~mvo/software-center/retire-gtk2:
    - remove (no longer used) gtk2 code, this has the added benefit
      that all the checks for pygtk vs pygi are gone as well
    - update gir1.2-* dependencies (LP: #842616)
  * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - wrap title instead of ellipsize (LP: #850857)
  * softwarecenter/toolkit.py:
    - update to current code
  * softwarecenter/backend/reviews.py:
    - do not crash for unknown deb names
  * softwarecenter/ui/gtk3/app.py:
    - make the locale code more robust (LP: #846038)
  * softwarecenter/db/history_impl/apthistory.py:
    - be more robust against broken history.log files (LP: #666449)
  * softwarecenter/backend/installbackend_impl/aptd.py:
    - be more robust about potential races (LP: #848676)
  * softwarecenter/ui/gtk3/models/pendingstore.py:
    - only add transactions if we get meaningful data

  [ Matthew McGowan ]
  * lp:~mmcg069/software-center/highcontrast-theme-improvements:
    - a host of improvements to the highcontrast themes
  * lp:~mmcg069/software-center/bug848845:
    - use the stock_zoom-page cursor, which in the currernt icon
      theme still presents as a magnifying glass (LP: #848845)
  * lp:~mmcg069/software-center/minor-vis-fixes:
    - even up the borders around a Frame (LP: #850780)

  [ Gary Lasker ]
  * softwarecenter/ui/gtk3/panes/installedpane.py:
    - implement a spinner for the installed view
 -- Michael Vogt <email address hidden> Thu, 15 Sep 2011 22:09:59 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
tags: removed: bugpattern-needed
tags: added: bugpattern-written

got this crash when using Ubuntu software center to install Skype from proposes 11.04 source while on beta 11.10

Abner Rizzi (bacteria666) wrote :

first, sorry my bad english,

the error appear when try to active skype source.

Tiago Ramos (tiagolramos) wrote :

Same thing append to me, while activating the source for skype instalation

Matthias Schmidt (mschmidt) wrote :

Can confirm a crash while adding the source for Ubuntu partners (needed for Skype)

Abner Rizzi (bacteria666) wrote :

first, sorry my bad english again:

yes ... after open software center, in search i type 'skype' ... after ... more info ... after ... ( i dont remember button name ) ... use this source ... and crash occurs

Michael Terry (mterry) wrote :

I just got this with 4.1.23.3. I got it by going to "Installed Packages -> Other" (these are packages that are no longer in the archive) and clicking remove on multiple packages. So multiple remove actions were queued up. Then I got this crash (not sure if each part of this is necessary to reproduce, but just telling what happened for me).

Changed in software-center (Ubuntu):
status: Fix Released → Confirmed
Changed in software-center (Ubuntu):
importance: Undecided → High
Chris Hermansen (c-hermansen) wrote :

I was installing some extra fonts when this crash happened. I believe it was for xfree86-nonfree fonts if that helps.

Lazy (ubuntu-bugs-oittaa) wrote :

I was about to install Skype and clicked the button to add "partners" source when the crash happened.

Mauricio Pretto (pretto) wrote :

same as #10 here

John Webster (civil-bigpond) wrote :

This bug is still present in Ubuntu 20110921.2, and USC remains slow and unreliable.

This happens to me when ever I try to install the adobe flash plugin

Michael Blank (mblank) wrote :

same with me; crashed when trying to install adobe flash plugin

Abner Rizzi (bacteria666) wrote :

same with me; again when try to active partner source ( Skype )

Robert Keefer Sery (rksery) wrote :

I have this problem trying to install the source require for adobe flash plugin.

nirwana (weisbeek) wrote :

I got the error message when I tried to install the Adobe Flash Player package through Software Center.
However, I could still continue to install the plug-in and it finished without a problem. After a restart of Firefox the Flash-plugin worked without a problem.

However, it would be nice when this crash could be resolved, because it could make other users think that something did not work well and they cannot continue installing the Flash Player. So people can say that one "cannot even install a Flash-player with this new Ubuntu version". However, I know that Oneiric is still in beta and that people are working hard to get everything working before the release date.

Mike Hansen (gordie69) wrote :

having problems updating hardware

Jacob Gadikian (faddat) wrote :

Yes - I was installing the flash plugin from the partner repository and the whole thing just croaked on me. `

David Gomes (davidgomes) wrote :

I was also installing something from the partner repository, Skype.

W Karaki (wafaa-karaki) wrote :

Same here. I was trying to install skype from the software center. I clicked "use this source" and it crashed.

crashed when i try to install skype (11.10 Beta2)

Bart Willemsen (b-willemsen8) wrote :

Looks like this crash happens everytime I try to add the cannonical Partners repository (which righ now only contains the Flash Plugin and Skype).

Bart Willemsen (b-willemsen8) wrote :

Also something to note: It still adds the repository, when I tried to install Skype as a test, it actually ran successfully.

Luca Bianchi (oile11) wrote :

This bug affects also me.

tags: added: rls-mgr-o-tracking
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.0

---------------
software-center (5.0) oneiric; urgency=low

  [ Gary Lasker ]
  * softwarecenter/ui/gtk3/views/appdetailsview.py,
    softwarecenter/ui/gtk3/views/appdetailsview_gtk.py,
    softwarecenter/ui/gtk3/widgets/reviews.py,
    utils/submit_review_gtk3.py:
    - restore the ability to edit or delete your own
      review (LP: #861999)
  * softwarecenter/db/application.py:
    - fix TypeError in __init__ (LP: #825729)
  * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - fix crash in _get_app_icon_xy_position_on_screen (LP: #843565)
  * softwarecenter/ui/gtk3/panes/softwarepane.py:
    - fix UnicodeDecodeError in on_add_to_launcher (LP: #835337)

  [ Michael Vogt ]
  * add support for license keys in $HOME
  * set correct version number
  * utils/submit_review_gtk3.py:
    - translate app name in review title, thanks to Gabor Kelemen
      (LP: #782146)
  * softwarecenter/backend/reviews.py:
    - leave the review sorting to the server now that the rnr-server
      is deployed that sorts properly by wilson_score
  * fix None vs "" crashes
  * fix another dbus exception when a tid vanishes (LP: #848676), thanks
    to Marc Deslauriers

  [ Kiwinote ]
  * softwarecenter/distro/Ubuntu.py:
    - display canonical support text again (LP: #862388)
      (no new strings - there was just some 'if False, display the text' code)

  [ Matthew McGowan ]
  * data/ui/gtk3/dialogs.ui:
    - fix incorrect sizing of dialogs (LP: #825959, LP: #844014)
  * display 'where is it' command line helper for installed apps with
    no desktop_files even when unity is running.'
  * set a minimum size for the CategoryTile so all english category
    names fit to two lines (Computer Science and Robotics took 3 lines
    to display).
  * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - cleanup dead code
 -- Michael Vogt <email address hidden> Thu, 29 Sep 2011 20:45:22 +0200

Changed in software-center (Ubuntu Oneiric):
status: Confirmed → Fix Released
Christer (christer-madsen) wrote :

Tried to uninstall several programs at once (the entire LibreOffice suite) then Software Center crashed.

Jojo (kuzniarpawel) wrote :

but I still got
software-center 4.1.23.4

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers