software-center crashed with TypeError in function(): Argument 1 does not allow None as a value

Bug #846508 reported by mkis62 on 2011-09-10
44
This bug affects 5 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

Reported crash when simultaneously installing a package and searching ... but the application still running

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.22
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
ApportVersion: 1.22.1-0ubuntu2
Architecture: i386
Date: Sat Sep 10 19:01:33 2011
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with TypeError in function(): Argument 1 does not allow None as a value
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare tape video

mkis62 (mihaikx62) wrote :
tags: removed: need-duplicate-check
Changed in software-center (Ubuntu):
status: New → Confirmed
Robert Roth (evfool) wrote :

Which application were you installing?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
mkis62 (mihaikx62) wrote :

I'm not sure ... Audacity, OpenShot, Videoporama, Xaos, Fraqtive, Scribus - perhaps one of them ...

mkis62 (mihaikx62) wrote :

New crash ... this time when installing checkbox-gtk (System Testing). Software-center still running, history seems to be OK, nothing annoying... just the crash-message

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

This should be fixed in trunk now, it only happens when running in a non-unity environment.

visibility: private → public
Changed in software-center (Ubuntu):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.23.3

---------------
software-center (4.1.23.3) oneiric; urgency=low

  * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - fix r2344 (line wrap for header) as it leaves overly
      huge margins, thanks to Matthew McGowan
    - fix crash if get_icon() returns None (LP: #846508)
  * softwarecenter/backend/installbackend_impl/aptd.py:
    - be more robust against a race when the transaction disappears
      between notify and fetching details #804444)
  * data/ui/gtk3/submit_usefulness.ui:
    - remove not needed cancel/post click handlers (LP: #830830)
  * softwarecenter/ui/gtk3/panes/installedpane.py,
    test/gtk3/test_installedpane.py:
    - fix show/hide technical items when in search mode in the installed
      pane and add regression test
  * softwarecenter/ui/gtk3/panes/installedpane.py:
    test/gtk3/test_installedpane.py,
    softwarecenter/ui/gtk3/widgets/actionbar.py:
    - fix show/hide nonapps count when doing searches
    - add tests
  * softwarecenter/ui/gtk3/widgets/reviews.py:
    - do not show "no network connection" message when checking for
      new reviews (LP: #848480)
  * softwarecenter/ui/gtk3/panes/softwarepane.py, softwarecenter/utils.py,
    test/test_utils.py:
    - do not offer to add NoDisplay=true desktop files like wine to the
      launcher (LP: #848437)
 -- Michael Vogt <email address hidden> Fri, 16 Sep 2011 21:12:26 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers