software-center-gtk3 crashed with UnicodeDecodeError in warning(): 'ascii' codec can't decode byte 0xc2 in position 2: ordinal not in range(128)

Bug #845298 reported by xe2xpk on 2011-09-09
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Gary Lasker

Bug Description

Installing packages

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.21
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.22.1-0ubuntu2
Architecture: i386
Date: Thu Sep 8 21:51:08 2011
ExecutablePath: /usr/share/software-center/software-center-gtk3
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110903)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center-gtk3
PythonArgs: ['/usr/bin/software-center-gtk3']
SourcePackage: software-center
Title: software-center-gtk3 crashed with UnicodeDecodeError in warning(): 'ascii' codec can't decode byte 0xc2 in position 2: ordinal not in range(128)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

xe2xpk (skorlowsky) wrote :
xe2xpk (skorlowsky) wrote :

I was installing packages from my HDD, not from internet

tags: removed: need-duplicate-check
Robert Roth (evfool) wrote :

Thank you for taking the time to report this bug. Could you specify what .deb package were you trying to install for us to be able to reproduce this to further investigate?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in software-center (Ubuntu):
status: New → Incomplete
Matthew Paul Thomas (mpt) wrote :

From the traceback, it looks like the package name contains a non-Ascii character, but warning() assumes that it's Ascii. Perhaps someone could supply a demo package with a non-Ascii name?

visibility: private → public
Changed in software-center (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Robert Roth (evfool) wrote :

@mpt: an example package I have used for reproducing UnicodeDecodeError is the Love framework (apt:love). I see this trace is about a deb file, but I guess it's easy to find a deb file for Love somewhere (maybe even newer then the one the user is using). Anyway, Love is the best sample for similar bugs, as the second character is non-ascii.

Changed in software-center (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.23.7

---------------
software-center (4.1.23.7) oneiric; urgency=low

  [ Gary Lasker ]
  * softwarecenter/backend/installbackend_impl/aptd.py:
    - fix UnicodeDecodeError in _show_transaction_failed_dialog
      (LP: #858193)
  * softwarecenter/backend/installbackend.py,
    softwarecenter/ui/gtk3/aptd_gtk3.py,
    softwarecenter/ui/gtk3/dialogs/__init__.py:
    - implement the error() method of InstallBackendUI to display the
      required error dialog in the event of a transaction error
      (LP: #860137)
  * softwarecenter/backend/installbackend_impl/aptd.py:
    - add unicode handling for the transaction error dialog
  * softwarecenter/utils.py:
    - let the utf8() method handle None as an input value
  * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - fix UnicodeDecodeError in set_value() (LP: #846600)
  * softwarecenter/db/debfile.py:
    - fix UnicodeDecodeError in warning() (LP: #845298)
  * softwarecenter/ui/gtk3/app.py:
    - fix intermittent crash at shutdown (LP: #728973)
  * softwarecenter/ui/gtk3/panes/availablepane.py,
    softwarecenter/ui/gtk3/session/navhistory.py,
    softwarecenter/ui/gtk3/session/viewmanager.py:
    - navigate back to the application details view on
      a purchase cancellation or a purchase error (LP: #859790)
  * softwarecenter/ui/gtk3/panes/installedpane.py:
    - fix empty installed view after clearing search (LP: #860810)
    - fix rendering glitch when searching with OneConf
      active (LP: #860818)
  * softwarecenter/utils.py:
    - fix crash in save_person_to_config() (LP: #858403)
  * softwarecenter/ui/gtk3/widgets/reviews.py:
    - fix UnicodeDecodeError in _whom_when_markup()

  [ Michael Vogt ]
  * softwarecenter/ui/gtk3/widgets/searchentry.py:
    - merge header fix
  * softwarecenter/ui/gtk3/app.py, softwarecenter/utils.py:
    - add support for proxy setup from gsettings (LP: #742564)

  [ Juhana Jauhiainen ]
  * Added For Software developers link to Help menu. (LP #722366)

  [ Didier Roche ]
  * softwarecenter/ui/gtk3/panes/installedpane.py:
    - disable search when viewing oneconfviews

  [ Kiwinote ]
  * softwarecenter/ui/gtk3/panes/viewswitcher.py:
    - if we're in the 'in progress' view and all the transactions finish, then
      navigate back (LP: #831524)
 -- Michael Vogt <email address hidden> Wed, 28 Sep 2011 18:02:08 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers