software-center-gtk3 crashed with AttributeError in _on_key_press_event(): 'NoneType' object has no attribute 'state'

Bug #843409 reported by Britt Yazel on 2011-09-07
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Gary Lasker

Bug Description

this happened immediately after booting.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.21
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
Architecture: amd64
Date: Thu Sep 1 23:01:19 2011
ExecutablePath: /usr/share/software-center/software-center-gtk3
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center-gtk3
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center-gtk3']
SourcePackage: software-center
Title: software-center-gtk3 crashed with AttributeError in _on_key_press_event(): 'NoneType' object has no attribute 'state'
Traceback:
 Traceback (most recent call last):
   File "/usr/share/software-center/softwarecenter/ui/gtk3/widgets/apptreeview.py", line 364, in _on_key_press_event
     if btn.state != Gtk.StateType.INSENSITIVE:
 AttributeError: 'NoneType' object has no attribute 'state'
UpgradeStatus: Upgraded to oneiric on 2011-09-02 (4 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Britt Yazel (bwyazel) wrote :
tags: removed: need-duplicate-check
Kiwinote (kiwinote) on 2011-09-08
visibility: private → public
Changed in software-center (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package software-center - 4.1.23

---------------
software-center (4.1.23) oneiric; urgency=low

  [ Michael Vogt ]
  * new default exhibit image from Marcus Haslam, many thanks
  * tweak html for the default text layout
  * softwarecenter/utils.py:
    - never cache local urls in the SimpleFileDownloader
  * softwarecenter/ui/gtk3/widgets/exhibits.py:
    - fix bug in banner image rendering when the agent serves the images
  * softwarecenter/ui/gtk3/app.py, debian/control:
    - renenable plugin loader
    - add conflict against older oneconf as the old oneconf plugin
      will crash softwarecenter because of mixing pygtk with pygi
    - load plugins from $SOFTWARE_CENTER_PLUGINS_DIR,
      /usr/share/software-center/plugins,
      ~/.local/share/software-center/plugins (LP: #631457)
  * doc/example_plugin.py:
    - updated to the gtk3 version
  * softwarecenter/backend/scagent.py:
    - generically deal with exhibts without a title
  * softwarecenter/ui/gtk3/widgets/exhibits.py:
    - set the default exhibit cycle time to 10s but do not cycle if
      the main application does not have the active toplevel focus
  * softwarecenter/ui/gtk3/views/catview_gtk.py:
    - if there is only a single app in a exhibit, show that on
      click (LP: #848995)
  * softwarecenter/ui/gtk3/panes/availablepane.py,
    softwarecenter/ui/gtk3/views/catview_gtk.py:
    - when showing a exhibts list, show with flags=["nonapps-visible"]
      (LP: #849035)
  * softwarecenter/backend/scagent.py:
    - if the server does not provide a title for a exhibit use the
      html title tag or the first h1
  * software-center-gtk3:
    - removed, the gtk3 version is now default and identical to
      the software-center command
  * softwarecenter/utils.py:
    - avoid race condition on slow connections (LP: #839462)
  * lp:~mvo/software-center/per-thread-xapiandb:
    - create per-thread xapian.Database objects to avoid race
      condition with multiple threads

  [ Matthew McGowan ]
  * softwarecenter/ui/gtk3/app.py:
    - inhibit system error bell (LP: #846138)
  * softwarecenter/utils.py,
    softwarecenter/ui/gtk3/widgets/description.py,
    test/test_description_norm.py:
    - tweak the description parser to not omit linebreaks when
      a newline follows a terminator (e.g. "." or ":"), add a
      preparser special case for texlive-fonts-extra, update
      unit test (LP: #846944)
  * softwarecenter/ui/gtk3/session/navhistory.py:
    - fix multiple navigation items generated during search
      (LP: #842734)
  * lp:~mmcg069/software-center/bug844068:
    - if search is cleared by the user whilst the search context is a
      subcategory, return to the unfiltered subcategory list not the
      category page (bug 844068).
  * lp:~mmcg069/software-center/themeing-improvements:
    - provide theming css for highcontrast and highcontrastinverse
    - fix dynamic theme updates
  * lp:~mmcg069/software-center/submit-review-fixes:
    - add changed sig to star rating widget and correctly ensure the
      user has set a star rating prior to allowing submition
    - cleanup
  * lp:~mmcg069/software-center/bug850033:
    - improve the back_forward b...

Read more...

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers