Apps from partners should show 'Use this source' rather than 'Install' button

Bug #842302 reported by David Coles on 2011-09-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

When trying to install a application from the partners repository the search list shows the 'Install' button rather than the 'Use this source' when the partners repository is not currently added to the list of software sources. This causes the install to fail silently.

Steps to reproduce:
1. Open software center and search for Skype
2. Click the 'Install' button next to the Skype result
3. The install bar will appear briefly but nothing will happen

Correct behavior:
3. Prompt the user asking if they want to enable the "Partners" repository
4. Install if the user selects yes.

Workaround:
1. Click 'More Info' button
2. Click 'Use This Source'
3. Click 'Install'

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.21
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
Architecture: amd64
Date: Mon Sep 5 20:14:13 2011
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

David Coles (dcoles) wrote :
Kiwinote (kiwinote) wrote :

Hi David! Thanks for your bug report. We are tracking this issue over at bug 841459. Please continue to report any bugs you may find in software-center. Thanks again for your help!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers