software-center-gtk3 crashed with UnicodeDecodeError in get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in position 7: ordinal not in range(128)

Bug #839391 reported by Thomas Schwiertz on 2011-09-02
260
This bug affects 42 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Kiwinote

Bug Description

Software Center crashed while trying to install a program.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.20
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic-pae 3.0.3
Uname: Linux 3.0.0-9-generic-pae i686
Architecture: i386
Date: Fri Sep 2 10:35:48 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/share/software-center/software-center-gtk3
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110830)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center-gtk3
PythonArgs: ['/usr/bin/software-center-gtk3']
SourcePackage: software-center
Title: software-center-gtk3 crashed with UnicodeDecodeError in get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in position 7: ordinal not in range(128)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: removed: need-duplicate-check
Changed in software-center (Ubuntu):
status: New → Confirmed
tags: added: iso-testing
visibility: private → public
Changed in software-center (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in software-center (Ubuntu):
importance: Medium → High
Robert Roth (evfool) wrote :

Thanks for taking the time tor report this bug. Can you remember which package you were installing when you have reported this crash?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Hello,

It happened several time on different software installations such as Wine or
flash player, or also external package for my printer driver for instance.
It also happened just when launching the app. But the app was still there
even if a crash was reported. Don't know exactly what was happening then.
Since then, I completely removed my installation, so I can't tell you if it
still happens.

Sorry if I can't help you much.

Emmanuel

2011/9/23 Robert Roth <email address hidden>

> Thanks for taking the time tor report this bug. Can you remember which
> package you were installing when you have reported this crash?
> ---
> Ubuntu Bug Squad volunteer triager
> http://wiki.ubuntu.com/BugSquad
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (846838).
> https://bugs.launchpad.net/bugs/839391
>
> Title:
> software-center-gtk3 crashed with UnicodeDecodeError in
> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in
> position 7: ordinal not in range(128)
>
> Status in “software-center” package in Ubuntu:
> Triaged
>
> Bug description:
> Software Center crashed while trying to install a program.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: software-center 4.1.20
> ProcVersionSignature: Ubuntu 3.0.0-9.15-generic-pae 3.0.3
> Uname: Linux 3.0.0-9-generic-pae i686
> Architecture: i386
> Date: Fri Sep 2 10:35:48 2011
> EcryptfsInUse: Yes
> ExecutablePath: /usr/share/software-center/software-center-gtk3
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110830)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/software-center-gtk3
> PythonArgs: ['/usr/bin/software-center-gtk3']
> SourcePackage: software-center
> Title: software-center-gtk3 crashed with UnicodeDecodeError in
> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in position 7:
> ordinal not in range(128)
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/839391/+subscriptions
>

--
P Please, consider your environmental responsibility before printing this
e-mail. ***** Avant d'imprimer*, pensez à l'environnement

Please also note that I was using Ubuntu in french.

2011/9/23 Emmanuel CHRISMENT <email address hidden>

> Hello,
>
> It happened several time on different software installations such as Wine
> or flash player, or also external package for my printer driver for
> instance. It also happened just when launching the app. But the app was
> still there even if a crash was reported. Don't know exactly what was
> happening then. Since then, I completely removed my installation, so I can't
> tell you if it still happens.
>
> Sorry if I can't help you much.
>
> Emmanuel
>
> 2011/9/23 Robert Roth <email address hidden>
>
>> Thanks for taking the time tor report this bug. Can you remember which
>> package you were installing when you have reported this crash?
>> ---
>> Ubuntu Bug Squad volunteer triager
>> http://wiki.ubuntu.com/BugSquad
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (846838).
>> https://bugs.launchpad.net/bugs/839391
>>
>> Title:
>> software-center-gtk3 crashed with UnicodeDecodeError in
>> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in
>> position 7: ordinal not in range(128)
>>
>> Status in “software-center” package in Ubuntu:
>> Triaged
>>
>> Bug description:
>> Software Center crashed while trying to install a program.
>>
>> ProblemType: Crash
>> DistroRelease: Ubuntu 11.10
>> Package: software-center 4.1.20
>> ProcVersionSignature: Ubuntu 3.0.0-9.15-generic-pae 3.0.3
>> Uname: Linux 3.0.0-9-generic-pae i686
>> Architecture: i386
>> Date: Fri Sep 2 10:35:48 2011
>> EcryptfsInUse: Yes
>> ExecutablePath: /usr/share/software-center/software-center-gtk3
>> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110830)
>> InterpreterPath: /usr/bin/python2.7
>> PackageArchitecture: all
>> ProcCmdline: /usr/bin/python /usr/bin/software-center-gtk3
>> PythonArgs: ['/usr/bin/software-center-gtk3']
>> SourcePackage: software-center
>> Title: software-center-gtk3 crashed with UnicodeDecodeError in
>> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in position 7:
>> ordinal not in range(128)
>> UpgradeStatus: No upgrade log present (probably fresh install)
>> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/839391/+subscriptions
>>
>
>
>
> --
> P Please, consider your environmental responsibility before printing this
> e-mail. ***** Avant d'imprimer*, pensez à l'environnement
>

--
P Please, consider your environmental responsibility before printing this
e-mail. ***** Avant d'imprimer*, pensez à l'environnement

Spinaker (mergzz) wrote :

Spinnaker

Yes no problem But where i note i using ubuntu in french?

It's me who uses ubuntu in french. This can be the reason for those dumps,
no ?

2011/9/23 Spinnaker <email address hidden>

> Spinnaker
>
> Yes no problem But where i note i using ubuntu in french?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (846838).
> https://bugs.launchpad.net/bugs/839391
>
> Title:
> software-center-gtk3 crashed with UnicodeDecodeError in
> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in
> position 7: ordinal not in range(128)
>
> Status in “software-center” package in Ubuntu:
> Triaged
>
> Bug description:
> Software Center crashed while trying to install a program.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: software-center 4.1.20
> ProcVersionSignature: Ubuntu 3.0.0-9.15-generic-pae 3.0.3
> Uname: Linux 3.0.0-9-generic-pae i686
> Architecture: i386
> Date: Fri Sep 2 10:35:48 2011
> EcryptfsInUse: Yes
> ExecutablePath: /usr/share/software-center/software-center-gtk3
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110830)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/software-center-gtk3
> PythonArgs: ['/usr/bin/software-center-gtk3']
> SourcePackage: software-center
> Title: software-center-gtk3 crashed with UnicodeDecodeError in
> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in position 7:
> ordinal not in range(128)
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/839391/+subscriptions
>

--
P Please, consider your environmental responsibility before printing this
e-mail. ***** Avant d'imprimer*, pensez à l'environnement

Spinaker (mergzz) wrote :

Spinnaker
Moi aussi j utilise ubuntu en francais ;)
I also use ubuntu in french

Using Ubuntu in German and getting the same error message quite often when installing some packages. It is a general Unicode problem somewhere within the function get_icon_from_theme() .

Cool, je vois que je ne suis pas le seul alors ! Enfin bon, comme mon
Macbook ne peut pas faire tourner World of Warcraft sous Wine, et comme il
rame sous Mac OS X Lion, je suis obligé de rester sous Windows 7, la honte !

2011/9/23 Spinnaker <email address hidden>

> Spinnaker
> Moi aussi j utilise ubuntu en francais ;)
> I also use ubuntu in french
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (846838).
> https://bugs.launchpad.net/bugs/839391
>
> Title:
> software-center-gtk3 crashed with UnicodeDecodeError in
> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in
> position 7: ordinal not in range(128)
>
> Status in “software-center” package in Ubuntu:
> Triaged
>
> Bug description:
> Software Center crashed while trying to install a program.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: software-center 4.1.20
> ProcVersionSignature: Ubuntu 3.0.0-9.15-generic-pae 3.0.3
> Uname: Linux 3.0.0-9-generic-pae i686
> Architecture: i386
> Date: Fri Sep 2 10:35:48 2011
> EcryptfsInUse: Yes
> ExecutablePath: /usr/share/software-center/software-center-gtk3
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110830)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/software-center-gtk3
> PythonArgs: ['/usr/bin/software-center-gtk3']
> SourcePackage: software-center
> Title: software-center-gtk3 crashed with UnicodeDecodeError in
> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in position 7:
> ordinal not in range(128)
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/839391/+subscriptions
>

--
P Please, consider your environmental responsibility before printing this
e-mail. ***** Avant d'imprimer*, pensez à l'environnement

Spinaker (mergzz) wrote :

Spinnaker

Slt moi c est Pareil je suis un fan de battlefield depuis des années a cause
de ce jeux j ai un multi boot win Ubuntu :)
Dit moi Tu es un developpeur chez Ubuntu?

Non, je ne suis pas développeur, même si j'ai fait du développement dans ma
jeunesse. J'ai commencé sur Linux avec RedHat en 1992...

2011/9/24 Spinnaker <email address hidden>

> Spinnaker
>
> Slt moi c est Pareil je suis un fan de battlefield depuis des années a
> cause
> de ce jeux j ai un multi boot win Ubuntu :)
> Dit moi Tu es un developpeur chez Ubuntu?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (846838).
> https://bugs.launchpad.net/bugs/839391
>
> Title:
> software-center-gtk3 crashed with UnicodeDecodeError in
> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in
> position 7: ordinal not in range(128)
>
> Status in “software-center” package in Ubuntu:
> Triaged
>
> Bug description:
> Software Center crashed while trying to install a program.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: software-center 4.1.20
> ProcVersionSignature: Ubuntu 3.0.0-9.15-generic-pae 3.0.3
> Uname: Linux 3.0.0-9-generic-pae i686
> Architecture: i386
> Date: Fri Sep 2 10:35:48 2011
> EcryptfsInUse: Yes
> ExecutablePath: /usr/share/software-center/software-center-gtk3
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110830)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/software-center-gtk3
> PythonArgs: ['/usr/bin/software-center-gtk3']
> SourcePackage: software-center
> Title: software-center-gtk3 crashed with UnicodeDecodeError in
> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in position 7:
> ordinal not in range(128)
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/839391/+subscriptions
>

--
P Please, consider your environmental responsibility before printing this
e-mail. ***** Avant d'imprimer*, pensez à l'environnement

Accessoirement, voici mon adresse e-mail : <email address hidden>

2011/9/24 Emmanuel CHRISMENT <email address hidden>

> Non, je ne suis pas développeur, même si j'ai fait du développement dans ma
> jeunesse. J'ai commencé sur Linux avec RedHat en 1992...
>
> 2011/9/24 Spinnaker <email address hidden>
>
>> Spinnaker
>>
>> Slt moi c est Pareil je suis un fan de battlefield depuis des années a
>> cause
>> de ce jeux j ai un multi boot win Ubuntu :)
>> Dit moi Tu es un developpeur chez Ubuntu?
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (846838).
>> https://bugs.launchpad.net/bugs/839391
>>
>> Title:
>> software-center-gtk3 crashed with UnicodeDecodeError in
>> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in
>> position 7: ordinal not in range(128)
>>
>> Status in “software-center” package in Ubuntu:
>> Triaged
>>
>> Bug description:
>> Software Center crashed while trying to install a program.
>>
>> ProblemType: Crash
>> DistroRelease: Ubuntu 11.10
>> Package: software-center 4.1.20
>> ProcVersionSignature: Ubuntu 3.0.0-9.15-generic-pae 3.0.3
>> Uname: Linux 3.0.0-9-generic-pae i686
>> Architecture: i386
>> Date: Fri Sep 2 10:35:48 2011
>> EcryptfsInUse: Yes
>> ExecutablePath: /usr/share/software-center/software-center-gtk3
>> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110830)
>> InterpreterPath: /usr/bin/python2.7
>> PackageArchitecture: all
>> ProcCmdline: /usr/bin/python /usr/bin/software-center-gtk3
>> PythonArgs: ['/usr/bin/software-center-gtk3']
>> SourcePackage: software-center
>> Title: software-center-gtk3 crashed with UnicodeDecodeError in
>> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in position 7:
>> ordinal not in range(128)
>> UpgradeStatus: No upgrade log present (probably fresh install)
>> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/839391/+subscriptions
>>
>
>
>
> --
> P Please, consider your environmental responsibility before printing this
> e-mail. ***** Avant d'imprimer*, pensez à l'environnement
>

--
P Please, consider your environmental responsibility before printing this
e-mail. ***** Avant d'imprimer*, pensez à l'environnement

Spinaker (mergzz) wrote :

Spinnaker
Oki ok C est cool tout cela me permet de te demander quelque petite Chose au
cas ou je me retrouve avec des soucis!
Car moi c est pas toute a fait ca j ai commencer avec mandrake il y a une
dizaine d année a la decouvert d un system sans antivirus malware etc... en
gros je recherche un tout autre windows car celui ci me faisait trop mal a
la tete!
Toi depuis 1992 tu dois en connaitre pas mal quand meme :)

Oui et non, j'ai testé énormément de distributions. Mais aucune ne me
satisfait. Ubuntu n'est pas mal, mais à cause des problèmes de performances
sur les jeux, je ne peux pas rester dessus. Et franchement, ça me gave de
devoir switcher entre deux systèmes. Donc je reste par dépit sous Windows,
même si ce n'est franchement pas la panacée.

Quand j'ai testé Ubuntu 11.10, ça m'a laissé une meilleure impression que la
11.04 qui est mal finie et trop beuguée. J'espère que les quelques plantages
que j'ai eus lors de mon test seront réglés. Ca promet. Maintenant, je
risque malgré tout de ne pas l'utiliser pour autant, car je ne pourrai plus
jouer.

2011/9/24 Spinnaker <email address hidden>

> Spinnaker
> Oki ok C est cool tout cela me permet de te demander quelque petite Chose
> au
> cas ou je me retrouve avec des soucis!
> Car moi c est pas toute a fait ca j ai commencer avec mandrake il y a une
> dizaine d année a la decouvert d un system sans antivirus malware etc... en
> gros je recherche un tout autre windows car celui ci me faisait trop mal a
> la tete!
> Toi depuis 1992 tu dois en connaitre pas mal quand meme :)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (846838).
> https://bugs.launchpad.net/bugs/839391
>
> Title:
> software-center-gtk3 crashed with UnicodeDecodeError in
> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in
> position 7: ordinal not in range(128)
>
> Status in “software-center” package in Ubuntu:
> Triaged
>
> Bug description:
> Software Center crashed while trying to install a program.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: software-center 4.1.20
> ProcVersionSignature: Ubuntu 3.0.0-9.15-generic-pae 3.0.3
> Uname: Linux 3.0.0-9-generic-pae i686
> Architecture: i386
> Date: Fri Sep 2 10:35:48 2011
> EcryptfsInUse: Yes
> ExecutablePath: /usr/share/software-center/software-center-gtk3
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110830)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/software-center-gtk3
> PythonArgs: ['/usr/bin/software-center-gtk3']
> SourcePackage: software-center
> Title: software-center-gtk3 crashed with UnicodeDecodeError in
> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in position 7:
> ordinal not in range(128)
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/839391/+subscriptions
>

--
P Please, consider your environmental responsibility before printing this
e-mail. ***** Avant d'imprimer*, pensez à l'environnement

@Spinnaker and Emmanuel Chrisment
I don't want to interfere into your private conversation, but could you both please hold your conversation privately and don't post here if it has nothing to do with the bug at all? Everyone who is subscribed to this bug is getting an e-mail each time you post something here. Also it makes it difficult to find the information related to the bug between your private conversation.

Spinaker (mergzz) wrote :

Spinnaker

ok desolé j ai recu cela (I don't want to interfere into your private
conversation, but could you both please hold your conversation privately and
don't post here if it has nothing to do with the bug at all? Everyone who is
subscribed to this bug is getting an e-mail each time you post something
here. Also it makes it difficult to find the information related to the bug
between your private conversation.)!
Donc si tu as une adresse personnel j amerai bien ca me permettra de te
demander des infos car apparament on a pas le droit de parler de privé ca
concerne les bugs seulement!

emmanuel.chrisment sur gmail

2011/9/24 Spinnaker <email address hidden>

> Spinnaker
>
> ok desolé j ai recu cela (I don't want to interfere into your private
> conversation, but could you both please hold your conversation privately
> and
> don't post here if it has nothing to do with the bug at all? Everyone who
> is
> subscribed to this bug is getting an e-mail each time you post something
> here. Also it makes it difficult to find the information related to the bug
> between your private conversation.)!
> Donc si tu as une adresse personnel j amerai bien ca me permettra de te
> demander des infos car apparament on a pas le droit de parler de privé ca
> concerne les bugs seulement!
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (846838).
> https://bugs.launchpad.net/bugs/839391
>
> Title:
> software-center-gtk3 crashed with UnicodeDecodeError in
> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in
> position 7: ordinal not in range(128)
>
> Status in “software-center” package in Ubuntu:
> Triaged
>
> Bug description:
> Software Center crashed while trying to install a program.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: software-center 4.1.20
> ProcVersionSignature: Ubuntu 3.0.0-9.15-generic-pae 3.0.3
> Uname: Linux 3.0.0-9-generic-pae i686
> Architecture: i386
> Date: Fri Sep 2 10:35:48 2011
> EcryptfsInUse: Yes
> ExecutablePath: /usr/share/software-center/software-center-gtk3
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110830)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/software-center-gtk3
> PythonArgs: ['/usr/bin/software-center-gtk3']
> SourcePackage: software-center
> Title: software-center-gtk3 crashed with UnicodeDecodeError in
> get_icon_from_theme(): 'ascii' codec can't decode byte 0xc2 in position 7:
> ordinal not in range(128)
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/839391/+subscriptions
>

--
P Please, consider your environmental responsibility before printing this
e-mail. ***** Avant d'imprimer*, pensez à l'environnement

xe2xpk (skorlowsky) wrote :

Trying to install additional packages:
The APpport error message just pops up. but the application (Software-Center) keeps on going to finish installation.

Kiwinote (kiwinote) wrote :

Hi! Thanks for your bug report. The bug you describe has been fixed in the branch I have linked and should be available in the next release. Please continue to report any bugs you may find in software-center. Thanks again for your help!

(testcase: LANGUAGE=fr_FR.utf8 LC_ALL=fr_FR.utf8 ./software-center and then install poedit)

Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.23.6

---------------
software-center (4.1.23.6) oneiric; urgency=low

  [ Kiwinote ]
  * softwarecenter/db/update.py:
    - update the sc-agent db even if there are no apps available (LP: #857268)
  * softwarecenter/utils.py:
    - fix UnicodeDecodeError in get_icon_from_theme() (LP: #839391)
  * utils/submit_review_gtk3.py:
    - fix UnicodeDecodeError in _on_one_gwibber_account() (LP: #836911)

  [ Gary Lasker ]
  * softwarecenter/ui/gtk3/app.py:
    - fix intermittent startup crashes (LP: #846674, LP: #857989)

  [ Matthew McGowan ]
  * work around some oddness that seems to have broken
    Gdk.EventButton.copy().

  [ Michael Vogt ]
  * softwarecenter/ui/gtk3/app.py:
    - do not crash if there is no active pane
  * softwarecenter/backend/reviews.py:
    - be more robust against db corruption when writing out
      the bsddb for unity (LP: #858437)
  * softwarecenter/backend/login_sso.py:
    - port to the new SSO dbus API (LP: #857514)

  [ Didier Roche ]
  * lp:~didrocks/software-center/replace_logintext_by_helptext:
    - use help_text internally to be aligned with the new ubuntu SSO
      parameter name (LP: #857514)
 -- Michael Vogt <email address hidden> Mon, 26 Sep 2011 16:59:33 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers