submit_review_gtk3.py crashed with UnicodeDecodeError in _setup_details(): 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)

Bug #834233 reported by dkdancer@mail.ru on 2011-08-26
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Kiwinote

Bug Description

косяк

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.19
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic i686
Architecture: i386
Date: Fri Aug 26 04:09:42 2011
ExecutablePath: /usr/share/software-center/submit_review_gtk3.py
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/software-center/submit_review_gtk3.py --pkgname remmina --iconname remmina --parent-xid None --version 0.9.3-2 --origin ubuntu --datadir /usr/share/software-center/ --appname Remmina\ Remote\ Desktop\ Client
ProcEnviron:
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/software-center/submit_review_gtk3.py', '--pkgname', 'remmina', '--iconname', 'remmina', '--parent-xid', 'None', '--version', '0.9.3-2', '--origin', 'ubuntu', '--datadir', '/usr/share/software-center/', '--appname', 'Remmina Remote Desktop Client']
SourcePackage: software-center
Title: submit_review_gtk3.py crashed with UnicodeDecodeError in _setup_details(): 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

dkdancer@mail.ru (dkdancer) wrote :
tags: removed: need-duplicate-check
Changed in software-center (Ubuntu):
status: New → Confirmed
visibility: private → public
Kiwinote (kiwinote) wrote :

Hi! Thanks for your bug report. The bug you describe has been fixed in the branch I have linked and should be available in the next release. Please continue to report any bugs you may find in software-center. Thanks again for your help!

Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
importance: Undecided → Medium
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.6 KiB)

This bug was fixed in the package software-center - 4.1.22

---------------
software-center (4.1.22) oneiric; urgency=low

  [ Gary Lasker ]
  * data/ubuntu-software-center.desktop.in,
    debian/rules,
    setup.py,
    software-center,
    software-center-gtk2,
    softwarecenter/toolkit.py:
    - launch the new UI using 'software-center', add script
      to launch the old version if feeling nostalgic (LP: #839257)
  * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - fix incorrect ellipsize for title and summary in the
      details view (LP: #842271)
  * softwarecenter/ui/gtk3/panes/availablepane.py,
    softwarecenter/ui/gtk3/session/viewmanager.py:
    - hide the search field when in the purchase
      view (LP: #844883)
  * softwarecenter/ui/gtk3/views/catview_gtk.py:
    - don't create the what's new panel if we don't have the
      corresponding category (LP: #835129)
  * softwarecenter/ui/gtk3/panes/installedpane.py:
    - fix crash in rebuild_categorised_view while viewing
      installed items (LP: #834260)
  * test/gtk3/test_catview.py,
    test/gtk3/test_panes.py,
    test/test_addons.py,
    test/test_package_info.py:
    - fix unit tests
  * setup.py:
    - fix build error when merging authors list
  * merged lp:~gary-lasker/software-center/pyflakes-fixes, no
    user visible changes, only code cleanup
  * po/software-center.pot:
    - refresh .pot file

  [ Matthew McGowan ]
  * data/ui/gtk3/css/softwarecenter.css,
    softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - fix grey addon label, only pkgname should be grey
      (LP: #838607)
  * softwarecenter/ui/gtk3/widgets/description.py,
    softwarecenter/utils.py,
    test/test_description_norm.py:
    - description formatting improvements, update unit test
  * data/ui/gtk3/css/softwarecenter.css,
    softwarecenter/ui/gtk3/widgets/cellrenderers.py:
    - use css to set border-radius of cellrenderer button
  * softwarecenter/ui/gtk3/views/appview.py:
    - disable appcount display at the bottom of list views
      for now to allow keyboard scrolling to work (LP: #830258)
  * lp:~mmcg069/software-center/lobby-tweaks:
    - restore tile borders but disable the checkerboard
      rendering, color tweaks and other improvements to the
      title area visuals
  * merge lp:~mmcg069/software-center/image-data-cleanup:
    - cleanup unused image files (LP: #839736)
  * softwarecenter/ui/gtk3/panes/softwarepane.py:
    - fix doubled search results (LP: #840235)
  * softwarecenter/ui/gtk3/app.py:
    - fix "Copy Web Link" feature (LP: #830291)

  [ Andrea Cimitan ]
  * softwarecenter/ui/gtk3/widgets/symbolic_icons.py:
    - Fix blurriness of toolbar icons, reduce shadow alpha level

  [ Gabor Kelemen ]
  * po/POTFILES.in:
    - additional i18n fixes (LP: #836346)

  [ Kiwinote ]
  * remove the old webkit ui
  * remove the need for dummy-screenshot-ubuntu.png (LP: #837223)
  * data/ui/gtk3/SoftwareCenter.ui,
    softwarecenter/ui/gtk3/app.py:
    - make all the accelerators work again (LP: #640426, LP: #660050,
      LP: #828233, LP: #830238, LP: #834988, LP: #843682)
      also fixes (LP: #823094, LP: #837062)
  * softwarecenter/db/appfilter.py,
    softwarecenter/ui/...

Read more...

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Download full text (7.8 KiB)

Nice!!

2011/9/9 Launchpad Bug Tracker <email address hidden>

> This bug was fixed in the package software-center - 4.1.22
>
> ---------------
> software-center (4.1.22) oneiric; urgency=low
>
> [ Gary Lasker ]
> * data/ubuntu-software-center.desktop.in,
> debian/rules,
> setup.py,
> software-center,
> software-center-gtk2,
> softwarecenter/toolkit.py:
> - launch the new UI using 'software-center', add script
> to launch the old version if feeling nostalgic (LP: #839257)
> * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
> - fix incorrect ellipsize for title and summary in the
> details view (LP: #842271)
> * softwarecenter/ui/gtk3/panes/availablepane.py,
> softwarecenter/ui/gtk3/session/viewmanager.py:
> - hide the search field when in the purchase
> view (LP: #844883)
> * softwarecenter/ui/gtk3/views/catview_gtk.py:
> - don't create the what's new panel if we don't have the
> corresponding category (LP: #835129)
> * softwarecenter/ui/gtk3/panes/installedpane.py:
> - fix crash in rebuild_categorised_view while viewing
> installed items (LP: #834260)
> * test/gtk3/test_catview.py,
> test/gtk3/test_panes.py,
> test/test_addons.py,
> test/test_package_info.py:
> - fix unit tests
> * setup.py:
> - fix build error when merging authors list
> * merged lp:~gary-lasker/software-center/pyflakes-fixes, no
> user visible changes, only code cleanup
> * po/software-center.pot:
> - refresh .pot file
>
> [ Matthew McGowan ]
> * data/ui/gtk3/css/softwarecenter.css,
> softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
> - fix grey addon label, only pkgname should be grey
> (LP: #838607)
> * softwarecenter/ui/gtk3/widgets/description.py,
> softwarecenter/utils.py,
> test/test_description_norm.py:
> - description formatting improvements, update unit test
> * data/ui/gtk3/css/softwarecenter.css,
> softwarecenter/ui/gtk3/widgets/cellrenderers.py:
> - use css to set border-radius of cellrenderer button
> * softwarecenter/ui/gtk3/views/appview.py:
> - disable appcount display at the bottom of list views
> for now to allow keyboard scrolling to work (LP: #830258)
> * lp:~mmcg069/software-center/lobby-tweaks:
> - restore tile borders but disable the checkerboard
> rendering, color tweaks and other improvements to the
> title area visuals
> * merge lp:~mmcg069/software-center/image-data-cleanup:
> - cleanup unused image files (LP: #839736)
> * softwarecenter/ui/gtk3/panes/softwarepane.py:
> - fix doubled search results (LP: #840235)
> * softwarecenter/ui/gtk3/app.py:
> - fix "Copy Web Link" feature (LP: #830291)
>
> [ Andrea Cimitan ]
> * softwarecenter/ui/gtk3/widgets/symbolic_icons.py:
> - Fix blurriness of toolbar icons, reduce shadow alpha level
>
> [ Gabor Kelemen ]
> * po/POTFILES.in:
> - additional i18n fixes (LP: #836346)
>
> [ Kiwinote ]
> * remove the old webkit ui
> * remove the need for dummy-screenshot-ubuntu.png (LP: #837223)
> * data/ui/gtk3/SoftwareCenter.ui,
> softwarecenter/ui/gtk3/app.py:
> - make all the accelerators work again (LP: #640426, LP: #660050,
> LP...

Read more...

sebikul (sebikul) wrote :

Still happening, but on a different line. See attachment

Josep Bigorra (josepbuntu) wrote :

I hope you fix it cuz its a very important bug that may cause a lot of
people to dont upgrade to oneiric...

2011/9/9 sebikul <email address hidden>

> Still happening, but on a different line. See attachment
>
> ** Attachment added: "software-center.log"
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/834233/+attachment/2378586/+files/software-center.log
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (835683).
> https://bugs.launchpad.net/bugs/834233
>
> Title:
> submit_review_gtk3.py crashed with UnicodeDecodeError in
> _setup_details(): 'ascii' codec can't decode byte 0xd0 in position 0:
> ordinal not in range(128)
>
> Status in “software-center” package in Ubuntu:
> Fix Released
>
> Bug description:
> косяк
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: software-center 4.1.19
> ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
> Uname: Linux 3.0.0-9-generic i686
> Architecture: i386
> Date: Fri Aug 26 04:09:42 2011
> ExecutablePath: /usr/share/software-center/submit_review_gtk3.py
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python
> /usr/share/software-center/submit_review_gtk3.py --pkgname remmina
> --iconname remmina --parent-xid None --version 0.9.3-2 --origin ubuntu
> --datadir /usr/share/software-center/ --appname Remmina\ Remote\ Desktop\
> Client
> ProcEnviron:
> PATH=(custom, no user)
> LANG=ru_RU.UTF-8
> SHELL=/bin/bash
> PythonArgs: ['/usr/share/software-center/submit_review_gtk3.py',
> '--pkgname', 'remmina', '--iconname', 'remmina', '--parent-xid', 'None',
> '--version', '0.9.3-2', '--origin', 'ubuntu', '--datadir',
> '/usr/share/software-center/', '--appname', 'Remmina Remote Desktop Client']
> SourcePackage: software-center
> Title: submit_review_gtk3.py crashed with UnicodeDecodeError in
> _setup_details(): 'ascii' codec can't decode byte 0xd0 in position 0:
> ordinal not in range(128)
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/834233/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers