"Cancel" at purchase sign-on leaves you at "OpenID failed" screen

Bug #833898 reported by Matthew Paul Thomas on 2011-08-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

software-center-gtk3 trunk r2209, Ubuntu Ocelot

(Until one of the real for-purchase items is published for Ocelot, you will need to be a member of the commercial QA team to reproduce this bug.)

1. Go to the screen for one of the for-purchase items, and choose "Buy".
2. At the sign-on screen, click "Cancel".

What happens:
* You end up at an HTML screen saying "OpenID failed" "Authentication cancelled".
* A traceback:
------------
Traceback (most recent call last):
  File "/home/mpt/hacking/software-center/softwarecenter/ui/gtk3/panes/availablepane.py", line 219, in on_purchase_cancelled_by_user
    self._click_appdetails_view()
AttributeError: 'AvailablePane' object has no attribute '_click_appdetails_view'
Traceback (most recent call last):
  File "/home/mpt/hacking/software-center/softwarecenter/ui/gtk3/views/purchaseview.py", line 192, in _on_title_changed
    self._process_json(title)
  File "/home/mpt/hacking/software-center/softwarecenter/ui/gtk3/views/purchaseview.py", line 223, in _process_json
    self._block_wk_handlers()
  File "/home/mpt/hacking/software-center/softwarecenter/ui/gtk3/views/purchaseview.py", line 254, in _block_wk_handlers
    self.wk.webkit.handler_block_by_func(self._on_new_window)
TypeError: nothing connected to <bound method PurchaseView._on_new_window of <PurchaseView object at 0x2545370 (softwarecenter+ui+gtk3+views+purchaseview+PurchaseView at 0x24ead50)>>
------------

What should happen: You are returned to the software item screen.

Matthew Paul Thomas (mpt) wrote :
Changed in software-center (Ubuntu):
importance: Undecided → Medium
description: updated
Matthew Paul Thomas (mpt) wrote :

I thought this was a duplicate of bug 615359 (which I didn't see because it isn't filed against the software-center package). But if the problem is entirely server-side, then why is there a traceback?

Michael Vogt (mvo) on 2011-08-25
Changed in software-center (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.20

---------------
software-center (4.1.20) oneiric; urgency=low

  [ Michael Vogt ]
  * softwarecenter/ui/gtk3/views/purchaseview.py:
    - fix crash in cancel a purchase (LP: #833898)
  * softwarecenter/db/enquire.py:
    - add database locking to avoid thread issues
  * softwarecenter/db/enquire.py:
    - fix crash by copy.copy(filter), provide a custom copy
      method instead this fixes random crash in the lobby

  [ Kiwinote ]
  * display category on the tile
 -- Michael Vogt <email address hidden> Thu, 25 Aug 2011 20:51:11 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments