[FFE] Switch default UI from gtk2 to gtk3

Bug #830901 reported by Michael Vogt on 2011-08-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

This is a request to change the default UI of software-center from gtk2 to gtk3.

The gtk3 version is part of the software-center package since version 4.1.12 and people can (and do) launch it via the software-center-gtk3 commandline switch. I want to make it default in the desktop file now as well.

Technically all the features are already in oneiric and its "just" a UI change, but because its a pretty visible change
I still wanted to ensure that this is approved by the release team and on the radar.

Thanks!
 Michael

Martin Pitt (pitti) wrote :

This is by and large a completely new UI, and thus a very large change. Do you have an idea how many people have tested the GTK3 version so far? Does it have feature parity with the current one?

Asked the other way around, how much attention does the GTK2 UI still actually get? In particular, are any of the developers still testing it with the current pygobject in oneiric? (Cf. bug 829186 and bug 828751).

What about this large and animated banner, I thought it was just a demo? It does not look very professional, takes away a lot of screen space, and draws away attention due to it being animated.

It also still has some UI deficiencies like the toolbar looking really buggy in a light theme like Radiance, but as we are still before beta I wouldn't consider these small issues a blocker.

Matthew Paul Thomas (mpt) wrote :

I have been testing the GTK3 version heavily. This list is mostly GTK3-specific bugs reported by me and others, though it includes some that affect GTK2 as well: http://ur1.ca/4y6zr Many of them have been fixed already. Michael could judge this better than me, but at this point I think the number of new bugs in the GTK3 UI is comparable to the number of GTK2-specific bugs it will resolve.

As far as I know, the GTK3 UI does have feature parity, except that the OneConf plug-in has not been adapted for it, and apturl's "minver" syntax is not implemented (bug 828281). I believe the improvement in learnability outweighs that temporary loss.

The banners are obviously placeholders. Otto Greenslade will be working on initial proper banners. The slow switching between banners is intentional, equivalent to the slow switching between "Featured" items on the home screen in 4.x.

The navigation bar looking bad in Radiance is bug 828092.

Michael Vogt (mvo) wrote :

Hello, thanks for your comments.

It is indeed a large UI change. But its building on the gtk2 and backend foundations so while it looks radically different
its not a complete rewrite (but yes, a lot of churn). I don't have hard numbers on the amount of testing the gtk3 version got. But its part of the main s-c package since a ~2 weeks and OMG ubuntu featured it. So we do expect that quite a few people tested it.

As for the gtk2 UI. Its in maintenance mode, we don't add new features, we only fix straightforward bugs (and backport them to 4.0 when appropriate). But the testsuite is run against the gtk2 version so we do notice any breakage.

Martin Pitt (pitti) wrote :

I'd like to see the banner go away (or at least become radically smaller and less play-ish) before this gets the default.

Also, does this depend on pygobject 2.90 (as this is still blocked on fixing some ubuntuone bits), or does it work with 2.28 as well?

Michael Vogt (mvo) wrote :

Thanks Martin for the update. The design team works on a better banner now that should land today.

It does not need pygobject 2.90, it will work with both.

Michael Vogt (mvo) wrote :

I uploaded a new version 4.1.18 with a updated default banner.

Its still using the gtk2 version as default but it got a ton of fixes and improvements and it would be nice if that version could be considered for gtk3 by default. Just run software-center-gtk3 to test it on a current oneiric box.

Martin Pitt (pitti) wrote :

We discussed that in #u-release; it is a fairly large and risky change, but as we can revert it with a single line change (flip the default in the .desktop file), let's try this for beta-1, and revert if it causes too many regressions.

Changed in software-center (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.19

---------------
software-center (4.1.19) oneiric; urgency=low

  [ Kiwinote ]
  * data/piston-helpers/piston_get_reviews_helper.py:
    - get reviews for the base pkg, not the multiarch one
  * softwarecenter/ui/gtk3/widgets/buttons.py:
    - hand cursor for category tiles and subcategory tiles
    - make a price of '0.00' render as 'free'
  * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - remove function calls to set the color of the pkgstatusbar (LP: #833195)
    - render icons for addons correctly
  * softwarecenter/ui/gtk3/views/catview_gtk.py:
    - don't show unavailable or already installed apps in the 'new' tiles
    - align the subcat view
  * softwarecenter/ui/gtk3/widgets/exhibits.py:
    - only render paging dots if we have more than one

  [ Michael Vogt ]
  * softwarecenter/db/application.py:
    -ignore errors from incorrect utf8 (LP: #833534)
  * data/ubuntu-software-center.desktop.in:
    - set default UI to gtk3 (LP: #830901)
  * add new icon LP: #432552

  [ Matthew Paul Thomas ]
  * softwarecenter/ui/gtk3/widgets/exhibits.py:
    - tweak the default banner presentation (LP: #833169)
  * debian/control:
    - improve package description
  * lp:~mpt/software-center/text-tweaks:
    - text fixes

  [ Matthew McGowan ]
  * lp:~mmcg069/software-center/small-fixes:
    - fix available pane channels
    - change nonapp filter

  [ Jacob Johan Edwards ]
  * lp:~j-johan-edwards/software-center/toolbar-quick-hack:
    - comment out hatching from USC custom toolbar.
 -- Michael Vogt <email address hidden> Thu, 25 Aug 2011 17:36:48 +0200

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers