software-center crashed with TypeError: Couldn't find conversion for foreign struct 'cairo.Context'

Bug #829067 reported by Richey Ward on 2011-08-18
196
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Ubuntu Software Center
Invalid
Undecided
Unassigned
software-center (Ubuntu)
High
Gary Lasker
Oneiric
High
Gary Lasker

Bug Description

Crashes on startup

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.15
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
Architecture: amd64
Date: Thu Aug 18 23:14:49 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/share/software-center/software-center-gtk3
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center-gtk3
PythonArgs: ['/usr/bin/software-center-gtk3']
SourcePackage: software-center
Title: software-center-gtk3 crashed with TypeError: Couldn't find conversion for foreign struct 'cairo.Context'
Traceback: TypeError: Couldn't find conversion for foreign struct 'cairo.Context'
UpgradeStatus: Upgraded to oneiric on 2011-08-18 (0 days ago)
UserGroups: admin

Richey Ward (richey-ward) wrote :
tags: removed: need-duplicate-check
Changed in software-center (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in software-center (Ubuntu):
importance: Undecided → Medium
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Is this still crashing in the current version of oneiric ?

Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
Harmen H (harmenh) wrote :

Yes. Today I upgraded the system to test it again. When I start software-center after starting up the computer I see on top of the software center screen a black/grey background and the search field. Below a loading circle which disappears after a while and a scrollbar on the right. Everything else is blank. After some loading (but I don't know if this is important) the software center crashes as described above.

(a few weeks ago i had almost the same problem, but then I only saw a search field on top of a blank window before crashing)

Changed in software-center (Ubuntu):
status: Incomplete → Confirmed
Yotam Benshalom (benshalom) wrote :

It seems that this problem is resolved after removing some deprecated cairo libraries. I do not remember exactly which ones, unfortunately, but they were used by the package "bum", which I uninstalled :)

Dmitry Shachnev (mitya57) wrote :

@Yotam:
The only cairo-related package in "bum" dependencies is libcairo-perl, and removing it doesn't help. Please check your history in synaptic, maybe you'll find a package there.

Also, when launching Software Center, I get these traces:
2011-09-18 18:11:37,426 - softwarecenter.db.history_impl.apthistory - ERROR - failed to load cache
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/history_impl/apthistory.py", line 79, in _rescan
    self._transactions = pickle.load(open(p))
ImportError: No module named apt.apthistory

...
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/historypane.py", line 317, in render_cell_icon
    pkg = store.get_value(iter, self.COL_PKG)
  File "/usr/lib/python2.7/dist-packages/gi/types.py", line 43, in function
    return info.invoke(*args, **kwargs)
ValueError: 2 not in range -2147483648 to 2147483647

Changed in software-center:
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

This bug still exists and collects duplicates. Can you please raise the importance?
A recent traceback: https://launchpadlibrarian.net/81717754/Traceback.txt.

tags: added: regression-release
removed: amd64
Juho Teperi (deraen) wrote :

Installing python-gobject-cairo fixes this for me. Something should depend on that?

Indeed, installing python-gobject-cairo solved the issue.

On Sun, Oct 2, 2011 at 20:13, Juho Teperi <email address hidden> wrote:

> Installing python-gobject-cairo fixes this for me. Something should
> depend on that?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (846906).
> https://bugs.launchpad.net/bugs/829067
>
> Title:
> software-center-gtk3 crashed with TypeError: Couldn't find conversion
> for foreign struct 'cairo.Context'
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/software-center/+bug/829067/+subscriptions
>

Sergey Basalaev (sbasalaev) wrote :

Confirming, this fixes the issue. Another missing dependency might be gir1.2-launchpad-integration-3.0 - without it I get an error "root - ERROR - Could not find any typelib for LaunchpadIntegration"

summary: - software-center-gtk3 crashed with TypeError: Couldn't find conversion
- for foreign struct 'cairo.Context'
+ software-center crashed with TypeError: Couldn't find conversion for
+ foreign struct 'cairo.Context'
Changed in software-center:
status: Confirmed → Invalid
Gary Lasker (gary-lasker) wrote :

Set as invalid for software-store only (we do not track bugs there). This bug remains open for the software-center package.

Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
status: Confirmed → In Progress
importance: Medium → High
Changed in software-center (Ubuntu Oneiric):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.0.1

---------------
software-center (5.0.1) oneiric; urgency=low

  [ Michael Vogt ]
  * softwarecenter/ui/gtk3/widgets/reviews.py:
    - Fix i18n bug in the error string for the reviews. This
      adds two new strings for a rare error message in the UI that
      was previously not translatable. Thanks to David Planella
  * softwarecenter/db/database.py:
    - when adding a new database (e.g. on reinstall-previous purchases)
      trigger a "reopen" to ensure that the db docids are reinitialized
  * apt-xapian-index-plugin/software-center.py:
    - do not crash if a apt.Package.candidate has no url (LP: #819907)
  * softwarecenter/ui/gtk3/views/catview_gtk.py:
    - only show the frame with new apps if we actually have information
      about new applications (LP: #862382)

  [ Robert Roth ]
  * softwarecenter/ui/gtk3/widgets/apptreeview.py:
    - fix crash in clear_model() (LP: #863233)

  [ Gary Lasker ]
  * debian/control:
    - add dependency on python-gobject-cairo to prevent crash
      at startup (LP: #829067)
  * softwarecenter/db/application.py,
    softwarecenter/db/update.py,
    softwarecenter/distro/Ubuntu.py,
    softwarecenter/enums.py:
    - display the correct license type for commercial apps as
      specified via the software-center-agent (LP: #864706)

  [ Matthew McGowan ]
  * lp:~mmcg069/software-center/bug855666:
    - add missing linewrap (LP: #855666)
  * lp:~mmcg069/software-center/bug858639 :
    - fix crash when data can not be parsed from the remote reviews server
      LP: #858639
 -- Michael Vogt <email address hidden> Wed, 05 Oct 2011 11:24:05 +0200

Changed in software-center (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers