Scroll position isn't remembered going Back/Forward to "Installed"

Bug #828887 reported by Matthew Paul Thomas on 2011-08-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Gary Lasker

Bug Description

software-center 5.1.13.2, The Precise Pangolin

1. Launch USC.
2. Click "Installed".
3. Expand a category or two to get a nice list of installed items showing.
4. Scroll to the bottom of the "Installed" screen, or anywhere in the middle.
5. Click Back.
6. Click Forward.

What happens: You see a spinner and have to wait for the view to refresh, and then you find that you are returned to the top of the "Installed" screen and all of the categories that you had expanded have been collapsed. You feel annoyed.

What should happen: There is no spinner and no wait. You are returned directly to the same spot in the "Installed" screen that you left it at. Any categories that you had expanded should still be expanded.

The same problem does not occur for the "All Software" or "History" screens, just the "Installed" screen.

<https://wiki.ubuntu.com/SoftwareCenter#navigation-back-forward>: "Each item in the history should remember its scroll position ... These attributes should persist if you return to the screen using Back/Forward navigation, but not if you navigate to the screen any other way."

See also bug 852763, the equivalent problem in search results.

Related branches

Changed in software-center (Ubuntu):
importance: Undecided → Low
Michael Vogt (mvo) on 2011-08-19
Changed in software-center (Ubuntu):
status: New → Confirmed
description: updated
Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
status: Confirmed → In Progress
summary: - [GTK3] Scroll position isn't remembered going Back/Forward to
- "Installed"
+ Scroll position isn't remembered going Back/Forward to "Installed"
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.14

---------------
software-center (5.1.14) precise; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/lp962580:
    - add locking to the expunge helper process to fix bugs that are triggered
      if multiple expunge cache processes are run (LP: #962580)
  * lp:~mvo/software-center/cache-refresh-glitch:
    - ensure that we get a full refresh if a pkg was not available before
      show_app is called
  * lp:~mvo/software-center/lp940482:
    - fix crash if the debfile does not return proper utf8 for the
      description (LP: #940482)
  * lp:~mvo/software-center/lp966514:
    - properly handle network disconnect conditions with the Ubuntu
      SSO dialog (LP: #966514)
  * lp:~mvo/software-center/lp966879:
    - fix for crashes in the installed view treeview (LP: #966879,
      LP: #950899)
  * lp:~mvo/software-center/lp846204:
    - fix ValueError crashes in get_iter due to invalid tree paths
      (LP: #846204)
  * lp:~mvo/software-center/lp964433:
    - disconnect the model from the view before calling set_from_matches
      (LP: #964433)
  * lp:~mvo/software-center/treeview-keep-state-on-db-cache-change:
   - restore the state of the installed view treeview when the
     the db or cache changes, such as on an app install or remove
  * lp:~mvo/software-center/946393:
   - fix installing multiple apps when in a custom list view (LP: #946393)
  * lp:~mvo/software-center/lp969050:
   - disconnect the view when the model is cleared to avoid a furry of
     cursor_changed signals as the rows get removed (LP: #969050)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/installed-pane-refresh:
    - avoid rebuilding the treeview in the installedpane if its not
      required (LP: #828887)
  * lp:~gary-lasker/software-center/fix-crash-lp967036:
    - Small branch to fix a crash due to a UnicodeDecodeError when accessing
      the short description for H/W requirements (LP: #967036)
  * lp:~gary-lasker/software-center/fix-crash-lp935930:
    - fix a crash due to a UnicodeDecodeError (LP: #935930)
 -- Michael Vogt <email address hidden> Fri, 30 Mar 2012 18:00:50 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers