software-center crashed with TypeError in show_available_packages(): this constructor takes no arguments

Bug #824692 reported by Bilal Shahid on 2011-08-11
364
This bug affects 81 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Kiwinote

Bug Description

happens on opening a .deb file

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.13
ProcVersionSignature: Ubuntu 3.0.0-8.10-generic 3.0.1
Uname: Linux 3.0.0-8-generic i686
Architecture: i386
Date: Thu Aug 11 22:44:11 2011
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110807)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center /home/username/Downloads/google-chrome-stable_current_i386.deb
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center', '/home/username/Downloads/google-chrome-stable_current_i386.deb']
SourcePackage: software-center
Title: software-center crashed with TypeError in show_available_packages(): this constructor takes no arguments
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Bilal Shahid (s9iper1) wrote :
visibility: private → public
Changed in software-center (Ubuntu):
status: New → Confirmed
Aslam Muhammad (aslamckra) wrote :

Same thing happened to me also

Tim Lunn (darkxst) wrote :

I am also experiencing this issue, trying to install a 3rd party .deb

Tim Lunn (darkxst) wrote :

There appears to be a problem in this file

/usr/share/software-center/softwarecenter/db/__init__.py

see attached patch, which fixes the problem, can now load .deb files ok atleast.

tags: added: patch
Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
SarahSlean (yoda4) wrote :

I am also experience this issue , trying install jitsi_1.0-beta1-nightly.build.3593_i386 in download the link

Bilal Shahid (s9iper1) wrote :

when ever i download any thing from the software center the software center crash...every single time

Omer Akram (om26er) wrote :

Also confirmed with software-center 4.1.14

Changed in software-center (Ubuntu):
importance: Undecided → High
status: Incomplete → Confirmed
description: updated
Omer Akram (om26er) wrote :

Tim, I tried your patch and it does not fix the issue for me.

Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
Tim Lunn (darkxst) wrote :

sorry my bad, this is what appears to have happened.

If software-center is already running then it will work when you run 'software-center /path/package.deb'.

If there is not an instance of software-center already running, then the above command fails.

the import of DebFileApplication fails, so DebFileApplication becomes an empty class without a constructor.

Kiwinote (kiwinote) on 2011-08-16
Changed in software-center (Ubuntu):
assignee: Gary Lasker (gary-lasker) → Kiwinote (kiwinote)
status: Confirmed → Fix Committed
Laudeci Oliveira (laudeci) wrote :

Same here installing mysql-workbench-gpl-5.2.34
 The same worked on 11.04

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.15

---------------
software-center (4.1.15) oneiric; urgency=low

  [ Michael Vogt ]
  * software-center-gtk3, software-center:
    - fix PYTHONPATH when running from a local repo
    - add "--dummy-backend" option start will start a fake
      aptdaemon in a private dbus for interactive testing of the
      installation/removal
  * softwarecenter/backend/spawn_helper.py:
    - make "--debug-filter softwarecenter.backend.spawn_helper"
      more useful
    - ensure that the io source is removed after any pending
      reads are flushed
  * software-center:
    - fix startup with no PYTHONPATH
  * softwarecenter/gmenusearch.py:
    - port to use gir1.2-gmenu-3.0
  * softwarecenter/ui/{gtk,gtk3}/views/appdetailsview_gtk.py:
    - updated for gir1.2-gmenu-3.0
  * softwarecenter/ui/gtk3/widgets/exhibits.py:
    - show hand cursor if the exhibit has package_names
  * setup.py:
    - fix AUTHORS file merging

  [ Matthew McGowan ]
  * lp:~mmcg069/software-center/appdetails-tweaks:
    - add a pretty frame around the thumbnail in the detailsview.
  * lp:~mmcg069/software-center/bugfix-823233:
    - fix so that markup is actually rendered by the submit_label
      when submitting usefulness (LP: #823233)
  * fix the annoying ascii codec error, #823363
  * add some checks to ensure the exhibits list contains exhibits and
    then some further checks within _render_exhbit_at_cursor to ensure
    the cursor is within the bounds of the exhibits_list

  [ Kiwinote ]
  * data/ui/gtk3/SoftwareCenter.ui,
    softwarecenter/ui/gtk3/app.py:
    - few more tweaks to the about dialog
  * softwarecenter/db/application.py:
    - import version_compare on demand to make deb files work (LP: #824692)
  * softwarecenter/ui/gtk/appview.py,
    softwarecenter/ui/gtk3/widgets/cellrenderers.py:
    - fix listviews in rtl setups (pango reverses LEFT and RIGHT itself)
  * softwarecenter/ui/gtk3/app.py:
    - fix rtl mode for testing
  * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - correctly show/hide website button
 -- Michael Vogt <email address hidden> Wed, 17 Aug 2011 10:21:25 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Tim Lunn (darkxst) wrote :

this fix has exposed another bug in the handling of .deb files.

see Bug #829138

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers