History doesn't show whether time was AM or PM

Bug #813803 reported by Thibault D on 2011-07-20
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Nicolas Delvaux

Bug Description

software-center 4.0.4, Ubuntu 11.04

This might be an issue only for a few countries/languages.

1) Open software-centre (for me in the french version)
2) Install any package during the afternoon (let's say between 12:01 and 23:59)
3) Check the time of installation in the historic

If you've installed something at 23:30, then you should see either "11:30pm" or "23:30", but you get "11:30".
So, is it "am" or "pm" ?

You can see the screenshot here-attached.

... and in the same time, the message should say "supprimé à 23:30" instead of "supprimé 23:30".

<https://wiki.ubuntu.com/SoftwareCenter#history>: "The time should be of the form “4:08 PM”."

ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic i686
Architecture: i386
CheckboxSubmission: 9e6554c36969a101b9e0e3075c8ffbe0
CheckboxSystem: b8f3ec504801f13fc208edb5c785b099
Date: Wed Jul 20 23:31:37 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Thibault D (thibdrev) wrote :
summary: - Bad time format displayed the historic
+ Bad time format displayed in the historic
description: updated
Changed in software-center (Ubuntu):
status: New → Triaged
importance: Undecided → Low
summary: - Bad time format displayed in the historic
+ History doesn't show whether time was AM or PM
Thibault D (thibdrev) wrote :

For information : the bug is still valid for software-center 4.1.21 (Ubuntu 11.10 Beta 1)

Nicolas Delvaux (malizor) wrote :

Still valid on an up-to-date Ubuntu 11.10, for all languages.
This looks like a paper-cut to me. Am I wrong?

Nicolas Delvaux (malizor) wrote :

In fact it was a translation issue, caused by a misplaced comment in the software-center sources.

The comment intended to explain to translators how to change the time-format string was not extracted, which led to poor translations.

I fixed the French one[1] and I filled a merge request to fix the extraction of this comment.

[1] https://translations.launchpad.net/software-center/trunk/+pots/software-center/fr/+translate?batch=10&show=all&search=%25I%3A%25M+%25p

Changed in software-center (Ubuntu):
assignee: nobody → Nicolas Delvaux (malizor)
Michael Vogt (mvo) wrote :

Thanks a lot for the fix. I commited it to bzr and it will be part of the next upload.

Changed in software-center (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.1

---------------
software-center (5.1.1) precise; urgency=low

  [ Matthew McGowan ]
  * fix the rtl rendering of the "more label arrow"
  * lp:~mmcg069/software-center/multi-screenshot-gallery:
    - add support for multiple screenshots for the main archive

  [ Nicolas Delvaux ]
  * lp:~malizor/software-center/fix-lp813803:
    - Time format in historypane: The translators comment was not
      extracted, which led to poor translations (eg. as reported
      in bug LP: #813803)

  [ Gabor Kelemen ]
  * lp:~kelemeng/software-center/bug875306:
    - Add translator comment: Free means Gratis, as it is used as price.
      LP: #875306

  [ Sebastian Heinlein ]
  * lp:~glatzor/software-center/portability:
    - improve portability

  [ Michael Vogt ]
  * more portability fixes
 -- Michael Vogt <email address hidden> Mon, 07 Nov 2011 14:58:40 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers