Editing a review isn't instantly update in the users view

Bug #807010 reported by Dave Morley on 2011-07-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Aaron Peachey

Bug Description

Steps to reproduce:
From trunk

1. run the testing script
2. select a package
3. click on leave a review
4. login
5. make the review and submit it
6. click on edit
7. make an edit and submit it

Note that the edit is not instantly updated as you would expect clicking on edit again shows the new version.

8. restart USC now the new edit is visible

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-center 4.0.3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Jul 7 15:28:14 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110423)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Dave Morley (davmor2) wrote :
Gary Lasker (gary-lasker) wrote :

Some relevant information from Aaron Peachey on this issue from bug 719843:

---

I think I know what this issue is, not that the update doesn't occur, but moreso that the old copy stays in the screen even though the new one is added.
I wrote the modify and delete code a long time ago and since then we received pagination support in USC which meant we needed to tweak the existing submit/flag/vote code to prevent duplication after a successful submit (see bug LP: #794060) with the new way the callback works after pagination was added.

I don't think we have made the same tweak on the modify/delete code since then so it's probably using the old callback method and 'duplicating' the reviews by not removing the original before inserting the updated version.
There are some helper functions in the UIReview class that should make this very simple to fix.

Aaron Peachey (aaronp) on 2011-07-08
Changed in software-center (Ubuntu):
status: New → In Progress
assignee: nobody → Aaron Peachey (aaronp)
Aaron Peachey (aaronp) wrote :

fixed in branch attached, proposed for merging to trunk

Gary Lasker (gary-lasker) wrote :

Nice fix, thank you Aaron! Merged.

Changed in software-center (Ubuntu):
importance: Undecided → Medium
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.9

---------------
software-center (4.1.9) oneiric; urgency=low

  [ Michael Vogt ]
  * data/ui/*.ui:
    - move into data/ui/gtk preparing the gtk3 merge
  * utils/piston-helpers/*.py:
    - return exitcode 1 on expections
  * softwarecenter/backend/scagent.py:
    - properly copy when building the command

  [ Gary Lasker ]
  * merge lp:~evfool/software-center/nonetworkfixes to fix menu
    item network state bugs, many thanks to Robert Roth
    (LP: #802919, LP: #802920)
  * softwarecenter/ui/gtk/appview.py:
    - fix crash on a network change event (LP: #804414)
  * softwarecenter/ui/gtk/appdetailsview_gtk.py:
    - gracefully handle AttributeError from zeitgeist pending
      fix in zeitgeist itself, fixes crasher (LP: #807282)
  * softwarecenter/ui/gtk/appdetailsview_gtk.py,
    softwarecenter/utils.py:
    - fix crash when searching gmenu paths (LP: #793024)

  [ Aaron Peachey ]
  * softwarecenter/backend/reviews.py,
    softwarecenter/backend/spawn_helper.py:
    - correct modify/delete UI callback behaviour with
      new spawn helper and pagination code (LP: #807010)
    - fix submit_usefulness and report_abuse callbacks
      to work with the new spawn_helper and pagination code
 -- Michael Vogt <email address hidden> Wed, 13 Jul 2011 16:11:35 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Dave Morley (davmor2) wrote :

Just to confirm this is now working for both edit and delete.

Aaron Peachey (aaronp) wrote :

Great! Thanks Dave

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers