Dragging off "Yes" / "No" doesn't cancel the click

Bug #796640 reported by Matthew Paul Thomas on 2011-06-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Robert Roth

Bug Description

Binary package hint: software-center

Ubuntu Software Center 4.0.3, Ubuntu 11.04

1. Find a review that you think is helpful or unhelpful.
2. Mouse down on the "Yes" or "No" link accordingly.
3. Drag away from the link.
4. Mouse up.

What happens: The recommendation is submitted anyway.
What should happen: Nothing.

Related branches

Can see that this is happening, so confirming.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in software-center (Ubuntu):
status: New → Confirmed
Robert Roth (evfool) on 2011-06-22
Changed in software-center (Ubuntu):
importance: Undecided → Low
Robert Roth (evfool) on 2011-06-22
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Robert Roth (evfool)
status: Triaged → In Progress
Gary Lasker (gary-lasker) wrote :

Nice fix, thanks a lot Robert!

Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.7

---------------
software-center (4.1.7) oneiric; urgency=low

  [ Aaron Peachey ]
  * Add fake-review API that can be used for GUI testing and
    automatic testing without actually hitting the network.
    Can be enabled with the SOFTWARE_CENTER_FAKE_REVIEW_API=1
    environment
  * add support to remove/modify reviews, this requires the
    new rnrserver in production

  [ Michael Vogt ]
  * merged lp:~aaronp/software-center/tests, many thanks
  * merged lp:~mvo/software-center/piston-sc-agent:
    This move the SoftwareCenterAgent support from restfulclient
    to piston-mini-client and adds a new SpawnHelper abstraction.
    It also adds a new SOFTWARE_CENTER_AGENT_INCLUDE_QA environment
    to get apps in QA (if you are in the right group)
  * remove get_http_proxy_string_from_gconf and remove python-gconf
    dependency

  [ Gary Lasker ]
  * merge lp:~evfool/software-center/smallfixes to fix up mouse click
    handling for LinkButton, many thanks to Robert Roth (LP: #796640)
  * merge lp:~mterry/software-center/drop-deja-dup courtesy Michael
    Terry, removes deja-dup from the featured apps list since it has
    been promoted to main
  * merge lp:~evfool/software-center/fixnavigation, fixes navigation
    error when searching (LP: #801114)
  * softwarecenter/ui/gtk/appview.py:
    - fix phantom install button in for purchase listview (LP: #801512)
  * softwarecenter/db/update.py:
    - add support for custom desktop key X-Ubuntu-Software-Center-Name
      for USC-specific display names (LP: #801197)
  * softwarecenter/ui/gtk/appdetailsview_gtk.py:
    - don't start the indeterminate progress bar for purchase
      transactions until after the authentication dialog is closed
      (LP: #725181)
  * softwarecenter/utils.py,
    softwarecenter/backend/aptd.py,
    test/test_software_channels.py:
    - obfuscate private ppa details in the error log output and in
      the error dialog itself, add corresponding unit test

  [ Steve Langasek ]
  * debian/control: point Vcs-Bzr field at the right branch.
 -- Michael Vogt <email address hidden> Mon, 04 Jul 2011 07:41:36 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers