Cannot review software updated from PPA

Bug #792017 reported by Andres Muniz on 2011-06-02
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: software-center

In natty, using software center 4.0.4 rating software is generally working, but when you try to write a review a software which has been updated/installed from a PPA, submitting the review just fails, without specifying the reason why you can not submit the review, something like "You can only rate software installed from the official ubuntu repositories".

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-center 4.0.4
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Architecture: i386
Date: Thu Jun 2 20:27:28 2011
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=es_ES:en
 LANG=en_GB.UTF-8
 LC_MESSAGES=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center

Andres Muniz (andresmp) wrote :
Andres Muniz (andresmp) wrote :

Hi,

I have seen that somebody else was able to rate it. Could it be related to the fact that I have the PPA for Gwyddion?

Robert Roth (evfool) wrote :

Thanks for helping us to improve Ubuntu. Could you please try to run software-center from a terminal and attach its output displayed when the review fails?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in software-center (Ubuntu):
status: New → Incomplete
Andres Muniz (andresmp) wrote :

Hi Robert, thank you for getting back to me.

Note, I have since changed from standard ubuntu natty to xubuntu natty. should be the same?
I have the ppa of gwyddion installed if it is of any difference.

Attached is the output as requested.

More details:
The process I went through is as follows:
opened software-centre through terminal
searched gwyd
more info button
I see it has two ratings (other people have rated)
be the first to rate(it seems it should be be the first to rate in spanish?)
write comment no more than 10 lines
write title no more than 10 words
click rate.
Gave me error of failing to rate
Looked at terminal and I see it tried to fetch gwibber
search and install gwibber. add facebook, twitter and identi.ca
repeat rating process this time selecting share in all gwibber accounts.
same fail. "fail to send review" (in spanish: fallo al enviar resena)

Robert Roth (evfool) wrote :

Thank you Andres: it doesn't matter if you've changed from natty to xubuntu natty, software-center is the same. Thanks for mentioning that you have gwyddion installed from the PPA, that's an important detail of a bug, just like the trace you just have attached. I have tried rating another software (indicator-weather) from a PPA and I have got the same stacktrace, so we can make this bug a bit more specific, like Reviewing software from PPA doesn't work and doesn't tell the user that he can not rate software from PPA's, only from the official repos. I am updating the title and description with these details.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in software-center (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Low
summary: - Cannot rate Gwyddion package
+ Cannot review software updated from PPA
description: updated

I don't know if it helps, but this is the trace that I get when submitting a review of DeadBeef (trace is from startup to submission)

software-center
/usr/share/software-center/softwarecenter/app.py:1191: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.window_main.show_all()
2011-09-16 11:46:05,045 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/pymodules/python2.7/zeitgeist/client.py', 367, 'reconnect_monitors')'
2011-09-16 11:46:05,044 - zeitgeist.client - INFO - Reconnected to Zeitgeist engine...
/usr/share/software-center/softwarecenter/SimpleGtkbuilderApp.py:50: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  gtk.main()
2011-09-16 11:46:07,948 - softwarecenter.app - INFO - software-center-agent finished with status 1
/usr/share/software-center/softwarecenter/view/channelpane.py:85: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.notebook.set_current_page(self.PAGE_APPLIST)
/usr/share/software-center/softwarecenter/apt/aptcache.py:179: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  gtk.main_iteration()
ERROR:root:submit_review
Traceback (most recent call last):
  File "/usr/share/software-center/submit_review.py", line 271, in _submit_reviews_if_pending
    res = self.rnrclient.submit_review(review=piston_review)
  File "/usr/lib/python2.7/dist-packages/piston_mini_client/validators.py", line 61, in wrapper
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/piston_mini_client/__init__.py", line 90, in wrapper
    body = func(self, *args, **kwargs)
  File "/usr/share/software-center/softwarecenter/backend/rnrclient_pristine.py", line 131, in submit_review
    scheme=AUTHENTICATED_API_SCHEME, content_type='application/json')
  File "/usr/lib/python2.7/dist-packages/piston_mini_client/__init__.py", line 255, in _post
    headers=headers, scheme=scheme)
  File "/usr/lib/python2.7/dist-packages/piston_mini_client/__init__.py", line 329, in _request
    body = handler.handle(response, body)
  File "/usr/lib/python2.7/dist-packages/piston_mini_client/failhandlers.py", line 59, in handle
    raise APIError('%s: %s' % (response['status'], response), body)
APIError: 400: {'status': '400', 'content-length': '101', 'via': '1.1 reviews.ubuntu.com', 'vary': 'Authorization,Accept-Encoding', 'server': 'Apache/2.2.14 (Ubuntu)', 'connection': 'close', 'date': 'Fri, 16 Sep 2011 10:47:51 GMT', 'content-type': 'text/html; charset=utf-8'}

tags: added: client-server
dino99 (9d9) wrote :

natty have reached EOL now ; closing that report. Feel free to report against a newer version if needed, with ubuntu-bug

Changed in software-center (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions