'Submitting now...' spinner runs forever on usefulness submit fails

Bug #790450 reported by Aaron Peachey on 2011-05-31
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Aaron Peachey
Natty
Medium
Unassigned

Bug Description

Binary package hint: software-center

When submitting a usefulness vote and the rnrclient encounters an exception, the spinner with text 'Submitting now...' does not change to the expected error notification, and instead continues to spin forever, leading the user to believe that the submission is still in progress (or that there is a problem, but they have no way to tell what it is).
User is unable to cancel or re-submit usefulness on that review until restarting the application.
Issue exists in version 4.02.

STR: Press Yes/No to submit usefulness for a review and immediately disconnect your network connection (i.e. before the submission is able to complete).

Propose this is fixed for natty.

Related branches

Aaron Peachey (aaronp) on 2011-05-31
Changed in software-center (Ubuntu):
status: New → In Progress
assignee: nobody → Aaron Peachey (aaronp)
Michael Vogt (mvo) on 2011-05-31
Changed in software-center (Ubuntu Natty):
status: New → In Progress
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
importance: Undecided → Low
Changed in software-center (Ubuntu Natty):
importance: Undecided → Low
Changed in software-center (Ubuntu):
importance: Low → Medium
Changed in software-center (Ubuntu Natty):
importance: Low → Medium
Martin Pitt (pitti) wrote :

Please fix in oneiric ASAP, so that this can progress to natty-updates.

Changed in software-center (Ubuntu Natty):
status: In Progress → Fix Committed
tags: added: verification-needed

Accepted software-center into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Gary Lasker (gary-lasker) wrote :

This bug was fixed in Oneiric with the release of software-center version 4.1.5:

software-center (4.1.5) oneiric; urgency=low

  [ Gary Lasker ]
  * data/ui/SoftwareCenter.ui,
    softwarecenter/app.py,
    softwarecenter/enums.py,
    softwarecenter/ui/gtk/appview.py:
    - implement history navigation using the mouse back/forward
      buttons (LP: #782661)
  * softwarecenter/app.py,
    softwarecenter/backend/channel.py,
    softwarecenter/ui/gtk/appdetailsview_gtk.py,
    softwarecenter/ui/gtk/catview_gtk.py,
    softwarecenter/ui/gtk/channelpane.py,
    softwarecenter/ui/gtk/softwarepane.py:
    - refactor/simplify the view background overlay code and
      fix issue where the background image is sometimes not
      rendered for installed channels (LP: #724724)
   * setup.py:
    - update script name to x2go_helper.py for happier build

  [ Michael Vogt ]
  * merged lp:~alexeftimie/software-center/debian-small-fixes, many
    thanks!
  * merged lp:~alexeftimie/software-center/backend-refactor to
    cleanup more code
  * merged lp:~weblive-dev/software-center/weblive-x2go, many thanks
    to Stephane Graber!
  * merged lp:~aaronp/software-center/lp790450-for-4.0, many thanks
    to Aaron Peachey
  * add support for X-AppInstall-Icon-Url (and also icon_url from
    SoftwareCenterAgent)
  * merged lp:~mterry/software-center/network-manager-0.9, many
    thanks to Michael Terry
  * merged lp:~mmcg069/software-center/enum-style-idea, this cleans
    up the the enum code handling, many thanks!
  * integration work on the qml branch
  * merged lp:~evfool/software-center/fix793896, many thanks to
    Robert Roth, LP: #793896

  [ Olivier Tilloy ]
  * add QML ui frontend (lp:~osomon/software-center/qml)

 -- Michael Vogt <email address hidden> Tue, 07 Jun 2011 15:36:46 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Gary Lasker (gary-lasker) wrote :

I have verified that this bug is fixed in software-center version 4.0.4 in natty-proposed. Thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.0.4

---------------
software-center (4.0.4) natty-proposed; urgency=low

  [ Aaron Peachey ]
  * utils/submit_review.py:
    - ensure error message shows if usefulness submit
      fails (LP: #790450)
  * softwarecenter/view/widgets/reviews.py:
    - fix disappearing usefulness UI on clicking 'OK' after error
  * softwarecenter/db/reviews.py,
    softwarecenter/view/appdetailsview_gtk.py,
    softwarecenter/view/widgets/reviews.py:
    - fix duplication of reviews after user has submitted
      usefulness or flagged a review (LP: #794060)

  [ Gary Lasker ]
  * softwarecenter/app.py,
    softwarecenter/view/softwarepane.py:
    - fix issue where the background image for installed channels
      details view is not consistently rendered (LP: #724724)
 -- Michael Vogt <email address hidden> Fri, 10 Jun 2011 18:22:41 +0200

Changed in software-center (Ubuntu Natty):
status: Fix Committed → Fix Released
Bob Kline (bkline) wrote :

Looks like we have a regression, because this bug is back in trusty (14.04). I've waited several hours for the "Submitting now ..." spinner to stop (see attached screen shot) and I'm not hopeful. :-) Unfortunately, the interface for changing the status of this issue appears to be broken or disabled.

Bob Kline (bkline) wrote :

It's worse than I thought. I finally gave up and closed down Ubuntu Software Center, or at least I thought I did, but every minute or so it reappeared, obscuring the windows for the foreground apps I was working in. I did some more digging, and found this using ps:

6131 ? Sl 0:00 /usr/bin/python /usr/share/software-center/submit_usefulness_gtk3.py --review-id 85959 --is-useful 1 --parent-xid --datadir /usr/share/software-center/
 6142 ? Sl 0:00 /usr/bin/python /usr/share/software-center/submit_usefulness_gtk3.py --review-id 89278 --is-useful 1 --parent-xid --datadir /usr/share/software-center/

So apparently the script to submit the feedback is hanging and making a zombie out of USC (not a zombie in the sense we use that term in the UNIX world, but the image for the USC window isn't going away until I kill those two processes, so that's what I'm going to do. Since I can't re-open this ticket, am I going to have to file a new bug report?

Bob Kline (bkline) wrote :

Killing the python submit usefulness scripts didn't do the trick. It really was a zombie, which I had to kill using sudo.

Bob Kline (bkline) wrote :

Even that didn't work. I'm going to have to reboot the system, as this USC image still keeps popping up.

Bob Kline (bkline) wrote :

Reboot wasn't necessary. I was able to launch USC from the applications menu and then close it again, and it appears to have cleaned up after itself this time (at least I haven't seen the phantom image since then, and during the time which has elapsed I would have seen it multiple times, so I've got my fingers crossed).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments