String-freeze exception for scary third party vendor string

Bug #789596 reported by Sense Egbert Hofstede on 2011-05-28
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Michael Vogt
Precise
Medium
Michael Vogt

Bug Description

software-center 4.0.2, Ubuntu 11.04

In the overview of software in Software Centre that does not come from the officially supported archives, a warning text is shown informing the user that this particular piece of software is not supported by Canonical, but that updates MAY be delivered by the community/a third-party. It is not only shown for software from community-maintained archvies or for PPAs, but also for software that is on sale.

Although this message is factually correct, it is a scary message. Users might get the impression that by default no updates should be expected, but if you are lucky something might be done. Especially for paid applications, this might not be very encouraging towards users.

I would suggest to change the warning from a negative formulation to a positive: updates for this software are provided by X. Not Canonical, etc.

Furthermore, this message is also shown for packages from the Canonical Partner archive--which is maintained by Canonical, AFAI. Is that desired behaviour?

See also bug 579855 and bug 659993.

Sense Egbert Hofstede (sense) wrote :
c0nsaw (c0nsaw) wrote :

Thank you for taking the time to report this issue and helping to make Ubuntu better.

Examining the information you have given us, this does not appear to be a bug report so I am closing it and converting it to a question in the support tracker.

c0nsaw

Changed in software-center (Ubuntu):
status: New → Invalid
Matthew Paul Thomas (mpt) wrote :

I don't understand how this isn't a bug report. It identifies a perceived problem, and suggests a solution. Reopening.

Matthew Paul Thomas (mpt) wrote :

The text is:
- "Canonical provides critical updates for Empathy Internet Messaging until October 2012." (Main)
- "Canonical does not provide updates for Adobe Reader 9. Some updates may be provided by the third party vendor." (Partner)
- "Canonical does not provide updates for Padre. Some updates may be provided by the Ubuntu community." (Universe, Multiverse, Restricted)

The use case for the text is a business person or IT manager considering using a particular package, and wanting to know if there's someone accountable to issue updates for problems with that package.

The MOTUs do great work, but they're not accountable in that way. So I think the "may be provided" text is not just correct, but also appropriately discouraging for that use case. It is also difficult for vendors to get updates into Partner, so "may be provided" is probably appropriate there too, though less so. Do you have other suggestions for how we could word those?

Once the developer portal is publicly available, application developers will be accountable for updates, and it will be easier for them to issue updates. So we'll be able to say, positively, "Updates for this software *are* provided by the vendor" or similar.

Changed in software-center (Ubuntu):
status: Invalid → New
Sense Egbert Hofstede (sense) wrote :

I think that a positive formulation of the sentence would be best. It should name only those who are accountable, not parties that are not. If Canonical or MOTUs are not involved, don't name them. People might skip over the little word 'not'.

"Updates for SOFTWARE are provided by VENDOR" does seem the best solution for third-party apps to me. I would name the vendor explicitly, so interested managers can check the company's track record without having to look somewhere else on the overview page.

For the community maintained packages something like "SOFTWARE is made available in Ubuntu by the community. Updates may or may not be provided."

The case of PPAs or unknown third-party repositories is a bit difficult, since you may have overlap with earlier versions in official repositories and you cannot easily refer to the name of the repository. However, we can say that Google's official Chrome repository or that of Dropbox are more thrustworthy than myfunrepo.example.com/ubuntu would be. It would be good to say "Updates for Google Chrome are (may be?) provided by Google." That's a reasonable statement. However, for <myfunrepo.example.com/ubuntu> I'd say something like "SOFTWARE is made available for Ubuntu by a third-party. Updates may be made available."

Furthermore, Canonical will provide updates for Empathy Internet Messaging after October 2012, but in a different release of Ubuntu. Shouldn't that be reflected in the string as well, or would that be too much information?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Phil Norisez (norisezp) wrote :

Please also see the discussion in https://answers.launchpad.net/ubuntu/+source/synaptic/+question/177603 for additional justifications.

tags: added: client-server
description: updated
Michael Vogt (mvo) wrote :

Assigning to mpt to get a better string. Once its there I'm happy to fix this.

Changed in software-center (Ubuntu Precise):
importance: Undecided → Medium
assignee: nobody → Matthew Paul Thomas (mpt)
Matthew Paul Thomas (mpt) wrote :

Specification updated. <https://wiki.ubuntu.com/SoftwareCenter?action=diff&rev2=608&rev1=607>
------------
The text “Updates provided:” followed by text of the form “by Canonical until 2012-03-06”, “none (Canonical updates ended 2011-10-26)”, “by the Ubuntu development community”, or “by the vendor”.
------------

Changed in software-center (Ubuntu Precise):
assignee: Matthew Paul Thomas (mpt) → Michael Vogt (mvo)
status: Confirmed → Triaged
Michael Vogt (mvo) wrote :

From irc:
<mpt> mvo, ok, a short-term fix for just that string is "Provided by the vendor"

summary: - "Canonical doesn't provide updates" is a scary message, especially for
- customers
+ String-freeze exception
summary: - String-freeze exception
+ String-freeze exception for scary third party vendor string
Scott Kitterman (kitterman) wrote :

OK. What about the part of this with not distinguishing between Universe and PPA packages? There is a lot of effort that's gone into distinguishing them in the LP U/I for good reason. It seems very wrong to lump them together here.

Changed in software-center (Ubuntu Precise):
status: Triaged → In Progress
Matthew Paul Thomas (mpt) wrote :

Sorry, my previous design was incomplete. I've now specified "Updates provided:" text more granularly for each software source, including Universe ("by the Ubuntu development community") and PPAs ("by the developer"). <https://wiki.ubuntu.com/SoftwareCenter#updates-text> Michael and Gary may choose only to change the worst of them for the purpose of this string freeze break, though.

I think that's pretty good. The only comment I would have is that there are
plenty of non-Canonical people working on packages in Main (including post-
release updates) so perhaps the longer description for Main/Restricted should
be something like "Canonical and the rest of the Ubuntu community" instead of
just Canonical.

Michael Vogt (mvo) wrote :

B1;2802;0cOn Thu, Mar 08, 2012 at 06:38:14PM -0000, Scott Kitterman wrote:
> I think that's pretty good. The only comment I would have is that there are
> plenty of non-Canonical people working on packages in Main (including post-
> release updates) so perhaps the longer description for Main/Restricted should
> be something like "Canonical and the rest of the Ubuntu community" instead of
> just Canonical.

Thanks! I will raise that with Mpt and get his feedback. Its a good
point.

Cheers,
 Michael

Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package software-center - 5.1.12

---------------
software-center (5.1.12) precise; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/webcam-string-fix:
  - small fix to support the debtagshw updated tags for hardware::camera
    (split into webcam,digicam now)
  * lp:~mvo/software-center/trivial-nm-state-override:
    - support the SOFTWARE_CENTER_NET_CONNECTED environment value to
      force the connected state as a stopgap workaround for bug 911706
  * lp:~mvo/software-center/lp941361:
    - adds a general make_string_from_list() helper to build (somewhat)
      i18n friendly human readable strings easily (LP: #941361)
  * lp:~mvo/software-center/expunge-cache:
    - merge os.nice() addition
  * lp:~mvo/software-center/lp789596:
    - better (less scary) string for updates from third-party
      venders (LP: #789596)
  * lp:~mvo/software-center/fix-refresh-of-whats-new:
    - fix missing refresh of the what's new content on a database
      reopen so that new content from the agent appears as soon
      as it finishes the update
  * lp:~mvo/software-center/review-fixes:
    - ensure ui is correctly updated after submitting/modifying review
  * lp:~mvo/software-center/simulate-slow-network:
    - add a small helper to simulate a slow network connection to
      see if we have hidden latencies in the UI when the network
      is (really) slow
  * lp:~mvo/software-center/top-rated-refresh:
    - ensure that the top-rated apps are refreshed when we have new data
  * lp:~mvo/software-center/apptreeview-tweaks:
    - fix 'load_range" errors when navigating the installed view
      (LP: #913675), and do some nice needed refactoring/cleanup

  [ Anthony Lenton ]
  * lp:~elachuni/software-center/dont-store:
    - consolidate Ubunty SSO logins to use "Ubuntu Software Center", fixes
      inconsistent UI and storing of two keys in they keyring, as well as
      being prompted to log in twice the first time that you review an app
  * lp:~elachuni/software-center/pep8-test,
    lp:~elachuni/software-center/pep8-test-part2,
    lp:~elachuni/software-center/pep8-test-part3,
    lp:~elachuni/software-center/pep8-test-part4:
    - add a unit test to check code statically for pep8 compliance and update
      more and more of the code to meet it

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/fix-crash-lp944875:
    - Fix an intermittent crash that can happen if the installed view pane
      has not been built yet when a call to show the spinner is made as a
      result of a refresh (LP: #944875)
  * lp:~gary-lasker/software-center/list-view-icon-coordinates-lp947624:
    - This branch adds support for providing the correct icon size and
      on-screen coordinates values in the Unity launcher integration dbus
      call when an installation is initiated via the list view
      (LP: #947624)
  * lp:~gary-lasker/software-center/enable-published-date-unit-test:
    - unit test change only, enable the published-date unit test that was
      disabled pending deployment of support on the staging server

  [ Natalia Bidart ]
  * lp:~nataliabidart/software-center/one-auth:
    - use consistently the same app name for eve...

Read more...

Changed in software-center (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions