fails to install commercial app after purchase

Bug #785149 reported by Selene ToyKeeper on 2011-05-19
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: software-center

This may be a dupe of Bug 785117, but has additional symptoms and relates to non-free apps. The short version is that I bought a commercial app, the payment finished (in state "captured"), and nothing was actually installed.

The first time I used Software Center (earlier today), I attempted to purchase World of Goo. I was mostly just testing a theory about how it handles VAT, so I went through the purchase process, checked my bank records, and was happy to see that the amount charged is what I expected. But a few minutes later, it occurred to me... after purchasing, shouldn't it, like, install something? The GUI simply returned me to the detail page for World of Goo, complete with a "Buy" button ready to accept another purchase. It never asked for my sudo password or otherwise appeared to do anything after completing the payment.

So, I asked dpkg to list anything matching 'goo' and got nothing. /var/lib/dpkg/info/ had nothing new in the past 24 hours, and I didn't see anything new in /etc/apt/ either, such as the location of a private PPA. I found nothing relevant in syslog and no obvious log files in my home directory either. I then thought to check the shell I launched the app from, and found it looping a message:

  ** Message: console message: https://software-center.ubuntu.com/subscriptions/25352/checkout_complete/ @18:

I tried going to this address in my browser. What I see there is a round animated progress image, followed by:

  Processing your request for “World of Goo”…
  Subscription complete (end state)

Every few seconds, the animation stops and the page reloads.

I also see a record of successful payment here: https://pay.ubuntu.com/payment/

Further back in the xterm scrollback, I found some other errors, which I think were triggered when I clicked file -> reinstall previously purchases. I'll attach that below. My scrollback didn't go far enough to see the actual purchase though.

I can try this again to get more data, but since it costs money to run more tests I would first like to know what extra data to collect. Perhaps running under strace or something for more details? At the very least, I'll log the full output in the parent shell, since the relevant bit seems to have scrolled off my 1024-line buffer before I could see it.

Selene ToyKeeper (toykeeper) wrote :
Gary Lasker (gary-lasker) wrote :

Hi Selene, we recently had a fix on the server side for bug 783896, and I am wondering if maybe that problem was possibly also causing the problem you report in this bug. When you get a chance, could you please open Software Center and select "File"->"Reinstall Previous Purchases..."? Hopefully World of Goo will appear in the list, since by all appearances you completed the transaction and so that app should be available for you.

Please let us know what happens. Many thanks!

Selene ToyKeeper (toykeeper) wrote :

I can see previous purchases now, but when I attempt to install one, this happens:

2011-06-01 09:05:43,504 - softwarecenter.backend - INFO - add_repo_add_key_and_install_app() 'private-ppa.launchpad.net/commercial-ppa-uploaders/world-of-goo/ubuntu natty main' '1024R/75254D99' 'World of Goo (already purchased),worldofgoo'
2011-06-01 09:05:43,523 - softwarecenter.backend - ERROR - authenticate_for_purchase failed
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/backend/aptd.py", line 392, in add_repo_add_key_and_install_app
    yield self.authenticate_for_purchase()
  File "/usr/lib/python2.7/dist-packages/defer/__init__.py", line 472, in _inline_callbacks
    result = gen.throw(result.type, result.value, result.traceback)
  File "/usr/share/software-center/softwarecenter/backend/aptd.py", line 366, in authenticate_for_purchase
    yield policykit1.check_authorization_by_name(name, action, flags=flags)
AuthorizationFailed: org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name': ':1.934'}): org.debian.apt.install-purchased-packages

This could perhaps be related to me not using a gnome or unity desktop. I've just got a window manager with no desktop environment.

tags: added: client-server
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu):
importance: Undecided → High

I can confirm this. I was using another window manager and getting the same error about policykit (was using i3). When I switched back to unity the software installed correctly.

Audun Gangsto (audun-m) wrote :

I can confirm that this is still an issue

Ken Tewnion (kentewnion) wrote :

TO: Mr. William Grant (or other personnel)

When trying to purchase "Kasino" ($0.00) an OOPS error was displayed and "Kasino" was NOT installed even though I was
emailed with 'thanks for purchasing'. The same situation happened when last trying to purchase issues #58 and #67 of
Full Circle Magazine.... so the situation is NOT resolved.

Here is the OOPS #...

OOPS-ID OOPS- 475b04b2e19aeefc7267647b396363ba

I hope this is helpful and the problem can be resolved. Please advise so I might be able to make future "purchases".

Respectfully submitted,

<email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers